Permalink
Browse files

Use new invocations blacken task

  • Loading branch information...
bitprophet committed May 23, 2018
1 parent 9d5d351 commit bde17e841b2b561bbfde287e404a956fb8469e73
Showing with 2 additions and 5 deletions.
  1. +2 −5 .travis.yml
View
@@ -38,8 +38,6 @@ install:
# TODO: follow invoke and split it up a bit so we're not pulling down
# conflicting or unused-by-travis deps?
- pip install -r dev-requirements.txt
# Black, only on 3.6, it literally cannot install on anything else =/
- "if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then pip install black==18.4a4; fi"
# Sanity test of the Invoke layer, if that's busted everything is
- inv --list
# Sanity test of Fabric itself
@@ -51,9 +49,8 @@ before_script:
- inv travis.make-sshable
script:
# Fast syntax check failures for more rapid feedback to submitters
# (Python 3.6 only; it doesn't run on anything less and there's no
# point running it multiple times either.)
- "if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then inv blacken --check; fi"
# (Travis-oriented metatask that version checks Python, installs, runs.)
- inv travis.blacken
# I have this in my git pre-push hook, but contributors probably don't
- flake8
# Execute full test suite + coverage, as the new sudo-capable user

0 comments on commit bde17e8

Please sign in to comment.