Browse files

Bump public Paramiko requirement for file-like object transfer feature

  • Loading branch information...
1 parent 54a1a8f commit ee1efc7f88c4861b59837caea1e5450149ded6e7 @bitprophet bitprophet committed Nov 30, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1
@@ -37,7 +37,7 @@
tests_require=['nose', 'fudge<1.0'],
- install_requires=['paramiko>=1.9.0'],
+ install_requires=['paramiko>=1.10.0'],
'console_scripts': [
'fab = fabric.main:main',

4 comments on commit ee1efc7


The pip-installation of fabric-dev is failing since this change as pypi doesn't contain version 1.10.0 for paramiko:

Downloading/unpacking paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76))
  Could not find a version that satisfies the requirement paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76)) (from versions: )
No distributions matching the version for paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76))

Perhaps this version was recently removed from Pypi? Is it worth opening an issue for this?


Fabric member

Dev versions of Fabric will depend on dev versions of Paramiko too -- so just install Paramiko from git and problem solved :)


Most likely this is being caused by not using proper sorting for versions. A version >=1.10.0 is available (in fact several are).

This is a bug. People want to use stable if they don't absolutely have to use dev.

Please sign in to comment.