Skip to content
This repository
Browse code

Bump public Paramiko requirement for file-like object transfer feature

commit ee1efc7f88c4861b59837caea1e5450149ded6e7 1 parent 54a1a8f
Jeff Forcier bitprophet authored

Showing 1 changed file with 1 addition and 1 deletion. Show diff stats Hide diff stats

  1. +1 1  setup.py
2  setup.py
@@ -37,7 +37,7 @@
37 37 packages=find_packages(),
38 38 test_suite='nose.collector',
39 39 tests_require=['nose', 'fudge<1.0'],
40   - install_requires=['paramiko>=1.9.0'],
  40 + install_requires=['paramiko>=1.10.0'],
41 41 entry_points={
42 42 'console_scripts': [
43 43 'fab = fabric.main:main',

4 comments on commit ee1efc7

Julien Phalip

The pip-installation of fabric-dev is failing since this change as pypi doesn't contain version 1.10.0 for paramiko: http://pypi.python.org/pypi/paramiko

Downloading/unpacking paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76))
  Could not find a version that satisfies the requirement paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76)) (from versions: )
No distributions matching the version for paramiko>=1.10.0 (from Fabric->-r requirements.txt (line 76))

Perhaps this version was recently removed from Pypi? Is it worth opening an issue for this?

Thanks!

Jeff Forcier
Owner

Dev versions of Fabric will depend on dev versions of Paramiko too -- so just install Paramiko from git and problem solved :)

Tyler Brock

Most likely this is being caused by not using proper sorting for versions. A version >=1.10.0 is available (in fact several are).

This is a bug. People want to use stable if they don't absolutely have to use dev.

Please sign in to comment.
Something went wrong with that request. Please try again.