Skip to content
Permalink
Browse files

Upgrade dependencies (#6614)

* Upgrade dependencies

* Upgrade a couple missed deps

* Run Prettier over codebase
  • Loading branch information...
ianschmitz authored and iansu committed Mar 12, 2019
1 parent 5b77280 commit 3c9c21a2858a3397cceca51b3a299878b29c5c7b
@@ -19,24 +19,24 @@
"compile:lockfile": "node tasks/compile-lockfile.js"
},
"devDependencies": {
"eslint": "5.12.0",
"eslint": "5.15.1",
"execa": "1.0.0",
"fs-extra": "^7.0.0",
"get-port": "^4.0.0",
"globby": "^8.0.1",
"husky": "1.0.0-rc.15",
"fs-extra": "^7.0.1",
"get-port": "^4.2.0",
"globby": "^9.1.0",
"husky": "^1.3.1",
"jest": "^23.6.0",
"lerna": "2.9.1",
"lerna-changelog": "^0.7.0",
"lerna-changelog": "~0.8.2",
"lint-staged": "^8.0.4",
"meow": "^5.0.0",
"multimatch": "^2.1.0",
"prettier": "1.15.2",
"puppeteer": "^1.8.0",
"strip-ansi": "^4.0.0",
"multimatch": "^3.0.0",
"prettier": "1.16.4",
"puppeteer": "^1.13.0",
"strip-ansi": "^5.1.0",
"svg-term-cli": "^2.1.1",
"tempy": "^0.2.1",
"wait-for-localhost": "2.0.1"
"wait-for-localhost": "^3.1.0"
},
"husky": {
"hooks": {
@@ -17,21 +17,21 @@
"test.js"
],
"dependencies": {
"@babel/core": "7.2.2",
"@babel/plugin-proposal-class-properties": "7.3.0",
"@babel/core": "7.3.4",
"@babel/plugin-proposal-class-properties": "7.3.4",
"@babel/plugin-proposal-decorators": "7.3.0",
"@babel/plugin-proposal-object-rest-spread": "7.3.2",
"@babel/plugin-proposal-object-rest-spread": "7.3.4",
"@babel/plugin-syntax-dynamic-import": "7.2.0",
"@babel/plugin-transform-classes": "7.2.2",
"@babel/plugin-transform-classes": "7.3.4",
"@babel/plugin-transform-destructuring": "7.3.2",
"@babel/plugin-transform-flow-strip-types": "7.2.3",
"@babel/plugin-transform-flow-strip-types": "7.3.4",
"@babel/plugin-transform-react-constant-elements": "7.2.0",
"@babel/plugin-transform-react-display-name": "7.2.0",
"@babel/plugin-transform-runtime": "7.2.0",
"@babel/preset-env": "7.3.1",
"@babel/plugin-transform-runtime": "7.3.4",
"@babel/preset-env": "7.3.4",
"@babel/preset-react": "7.0.0",
"@babel/preset-typescript": "7.1.0",
"@babel/runtime": "7.3.1",
"@babel/preset-typescript": "7.3.3",
"@babel/runtime": "7.3.4",
"babel-loader": "8.0.5",
"babel-plugin-dynamic-import-node": "2.2.0",
"babel-plugin-macros": "2.5.0",
@@ -135,7 +135,6 @@ if (program.info) {
npmGlobalPackages: ['create-react-app'],
},
{
clipboard: false,
duplicates: true,
showNotFound: true,
}
@@ -8,7 +8,7 @@
"repository": "facebook/create-react-app",
"license": "MIT",
"engines": {
"node": ">=4"
"node": ">=8"
},
"bugs": {
"url": "https://github.com/facebook/create-react-app/issues"
@@ -22,13 +22,13 @@
"create-react-app": "./index.js"
},
"dependencies": {
"chalk": "1.1.3",
"commander": "2.18.0",
"cross-spawn": "4.0.2",
"envinfo": "5.11.1",
"fs-extra": "5.0.0",
"chalk": "2.4.2",
"commander": "2.19.0",
"cross-spawn": "6.0.5",
"envinfo": "7.1.0",
"fs-extra": "7.0.1",
"hyperquest": "2.1.3",
"semver": "5.5.1",
"semver": "5.6.0",
"tar-pack": "3.4.1",
"tmp": "0.0.33",
"validate-npm-package-name": "3.0.0"
@@ -16,7 +16,7 @@
"jsdom.js"
],
"dependencies": {
"core-js": "2.6.4",
"core-js": "2.6.5",
"object-assign": "4.1.1",
"promise": "8.0.2",
"raf": "3.4.1",
@@ -48,7 +48,7 @@
"dependencies": {
"@babel/code-frame": "7.0.0",
"address": "1.0.3",
"browserslist": "4.4.1",
"browserslist": "4.4.2",
"chalk": "2.4.2",
"cross-spawn": "6.0.5",
"detect-port-alt": "1.1.6",
@@ -60,7 +60,7 @@
"globby": "8.0.2",
"gzip-size": "5.0.0",
"immer": "1.10.0",
"inquirer": "6.2.1",
"inquirer": "6.2.2",
"is-root": "2.0.0",
"loader-utils": "1.2.3",
"opn": "5.4.0",
@@ -69,7 +69,7 @@
"recursive-readdir": "2.2.2",
"shell-quote": "1.6.1",
"sockjs-client": "1.3.0",
"strip-ansi": "5.0.0",
"strip-ansi": "5.1.0",
"text-table": "0.2.0"
},
"devDependencies": {
@@ -31,37 +31,37 @@
],
"devDependencies": {
"@babel/code-frame": "7.0.0",
"@babel/core": "7.2.2",
"@babel/core": "7.3.4",
"anser": "1.4.8",
"babel-core": "7.0.0-bridge.0",
"babel-eslint": "9.0.0",
"babel-eslint": "10.0.1",
"babel-jest": "23.6.0",
"babel-loader": "8.0.5",
"babel-preset-react-app": "^7.0.2",
"chalk": "^2.4.2",
"chokidar": "^2.0.2",
"chokidar": "^2.1.2",
"cross-env": "5.2.0",
"eslint": "5.12.0",
"eslint": "5.15.1",
"eslint-config-react-app": "^3.0.8",
"eslint-plugin-flowtype": "2.50.1",
"eslint-plugin-import": "2.14.0",
"eslint-plugin-jsx-a11y": "6.1.2",
"eslint-plugin-react": "7.12.3",
"eslint-plugin-import": "2.16.0",
"eslint-plugin-jsx-a11y": "6.2.1",
"eslint-plugin-react": "7.12.4",
"flow-bin": "^0.63.1",
"html-entities": "1.2.1",
"jest": "23.6.0",
"jest-fetch-mock": "1.6.6",
"object-assign": "4.1.1",
"promise": "8.0.2",
"raw-loader": "^0.5.1",
"react": "^16.3.2",
"raw-loader": "^1.0.0",
"react": "^16.8.4",
"react-app-polyfill": "^0.2.2",
"react-dom": "^16.3.2",
"rimraf": "^2.6.2",
"react-dom": "^16.8.4",
"rimraf": "^2.6.3",
"settle-promise": "1.0.0",
"source-map": "0.5.6",
"terser-webpack-plugin": "1.2.1",
"webpack": "^4.8.1"
"terser-webpack-plugin": "1.2.3",
"webpack": "^4.29.6"
},
"jest": {
"setupFiles": [
@@ -24,27 +24,27 @@
},
"types": "./lib/react-app.d.ts",
"dependencies": {
"@babel/core": "7.2.2",
"@babel/core": "7.3.4",
"@svgr/webpack": "4.1.0",
"babel-core": "7.0.0-bridge.0",
"babel-eslint": "9.0.0",
"babel-eslint": "10.0.1",
"babel-jest": "23.6.0",
"babel-loader": "8.0.5",
"babel-plugin-named-asset-import": "^0.3.1",
"babel-preset-react-app": "^7.0.2",
"bfj": "6.1.1",
"case-sensitive-paths-webpack-plugin": "2.2.0",
"css-loader": "1.0.0",
"dotenv": "6.0.0",
"css-loader": "2.1.1",
"dotenv": "6.2.0",
"dotenv-expand": "4.2.0",
"eslint": "5.12.0",
"eslint": "5.15.1",
"eslint-config-react-app": "^3.0.8",
"eslint-loader": "2.1.1",
"eslint-loader": "2.1.2",
"eslint-plugin-flowtype": "2.50.1",
"eslint-plugin-import": "2.14.0",
"eslint-plugin-jsx-a11y": "6.1.2",
"eslint-plugin-import": "2.16.0",
"eslint-plugin-jsx-a11y": "6.2.1",
"eslint-plugin-react": "7.12.4",
"file-loader": "2.0.0",
"file-loader": "3.0.1",
"fs-extra": "7.0.1",
"html-webpack-plugin": "4.0.0-beta.5",
"identity-obj-proxy": "3.0.0",
@@ -57,26 +57,26 @@
"pnp-webpack-plugin": "1.2.1",
"postcss-flexbugs-fixes": "4.1.0",
"postcss-loader": "3.0.0",
"postcss-preset-env": "6.5.0",
"postcss-preset-env": "6.6.0",
"postcss-safe-parser": "4.0.1",
"react-app-polyfill": "^0.2.2",
"react-dev-utils": "^8.0.0",
"resolve": "1.10.0",
"sass-loader": "7.1.0",
"style-loader": "0.23.1",
"terser-webpack-plugin": "1.2.2",
"terser-webpack-plugin": "1.2.3",
"url-loader": "1.1.2",
"webpack": "4.28.3",
"webpack": "4.29.6",
"webpack-dev-server": "3.2.1",
"webpack-manifest-plugin": "2.0.4",
"workbox-webpack-plugin": "3.6.3"
},
"devDependencies": {
"react": "^16.3.2",
"react-dom": "^16.3.2"
"react": "^16.8.4",
"react-dom": "^16.8.4"
},
"optionalDependencies": {
"fsevents": "1.2.4"
"fsevents": "1.2.7"
},
"browserslist": [
">0.2%",
@@ -22,7 +22,10 @@ function writeJson(fileName, object) {
}

function verifyNoTypeScript() {
const typescriptFiles = globby(['**/*.(ts|tsx)', '!**/node_modules', '!**/*.d.ts'], { cwd: paths.appSrc });
const typescriptFiles = globby(
['**/*.(ts|tsx)', '!**/node_modules', '!**/*.d.ts'],
{ cwd: paths.appSrc }
);
if (typescriptFiles.length > 0) {
console.warn(
chalk.yellow(
@@ -66,7 +66,7 @@ module.exports = class ReactScripts {
return await execaSafe('yarnpkg', ['start', '--smoke-test'], options);
}
const startProcess = execa('yarnpkg', ['start'], options);
await waitForLocalhost(port);
await waitForLocalhost({ port });
return {
port,
done() {
@@ -91,7 +91,7 @@ module.exports = class ReactScripts {
cwd: this.root,
}
);
await waitForLocalhost(port);
await waitForLocalhost({ port });
return {
port,
done() {

0 comments on commit 3c9c21a

Please sign in to comment.
You can’t perform that action at this time.