@fson fson released this Oct 22, 2016 · 887 commits to master since this release

Assets 2

0.7.0 (October 22, 2016)

Build Dependency (react-scripts)

  • Updates Jest to version 16.0, with an upgraded CLI, improved snapshot testing, new matchers and more. (@chase in #858)
  • Test setup file src/setupTests.js is now called after test framework initialization to support loading custom matchers. (@just-boris in #846)
  • Build command shows better instructions for deploying the app to GitHub Pages (@Janpot in #841)
  • Build command now generates an asset manifest with mappings from each filename to its final output filename. (@lukyth in #891)
  • Build command exits, if there are errors from UglifyJS (@pdillon in #859)
  • Eject output is more beautiful now. (@azakordonets in #769)
  • Fixes opening the app in a new tab in Chrome. (@unixdev in #831)
  • Fixes environment variables not being defined as normal properties of the process.env object. (@dvkndn in #807)
  • Fixes PostCSS autoprefixer not processing CSS files imported with CSS @import statements. (@nhunzaker in #929)

ESLint Config (eslint-config-react-app)

  • Adds import/no-webpack-loader-syntax rule that forbids using custom Webpack specific syntax to specify Webpack loaders in import statements. (@fson in #803)
  • react/react-in-jsx-scope rule ("React must be in scope") is now an error. (@gaearon in #822)
  • no-unused-expressions rule now allows the use of short circuit and ternary expressions. (@cannona in #724)

Babel Preset (babel-preset-react-app)

  • The preset now detects the Node.js version in test environment and disables unnecessary ES2015 transforms using using babel-preset-env. (@shubheksha in #878, @JeffreyATW in #927
    )
  • Fixes a duplicate dependency on babel-plugin-transform-regenerator. (@akofman in #864)

Utilities (react-dev-utils)

  • The error overlay is now disposed after fixing linting errors. (@jarlef in #856)
  • Adds support for Webpack 2 to webpackHotDevClient. (@michalkvasnicak in #840)

Global CLI (create-react-app)

  • Adds support for passing a scoped package name to the --scripts-version argument. (@pdillon in #826)
  • Fixes installing pre-release versions using a tarball URL with the --scripts-version argument. (@jihchi in #876)

Migrating from 0.6.1 to 0.7.0

You may optionally update the global command (it’s not required):

npm install -g create-react-app@0.6.0

Inside any created project that has not been ejected, run:

npm install --save-dev --save-exact react-scripts@0.7.0

Breaking Change in 0.7.0

Updating Snapshots

Jest 16 includes improvements to snapshot testing and changes to the snapshot format. If your project uses snapshot testing, you'll need to update the snapshot files. To update the snapshots, run:

npm test -- -u