Skip to content

@gaearon gaearon released this Jun 28, 2017 · 1409 commits to master since this release

1.0.8 (June 28, 2017)

🐛 Bug Fix

💅 Enhancement

  • react-scripts

  • babel-preset-react-app, react-dev-utils, react-scripts

  • create-react-app, react-scripts

  • react-dev-utils

    • #2637 Auto-detect Brackets editor from error overlay. (@petetnt)
    • #2552 Auto-detect running editor on Windows for error overlay. (@levrik)
    • #2622 Support opening PhpStorm for error overlay. (@miraage)
    • #2414 Support opening WebStorm 2017+ from error overlay. (@wirmar)
    • #2518 Warn when trying to run on port below 1024 without admin permissions under Linux/macOS. (@levrik)
    • #2385 Suggest just yarn build in output. (@gaearon)
  • create-react-app

📝 Documentation

🏠 Internal

Committers: 46

Migrating from 1.0.7 to 1.0.8

Inside any created project that has not been ejected, run:

npm install --save-dev --save-exact react-scripts@1.0.8

or

yarn add --dev --exact react-scripts@1.0.8

You may optionally then move react-scripts from devDependencies to dependencies since that’s how we’ll structure newly created projects. It is not necessary though.

If you previously used HTTPS=true environment variable in development, make sure you aren't affected by a now-fixed vulnerability in Webpack by visiting this page. You can read more about the vulnerability here.

If you left the service worker integration enabled and didn’t change how it works, you can replace src/registerServiceWorker.js with this updated version.

If you haven't changed the default CSS organization, you may want to apply this fix that makes index.css take precedence over App.css in your project.

Assets 2
You can’t perform that action at this time.