Skip to content
Compare
Choose a tag to compare

v5.0.0

Latest
@iansu iansu released this
· 6 commits to main since this release
9673858
Compare
Choose a tag to compare

v5.0.0 (2021-12-14)

Create React App 5.0 is a major release with several new features and the latest version of all major dependencies.

Thanks to all the maintainers and contributors who worked so hard on this release! 🙌

Highlights

  • webpack 5 (#11201)
  • Jest 27 (#11338)
  • ESLint 8 (#11375)
  • PostCSS 8 (#11121)
  • Fast Refresh improvements and bug fixes (#11105)
  • Support for Tailwind (#11717)
  • Improved package manager detection (#11322)
  • Unpinned all dependencies for better compatibility with other tools (#11474)
  • Dropped support for Node 10 and 12

Migrating from 4.0.x to 5.0.0

Inside any created project that has not been ejected, run:

npm install --save --save-exact react-scripts@5.0.0

or

yarn add --exact react-scripts@5.0.0

NOTE: You may need to delete your node_modules folder and reinstall your dependencies by running npm install (or yarn) if you encounter errors after upgrading.

If you previously ejected but now want to upgrade, one common solution is to find the commits where you ejected (and any subsequent commits changing the configuration), revert them, upgrade, and later optionally eject again. It’s also possible that the feature you ejected for is now supported out of the box.

Breaking Changes

Like any major release, react-scripts@5.0.0 contains a number of breaking changes. We expect that they won't affect every user, but we recommend you look over this section to see if something is relevant to you. If we missed something, please file a new issue.

Dropped support for Node 10 and 12

Node 10 reached End-of-Life in April 2021 and Node 12 will be End-of-Life in April 2022. Going forward we will only support the latest LTS release of Node.js.

Full Changelog

💥 Breaking Change

  • create-react-app
  • babel-preset-react-app, cra-template-typescript, cra-template, create-react-app, eslint-config-react-app, react-app-polyfill, react-dev-utils, react-error-overlay, react-scripts
  • eslint-config-react-app, react-error-overlay, react-scripts
  • react-scripts

🐛 Bug Fix

💅 Enhancement

  • react-scripts
    • #11717 Add support for Tailwind (@iansu)
    • #8227 Add source-map-loader for debugging into original source of node_modules libraries that contain sourcemaps (@justingrant)
    • #10499 Remove ESLint verification when opting-out (@mrmckeb)
  • eslint-config-react-app, react-error-overlay, react-scripts
  • create-react-app
  • react-dev-utils
    • #11105 fix: fast refresh stops on needed bail outs (@pmmmwh)
    • #10205 Update ModuleNotFoundPlugin to support Webpack 5 (@raix)
  • create-react-app, react-scripts

📝 Documentation

🏠 Internal

  • Other
  • create-react-app
  • babel-plugin-named-asset-import, babel-preset-react-app, confusing-browser-globals, create-react-app, react-app-polyfill, react-dev-utils, react-error-overlay, react-scripts
  • react-scripts
  • babel-plugin-named-asset-import, confusing-browser-globals, create-react-app, eslint-config-react-app, react-dev-utils, react-error-overlay, react-scripts
  • confusing-browser-globals, cra-template-typescript, cra-template, create-react-app
  • react-error-overlay, react-scripts
  • babel-preset-react-app, cra-template-typescript, cra-template, create-react-app, eslint-config-react-app, react-app-polyfill, react-dev-utils, react-error-overlay, react-scripts

🔨 Underlying Tools

  • react-dev-utils, react-scripts
  • react-scripts
  • babel-plugin-named-asset-import, confusing-browser-globals, create-react-app, react-dev-utils, react-error-overlay, react-scripts
    • #11338 Upgrade jest and related packages from 26.6.0 to 27.1.0 (@krreet)
  • eslint-config-react-app, react-error-overlay, react-scripts
  • babel-preset-react-app, react-dev-utils, react-error-overlay, react-scripts
  • react-dev-utils

Committers: 34