Skip to content
This repository

Android Source compatibility #243

Closed
wants to merge 1 commit into from

2 participants

Greg Espen Riskedal
Greg

Hi,
Android is Java 1.5 source compatible. Java 1.6 syntax is not supported. I pulled the new changes and saw that there was a stray Override around in the FBDialog class. This should just remove that and leave everything else alone :)

Thanks,
Greg

Greg

nvm sorry, my mistake.

Greg greggiacovelli closed this October 19, 2011
Espen Riskedal

Hi there, what was your mistake? I see the same issue (doesn't like the @Override) here and I'm not quite sure whats wrong.

Greg

Hi. I was working on an old build configuration. After talking with a colleague we realized that we could use java 1.6 compatible source with the sdk. That I am guessing is what the issue is on your end too. I have since upgraded my source compatibility to 1.6

Espen Riskedal

Jupp that was the issue, thanks :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Showing 1 unique commit by 1 author.

Oct 19, 2011
Fixing java 1.5 compatibility. Android Source is 1.5 compatible not 1.6 ba4d351
This page is out of date. Refresh to see the latest.
2  facebook/src/com/facebook/android/FbDialog.java
@@ -97,7 +97,7 @@ private void createCrossImage() {
97 97
         mCrossImage = new ImageView(getContext());
98 98
         // Dismiss the dialog when user click on the 'x'
99 99
         mCrossImage.setOnClickListener(new View.OnClickListener() {
100  
-            @Override
  100
+            
101 101
             public void onClick(View v) {
102 102
                 mListener.onCancel();
103 103
                 FbDialog.this.dismiss();
Commit_comment_tip

Tip: You can add notes to lines in a file. Hover to the left of a line to make a note

Something went wrong with that request. Please try again.