Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unsupported option specified! (unsafe.enable_getters_and_setters) #5594

Closed
dsherida opened this Issue Dec 30, 2017 · 12 comments

Comments

Projects
None yet
8 participants
@dsherida
Copy link

dsherida commented Dec 30, 2017

I'm getting the message .flowconfig:72 Unsupported option specified! (unsafe.enable_getters_and_setters) which is an option defined in the default .flowconfig while using create-react-native-app. This option is also specified in the Flow documentation so why am I getting this error?

@idiostruct

This comment has been minimized.

Copy link

idiostruct commented Dec 30, 2017

The unsafe.enable_getters_and_setters option was removed in 0.62.0; getters and setters are now enabled by default.

@aikar

This comment has been minimized.

Copy link

aikar commented Jan 7, 2018

That was a horrible idea to make everyones process fail hard instead of simply ignoring it or printing a deprecation warning.

@TrySound

This comment has been minimized.

Copy link
Collaborator

TrySound commented Jan 7, 2018

@aikar It's major release. Just read changelog.

marcelmokos added a commit to marcelmokos/eslint-config-with-prettier that referenced this issue Jan 7, 2018

@Aravindhan12

This comment has been minimized.

Copy link

Aravindhan12 commented Jan 10, 2018

I'm using flow bin version 0.63.1. Same error as @dsherida mentioned. Tried Downgrading to 0.62.0 but still the error remains the same.

While the yarn run flow command runs, following error appears,
.flowconfig:72 Unsupported option specified! (unsafe.enable_getters_and_setters)
error Command failed with exit code 8.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

@TrySound

This comment has been minimized.

Copy link
Collaborator

TrySound commented Jan 10, 2018

@Aravindhan12 Just remove that option from your config.

@Aravindhan12

This comment has been minimized.

Copy link

Aravindhan12 commented Jan 10, 2018

Finally I have fixed this by downgrading to Version 0.56.0.

@TrySound As you said I have removed the option. Now when the yarn run flow command runs, I received a error as Launching Flow server for Wrong version of Flow. The config specifies version ^0.56.0 but this is version 0.62.0 Could not start Flow server! error Command failed with exit code 78.

So I downgraded to 0.56.0. After that when I run the yarn run flow command, lot of errors was thrown in all the files with the message get/set properties not yet supported.

To fix it I have added the unsafe.enable_getters_and_setters in the .flowconfig (which I have removed earlier) and it works.

Hope this helps someone.

@TrySound

This comment has been minimized.

Copy link
Collaborator

TrySound commented Jan 10, 2018

@Aravindhan12 Downgrading doesn't help anybody. Kill all flow processes, remove version mark from config, remove unsafe.enable_getters_and_setters and run flow.

@TrySound

This comment has been minimized.

Copy link
Collaborator

TrySound commented Jan 10, 2018

@Aravindhan12 Also make sure you have latest versions installed globally and locally.

@Aravindhan12

This comment has been minimized.

Copy link

Aravindhan12 commented Jan 10, 2018

@TrySound Thanks for Pointing it out. I have removed the option and changed the version to 0.63.1 in my config file. Also upgraded to version 0.63.1 from 0.56.0. It's all works fine now.

Thanks for quick help.

@tintorres

This comment has been minimized.

Copy link

tintorres commented Feb 7, 2018

I can reproduce the issue in 0.64.0

It fix the issue when I downgraded to 0.57.3

@TrySound

This comment has been minimized.

Copy link
Collaborator

TrySound commented Feb 7, 2018

@tintorres If you look above you can find solution. Also you can read changelog

@kazeshini178

This comment has been minimized.

Copy link

kazeshini178 commented Jun 8, 2018

Think the flow docs should be updated to indicate this change. As they are currently misleading or just wrong (depending how you look at it)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.