Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

`jest-runner`: Ability to run with `--allow-natives-syntax` #8931

Closed
JounQin opened this issue Sep 9, 2019 · 1 comment
Closed

`jest-runner`: Ability to run with `--allow-natives-syntax` #8931

JounQin opened this issue Sep 9, 2019 · 1 comment

Comments

@JounQin
Copy link

@JounQin JounQin commented Sep 9, 2019

馃殌 Feature Proposal and Motivation

After @babel/core@^7.6.0, v8intrinsic is supported to be parsed via babel, but run it with node requires a flag --allow-natives-syntax.

We are able to test this feature by exec with that flag, example: https://github.com/rx-ts/babel-preset-proposal-typescript/blob/master/test/v8intrinsic.spec.ts#L20

The spec itself passes, but jest-runner is not able to recognize this syntax without --allow-natives-syntax flag.

We are not using node --allow-natives-syntax node_modules/.bin/jest here because it will be enabled for all test cases which is unexpected.

@JounQin JounQin changed the title Ability to run with `--allow-natives-syntax` `jest-runner`: Ability to run with `--allow-natives-syntax` Sep 9, 2019
@JounQin

This comment has been minimized.

Copy link
Author

@JounQin JounQin commented Sep 9, 2019

Seems be responsible to istanbul-lib-instrument.

@JounQin JounQin closed this Sep 9, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can鈥檛 perform that action at this time.