Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
tree: 7a9e94295d
Fetching contributors…

Cannot retrieve contributors at this time

36 lines (25 sloc) 0.94 kB
You must first install a recent version of
- OCaml (at least 3.11),
see http://caml.inria.fr/download.en.html
- Pcre
if you want stuff I don't remember.
- GTK (at least gtk 2.10) and Cairo
if you want codemap, the fancy graphics code visualizer.
- Berkeley DB (at least 4.3)
if you need to process huge codebase
- SWI-prolog
if you want the interactive code query tool
You will need both the runtime and the development library for
those packages (e.g. pcre and pcre-devel packages under most Linux
distributions).
If you want most of the good things just type:
$ ./configure
$ make depend
$ make
$ make opt
This should generate a few binaries at the toplevel directory such
as pfff or codemap.
If you just want to compile the parsing frontend, then type
$ ./configure -nogui -novisual -nobdb
If you want the parsing frontend and the analysis framework then type
$ ./configure -nogui -novisual
Jump to Line
Something went wrong with that request. Please try again.