Permalink
Browse files

install.txt modifs

  • Loading branch information...
1 parent 50eaea3 commit 2bc2c463914e6a035370e8b9fc66791e24bb4c78 pad committed Sep 23, 2010
Showing with 32 additions and 42 deletions.
  1. +14 −25 install.txt
  2. +9 −6 install_linux.txt
  3. +9 −11 install_macos.txt
View
@@ -10,38 +10,27 @@ You must first install a recent version of
if you want the fancy graphics capabilities.
- Pcre
if you want stuff I don't remember.
+You will need both the runtime and the development library for
+those packages (e.g. pcre and pcre-devel packages under most Linux
+distributions).
-OCaml may be available already on your Linux/Mac/Windows distributions.
-You can also try to do:
-
- $ source env.sh
-
-which setup the PATH and other variables to places where OCaml may
-already be.
-
-If you just want to compile the parsing frontend, then type
-
- $ ./configure
-
-
-If you want the parsing frontend and the analysis framework then type
-
- $ ./configure --bdb
-
-You will also need the runtime and development library for berkley db 4.3.
+Then if you want everything then just type
+ $ ./configure
+ $ make depend
+ $ make
+ $ make opt
-If you want everything then just type
+This should generate a few binaries at the toplevel directory such
+as pfff or pfff_visual.
- $ ./configure --with-all
-You will also need the runtime and development library for gtk2 and cairo.
+If you just want to compile the parsing frontend, then type
-Then type:
+ $ ./configure -nobdb -nogui -novisual
- $ make depend
- $ make
- $ make install
+If you want the parsing frontend and the analysis framework then type
+ $ ./configure -nogui -novisual
View
@@ -1,11 +1,14 @@
-Install pcre-devel, gtk2-devel, atk-devel, pango-devel, cairo-devel.
-redhat: sudo yum install pcre-devel
-ubuntu: sudo apt-get install pcre-devel
-gentoo: emerge pcre
-...
+Install pcre-devel, gtk2-devel, atk-devel, pango-devel, and cairo-devel.
+
+For instance:
+for redhat: sudo yum install pcre-devel
+for ubuntu: sudo apt-get install pcre-devel
+for gentoo: sudo emerge pcre
+for arch: I don't remember
then
$ ./configure
$ make depend
- $ make; make opt
+ $ make
+ $ make opt
View
@@ -1,17 +1,15 @@
-port install pcre
+Install macports http://www.macports.org/
+
+Then
+ $ sudo port install pcre
=> can ./configure -bdb
-port install cairo; port install gtk
+ $ sudo port install cairo
+ $ sudo port install gtk
=> can configure -visual
-port install mysql
+ $ sudo port install mysql
=> can ./configure -facebook
-for cairo + gtk don't use the quartz setting. Here are a few problems:
- - problem with current tk package in macports, had to patch it.
- - problem with flags. Had to use +no_x11 in addition to +quartz.
- Try install first cairo (with the 2 flags), then pango, then
- gtk2
- - get segfault on text_extent, probably because of pbs with pango ...
-=> have to use cairo + gtk + x11 for now
-
+For cairo and gtk don't use the quartz setting as it is currently
+buggy under macports.

0 comments on commit 2bc2c46

Please sign in to comment.