pfff can't compile on Ubuntu Natty due to syntax error #11

Closed
salimane opened this Issue Jul 19, 2011 · 5 comments

Comments

Projects
None yet
4 participants

$make depend
......
ocamldep -I ocamlextra -I ocollection -I lib-sexp -I lib-json -I lib-xml .mli *.ml > .depend
for i in ocamlextra ocollection lib-sexp lib-json lib-xml; do ocamldep -I ocamlextra -I ocollection -I lib-sexp -I lib-json -I lib-xml $i/
.ml $i/_.mli >> .depend; done
File "lib-sexp/pre_sexp.ml", line 241, characters 44-45:
Error: Syntax error
........
make[1]: Entering directory /home/salimane/htdocs/pfff/h_visualization' ocamldep -I ../commons -I ../commons/lib-json *.mli *.ml > .depend File "treemap.ml", line 133, characters 23-24: Error: Syntax error make[1]: *_\* [depend] Error 2 make[1]: Leaving directory/home/salimane/htdocs/pfff/h_visualization'
make: *** [depend] Error 2

jsleetw commented Dec 6, 2011

same here on Ubuntu 11.04
package i installed:
libpcre3-dev, libgtk2.0-dev, libcairo2-dev and libpango1.0-dev

jsleetw commented Dec 8, 2011

You maybe need upgrade ubuntu to oneiric to have ocaml 3.12.0.

http://packages.ubuntu.com/search?keywords=ocaml

Contributor

aryx commented Mar 13, 2012

Does it still happen?

Still failing on Ubuntu 10.04 with ocaml: The Objective Caml toplevel, version 3.11.2

Contributor

aryx commented Jun 14, 2012

yes you need to upgrade to ocaml 3.12.
I've updated the configure script so the error message should be clearer
016f9c4

@aryx aryx closed this Jun 14, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment