Build Error on Fedora 17 #25

Closed
jmaitrehenry opened this Issue May 31, 2012 · 2 comments

Comments

Projects
None yet
2 participants

ocamlc -g -I ../../ocamlpcre/lib -I ../netsys -c nethttp.ml
File "nethttp.ml", line 1, characters 0-1:
Error: The implementation nethttp.ml
does not match the interface nethttp.cmi:
The field rev_split' is required but not provided The fieldHeader' is required but not provided
The field Cookie' is required but not provided The fielduripath_decode' is required but not provided
The field uripath_encode' is required but not provided The fieldsplit_host_port' is required but not provided
The field decode_query' is required but not provided The fieldcookie' is required but not provided
The field netscape_cookie' is required but not provided The fieldstatus_of_cgi_header' is required but not provided
The field #http_trailer_ro' is required but not provided The fieldhttp_trailer_ro' is required but not provided
The field http_trailer_ro' is required but not provided The field#http_trailer' is required but not provided
The field http_trailer' is required but not provided The fieldhttp_trailer' is required but not provided
The field #http_header_ro' is required but not provided The fieldhttp_header_ro' is required but not provided
The field http_header_ro' is required but not provided The field#http_header' is required but not provided
The field http_header' is required but not provided The fieldhttp_header' is required but not provided
The field Bad_header_field' is required but not provided The fieldstrong_validator_match' is required but not provided
The field weak_validator_match' is required but not provided The fieldetag' is required but not provided
The field cache_control_token' is required but not provided The fieldhttp_method' is required but not provided
The field string_of_http_status' is required but not provided The fieldhttp_status_of_int' is required but not provided
The field int_of_http_status' is required but not provided The fieldhttp_status' is required but not provided
The field protocol_of_string' is required but not provided The fieldstring_of_protocol' is required but not provided
The field protocol' is required but not provided The fieldprotocol_attribute' is required but not provided
The field `protocol_version' is required but not provided

Contributor

aryx commented Jun 14, 2012

Can you try with a fresh checkout of pfff?
then ./configure; make depend; make
and let me know if you still have the problem.

It works now.
Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment