Permalink
Browse files

Remove npm 2 recommendation

Summary:
npm 3 is working fine especially if you use shrinkwrap at the end. we've been using it for a month+ and the dependency deduping works well.
Closes #5391

Reviewed By: svcscm

Differential Revision: D2839472

Pulled By: androidtrunkagent

fb-gh-sync-id: 33e551185236694ee5979da701312f12e2582f3c
  • Loading branch information...
ide authored and facebook-github-bot-7 committed Jan 19, 2016
1 parent 05e8681 commit 1b5b42f3cb594edbfef73e80763c826f2890885a
Showing with 0 additions and 2 deletions.
  1. +0 −1 docs/EmbeddedAppIOS.md
  2. +0 −1 docs/GettingStarted.md
View
@@ -14,7 +14,6 @@ Since React makes no assumptions about the rest of your technology stack – it
- [CocoaPods](http://cocoapods.org/) – `gem install cocoapods`
- [Node.js](http://nodejs.org)
- Install **nvm** with [its setup instructions here](https://github.com/creationix/nvm#installation). Then run `nvm install node && nvm alias default node`, which installs the latest version of Node.js and sets up your terminal so you can run it by typing `node`. With nvm you can install multiple versions of Node.js and easily switch between them.
- - If you are using Node 5.0 or newer, we recommend installing npm 2, which is much faster than npm 3. After installing Node, run `npm install -g npm@2`
- Install the `react-native` package from npm by running the following command in the root directory of your project:
- `npm install react-native`
View
@@ -13,7 +13,6 @@ next: android-setup
2. [Homebrew](http://brew.sh/) is the recommended way to install Watchman and Flow.
3. Install [Node.js](https://nodejs.org/) 4.0 or newer.
- Install **nvm** with [its setup instructions here](https://github.com/creationix/nvm#installation). Then run `nvm install node && nvm alias default node`, which installs the latest version of Node.js and sets up your terminal so you can run it by typing `node`. With nvm you can install multiple versions of Node.js and easily switch between them.
- - If you are using Node 5.0 or newer, we recommend installing npm 2, which is much faster than npm 3. After installing Node, run `npm install -g npm@2`.
- New to [npm](https://docs.npmjs.com/)?
4. `brew install watchman`. We recommend installing [watchman](https://facebook.github.io/watchman/docs/install.html), otherwise you might hit a node file watching bug.
5. `brew install flow`, if you want to use [flow](http://www.flowtype.org).

0 comments on commit 1b5b42f

Please sign in to comment.