Permalink
Browse files

Move Terminal to metro-core

Reviewed By: rafeca

Differential Revision: D6532920

fbshipit-source-id: d1463aa0759a6b6d5cc46b05157518a4ce3eb9bf
  • Loading branch information...
Peter van der Zee authored and facebook-github-bot committed Dec 15, 2017
1 parent 5a1171e commit 29dafa1a8644f7a537499074df334bab8da4ad00
Showing with 3 additions and 11 deletions.
  1. +1 −4 local-cli/bundle/buildBundle.js
  2. +2 −7 local-cli/server/runServer.js
@@ -16,10 +16,7 @@ const log = require('../util/log').out('bundle');
* found when Flow v0.54 was deployed. To see the error delete this comment and
* run Flow. */
const Server = require('metro/src/Server');
/* $FlowFixMe(>=0.54.0 site=react_native_oss) This comment suppresses an error
* found when Flow v0.54 was deployed. To see the error delete this comment and
* run Flow. */
const Terminal = require('metro/src/lib/Terminal');
const {Terminal} = require('metro-core');
/* $FlowFixMe(>=0.54.0 site=react_native_oss) This comment suppresses an error
* found when Flow v0.54 was deployed. To see the error delete this comment and
* run Flow. */
@@ -13,17 +13,12 @@
'use strict';
require('../../setupBabel')();
/* $FlowFixMe(>=0.54.0 site=react_native_oss) This comment suppresses an error
* found when Flow v0.54 was deployed. To see the error delete this comment and
* run Flow. */
const Metro = require('metro');
const HmrServer = require('metro/src/HmrServer');
/* $FlowFixMe(>=0.54.0 site=react_native_oss) This comment suppresses an error
* found when Flow v0.54 was deployed. To see the error delete this comment and
* run Flow. */
const Terminal = require('metro/src/lib/Terminal');
const {Terminal} = require('metro-core');
const attachWebsocketServer = require('./util/attachWebsocketServer');
/* $FlowFixMe(>=0.54.0 site=react_native_oss) This comment suppresses an error

0 comments on commit 29dafa1

Please sign in to comment.