Skip to content
Permalink
Browse files
Add community-eslint-plugin to eslint-config dependency (#27680)
Summary:
Added `react-native-community/eslint-plugin` as a dependency for `react-native-community/eslint-config`

The newly published eslint-config has `react-native-community/eslint-plugin` in its `.eslintrc`, but it's not listed under dependency, so when I try to use it in a community package, I'd have to install both `eslint-config` and `eslint-plugin`.
It would be nice to just be able to install `eslint-config` and extend that without additional package listed under devDependency.

## Changelog

[General] [Changed] - Added `react-native-community/eslint-plugin` as a dependency for `react-native-community/eslint-config`
Pull Request resolved: #27680

Differential Revision: D19287051

Pulled By: cpojer

fbshipit-source-id: 3aea54def7fb4598a21bfc087cc7938ce0662a59
  • Loading branch information
Naturalclar authored and facebook-github-bot committed Jan 6, 2020
1 parent 8881376 commit 2c2e35c634cd936bd7ea7a7fe444058268308224
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 0 deletions.
@@ -9,6 +9,7 @@
"url": "git@github.com:facebook/react-native.git"
},
"dependencies": {
"@react-native-community/eslint-plugin": "^1.0.0",
"@typescript-eslint/eslint-plugin": "^1.5.0",
"@typescript-eslint/parser": "^1.5.0",
"babel-eslint": "10.0.3",
@@ -90,6 +90,11 @@
lodash "^4.17.11"
to-fast-properties "^2.0.0"

"@react-native-community/eslint-plugin@^1.0.0":
version "1.0.0"
resolved "https://registry.yarnpkg.com/@react-native-community/eslint-plugin/-/eslint-plugin-1.0.0.tgz#ae9a430f2c5795debca491f15a989fce86ea75a0"
integrity sha512-GLhSN8dRt4lpixPQh+8prSCy6PYk/MT/mvji/ojAd5yshowDo6HFsimCSTD/uWAdjpUq91XK9tVdTNWfGRlKQA==

"@typescript-eslint/eslint-plugin@^1.5.0":
version "1.5.0"
resolved "https://registry.yarnpkg.com/@typescript-eslint/eslint-plugin/-/eslint-plugin-1.5.0.tgz#85c509bcfc2eb35f37958fa677379c80b7a8f66f"

0 comments on commit 2c2e35c

Please sign in to comment.