Permalink
Browse files

Add .nvmrc + fix node version for eslint 5 compat (#20109)

Summary:
A .nvmrc file is practical when working on many node projects with different version requirements.

Also, the current required node engine is incompatible with eslint5 requirements:

```js
  "engines": {
    "node": ">=8"
  },
```

It produces the following warning on install:

> error eslint@5.0.1: The engine "node" is incompatible with this module. Expected version "^6.14.0 || ^8.10.0 || >=9.10.0".
> error Found incompatible module

I made the requirement compatible with eslint5 requirements
Pull Request resolved: #20109

Differential Revision: D9071440

Pulled By: hramos

fbshipit-source-id: 0d3728d03cad20d22c67a731a6d283cea48b8da8
  • Loading branch information...
slorber authored and facebook-github-bot committed Jul 31, 2018
1 parent b6f2aad commit 30b9d81087cb86f5fb272d00bfee63a0632009f5
Showing with 1 addition and 0 deletions.
  1. +1 −0 .nvmrc
View
1 .nvmrc
@@ -0,0 +1 @@
8.11.3

0 comments on commit 30b9d81

Please sign in to comment.