Skip to content
Permalink
Browse files

Add `folly_compiler_flags` to Core subspec (#23488)

Summary:
This fixes the following iOS build error when using React via pods (using the new Xcode build system);

> project/Pods/Folly/folly/portability/Config.h:20:10: 'folly/folly-config.h' file not found

react-native-community/releases#79 (comment)
react-native-community/releases#79 (comment)
react-native-community/releases#79 (comment)

[iOS] [Fixed] - Fixed a "'folly/folly-config.h' file not found" build error when using React via CocoaPods
Pull Request resolved: #23488

Differential Revision: D14121296

Pulled By: cpojer

fbshipit-source-id: 5eb2ba3066aef2bc9cfb95a9172cbef921c47170
  • Loading branch information...
Salakar authored and grabbou committed Feb 17, 2019
1 parent 179d490 commit 415cc2578893c924870d94a893ae7686a81d2831
Showing with 1 addition and 0 deletions.
  1. +1 −0 React.podspec
@@ -66,6 +66,7 @@ Pod::Spec.new do |s|
"React/Views/RCTSlider*",
"React/Views/RCTSwitch*",
"React/Views/RCTWebView*"
ss.compiler_flags = folly_compiler_flags
ss.header_dir = "React"
ss.framework = "JavaScriptCore"
ss.libraries = "stdc++"

0 comments on commit 415cc25

Please sign in to comment.
You can’t perform that action at this time.