Skip to content
Permalink
Browse files
Remove the post install step (#28651)
Summary:
Removes the post install step for Flipper, as the latest version of YogaKit is compatible with swift 5.

cc alloy

## Changelog

<!-- Help reviewers and the release process by writing your own changelog entry. For an example, see:
https://github.com/facebook/react-native/wiki/Changelog
-->

[Flipper] [Template] - Remove the post install step for Flipper
Pull Request resolved: #28651

Test Plan: Tested a newly created RN app without post install step and it built successfully.

Reviewed By: passy

Differential Revision: D21064653

Pulled By: priteshrnandgaonkar

fbshipit-source-id: da56d0754d918e30a0ebe480c77590f0139d48ac
  • Loading branch information
priteshrnandgaonkar authored and facebook-github-bot committed Apr 16, 2020
1 parent 7cedccd commit 44beb2a685b7ceb0311bde7d0d33cb70bb891d30
Show file tree
Hide file tree
Showing 2 changed files with 0 additions and 14 deletions.
@@ -88,14 +88,3 @@ def use_flipper!(versions = {})
pod 'FlipperKit/FlipperKitLayoutTextSearchable', versions['Flipper'], :configuration => 'Debug'
pod 'FlipperKit/FlipperKitNetworkPlugin', versions['Flipper'], :configuration => 'Debug'
end

# Post Install processing for Flipper
def flipper_post_install(installer)
installer.pods_project.targets.each do |target|
if target.name == 'YogaKit'
target.build_configurations.each do |config|
config.build_settings['SWIFT_VERSION'] = '4.1'
end
end
end
end
@@ -18,9 +18,6 @@ target 'HelloWorld' do
# Note that if you have use_frameworks! enabled, Flipper will not work and
# you should disable these next few lines.
use_flipper!
post_install do |installer|
flipper_post_install(installer)
end
end

target 'HelloWorld-tvOS' do

0 comments on commit 44beb2a

Please sign in to comment.