Permalink
Browse files

Bump compileSdkVersion to 27 and buildToolsVersion to 27.0.3 (#20777)

Summary:
I found that android support library 27.x (874cca1) requires compileSdkVersion to be 27. Also found that many FB projects use SDK 27.
Pull Request resolved: #20777

Differential Revision: D9478431

Pulled By: hramos

fbshipit-source-id: ca100f6b5b39e7d112926124423f9510a0efc291
  • Loading branch information...
dulmandakh authored and kelset committed Aug 23, 2018
1 parent 4b68b64 commit 5992f8d5870963ce2c4f50035720753ecb0f7652
View
@@ -1,6 +1,6 @@
[android]
target = android-26
target = android-27
[download]
max_number_of_retries = 3
View
@@ -28,11 +28,11 @@ aliases:
- &restore-cache-android-packages
keys:
- v1-android-sdkmanager-packages-api-26-alpha-{{ checksum "scripts/.tests.env" }}
- v1-android-sdkmanager-packages-api-27-alpha-{{ checksum "scripts/.tests.env" }}
- &save-cache-android-packages
paths:
- /opt/android/sdk
key: v1-android-sdkmanager-packages-api-26-alpha-{{ checksum "scripts/.tests.env" }}
key: v1-android-sdkmanager-packages-api-27-alpha-{{ checksum "scripts/.tests.env" }}
- &restore-cache-gradle
keys:
@@ -334,7 +334,7 @@ js_defaults: &js_defaults
android_defaults: &android_defaults
<<: *defaults
docker:
- image: circleci/android:api-26-node8-alpha
- image: circleci/android:api-27-node8-alpha
resource_class: "large"
environment:
- TERM: "dumb"
@@ -18,8 +18,8 @@ LABEL maintainer="Héctor Ramos <hector@fb.com>"
# set default build arguments
ARG SDK_VERSION=sdk-tools-linux-3859397.zip
ARG ANDROID_BUILD_VERSION=26
ARG ANDROID_TOOLS_VERSION=26.0.3
ARG ANDROID_BUILD_VERSION=27
ARG ANDROID_TOOLS_VERSION=27.0.3
ARG BUCK_VERSION=v2018.07.23.01
ARG NDK_VERSION=17b
ARG NODE_VERSION=8.10.0
@@ -84,8 +84,8 @@ def enableSeparateBuildPerCPUArchitecture = false
def enableProguardInReleaseBuilds = true
android {
compileSdkVersion 26
buildToolsVersion "26.0.3"
compileSdkVersion 27
buildToolsVersion "27.0.3"
defaultConfig {
applicationId "com.facebook.react.uiapp"
@@ -245,8 +245,8 @@ task packageReactNdkLibsForBuck(dependsOn: packageReactNdkLibs, type: Copy) {
}
android {
compileSdkVersion 26
buildToolsVersion "26.0.3"
compileSdkVersion 27
buildToolsVersion "27.0.3"
defaultConfig {
minSdkVersion 16
View
@@ -1,8 +1,8 @@
environment:
ANDROID_HOME: "C:\\android-sdk-windows"
ANDROID_NDK: "C:\\android-sdk-windows\\android-ndk-r17b"
ANDROID_BUILD_VERSION: 26
ANDROID_TOOLS_VERSION: 26.0.3
ANDROID_BUILD_VERSION: 27
ANDROID_TOOLS_VERSION: 27.0.3
GRADLE_OPTS: -Dorg.gradle.daemon=false
@@ -32,9 +32,9 @@ allprojects {
}
ext {
buildToolsVersion = "26.0.3"
buildToolsVersion = "27.0.3"
minSdkVersion = 16
compileSdkVersion = 26
compileSdkVersion = 27
targetSdkVersion = 26
supportLibVersion = "27.1.1"
}
View
@@ -4,9 +4,9 @@
## ANDROID ##
# Android SDK Build Tools revision
export ANDROID_SDK_BUILD_TOOLS_REVISION=26.0.3
export ANDROID_SDK_BUILD_TOOLS_REVISION=27.0.3
# Android API Level we build with
export ANDROID_SDK_BUILD_API_LEVEL="26"
export ANDROID_SDK_BUILD_API_LEVEL="27"
# Google APIs for Android level
export ANDROID_GOOGLE_API_LEVEL="23"
# Minimum Android API Level we target

0 comments on commit 5992f8d

Please sign in to comment.