Skip to content
Permalink
Browse files
Upgrade internal packages to support ESLint >= 6 (#28393)
Summary:
Fixes #28293

I've tested it with https://github.com/react-native-community/react-native-template-typescript and it seems to be working as expected - no warnings, supports typescript 3.8.

(note: I didn't upgrade the package version as I don't know how the releases work for this package)

## Changelog

[CATEGORY] [TYPE] - Message
Pull Request resolved: #28393

Reviewed By: hramos

Differential Revision: D20647112

Pulled By: cpojer

fbshipit-source-id: ca6b67971f625dc8125a58f9220dfcd86250ba94
  • Loading branch information
Barbiero authored and facebook-github-bot committed Mar 26, 2020
1 parent 8ac00b3 commit 89d04b5e4a3fd0b0f77b5a390c0aa62a3804e2bc
Show file tree
Hide file tree
Showing 2 changed files with 643 additions and 345 deletions.
@@ -1,6 +1,6 @@
{
"name": "@react-native-community/eslint-config",
"version": "0.0.7",
"version": "1.0.0",
"description": "ESLint config for React Native",
"main": "index.js",
"license": "MIT",
@@ -10,23 +10,23 @@
},
"dependencies": {
"@react-native-community/eslint-plugin": "^1.0.0",
"@typescript-eslint/eslint-plugin": "^1.5.0",
"@typescript-eslint/parser": "^1.5.0",
"babel-eslint": "10.0.3",
"eslint-config-prettier": "^6.0.0",
"@typescript-eslint/eslint-plugin": "^2.25.0",
"@typescript-eslint/parser": "^2.25.0",
"babel-eslint": "10.1.0",
"eslint-config-prettier": "^6.10.1",
"eslint-plugin-eslint-comments": "^3.1.2",
"eslint-plugin-flowtype": "2.50.3",
"eslint-plugin-jest": "22.4.1",
"eslint-plugin-prettier": "2.6.2",
"eslint-plugin-react": "7.16.0",
"eslint-plugin-react-hooks": "^2.0.1",
"eslint-plugin-prettier": "3.1.2",
"eslint-plugin-react": "7.19.0",
"eslint-plugin-react-hooks": "^2.5.1",
"eslint-plugin-react-native": "3.8.1",
"prettier": "1.17.0"
"prettier": "^2.0.2"
},
"peerDependencies": {
"eslint": ">=5"
"eslint": ">=6"
},
"devDependencies": {
"eslint": "^5.1.0"
"eslint": "^6.5.1"
}
}

0 comments on commit 89d04b5

Please sign in to comment.