Permalink
Browse files

Bugfix: Check NodeJS version successfully even for old runtimes (Fixes

…#20769) (#20779)

Summary:
Fixes #20769

Release notes
--------------
[CLI] [BUGFIX] [local-cli/server/checkNodeVersion.js] - Disable auto-formatting in `local-cli/server/checkNodeVersion.js` since it introduces ES6 and ES7 syntax (trailing comma in argument list) which in turn makes ES5 engines crash with a `SyntaxError`.
Pull Request resolved: #20779

Differential Revision: D9468346

Pulled By: hramos

fbshipit-source-id: 24761a377a5fd104e11ed6b6e86da15e96a0e38b
  • Loading branch information...
keksipurkki authored and hramos committed Aug 23, 2018
1 parent 893c027 commit 9a4c21f92bf7a979d1719dd9dad533fb246786ca
Showing with 5 additions and 2 deletions.
  1. +5 −2 local-cli/server/checkNodeVersion.js
@@ -4,7 +4,10 @@
* This source code is licensed under the MIT license found in the
* LICENSE file in the root directory of this source tree.
*
* @format
* Be mindful that this script may be run by legacy NodeJS runtimes. Keep this
* script ES5 compatible (e.g. do not insert the `@format` pragma here which
* may introduce non-ES5 compatible syntax.)
*
*/
'use strict';
@@ -36,7 +39,7 @@ module.exports = function() {
marginLeft: 1,
marginRight: 1,
paddingBottom: 1,
}),
})
);
process.exit(1);
}

0 comments on commit 9a4c21f

Please sign in to comment.