Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

iOS - 0.48.0 - Blank App Crashes At Launch #15762

Closed
fabriziogiordano opened this issue Sep 2, 2017 · 44 comments

Comments

Projects
None yet
@fabriziogiordano
Copy link

commented Sep 2, 2017

Is this a bug report?

Yes

Have you read the Contributing Guidelines?

Yes

Environment

  1. react-native -v: 0.48.0
  2. node -v: v8.3.0
  3. npm -v: 5.3.0
  4. yarn --version: 0.27.5

Then, specify:

  • Target Platform: iOS - xCode Version 8.3.3 (8E3004b)
  • Development Operating System: macOS Sierra 10.12.4
  • Build tools: Command Line

Steps to Reproduce

(Write your steps here:)

  1. react-native init --version 0.48.0 test
  2. cd ./test
  3. react-native run-ios
  4. iPhone 6 - iOS 10.0 (14A345) with resetted content and settings
  5. Loading screen open
  6. App crashes and does not even compile the JS bundle

Here the command line log:
https://gist.github.com/fabriziogiordano/2952ea25e10dfc10d13e5fd8ca9f9690

Expected Behavior

The App does not crash on launch and the JS is bundled.

Actual Behavior

The App does crash on launch and the JS is bundled.

xcodeerror

xcodeversion

Reproducible Demo

React Native 0.48.0-rc.1 does not throw such error and works as expected.
I am assuming that something in here v0.48.0-rc.1...v0.48.0 is causing the issue.

(Paste the link to an example project and exact instructions to reproduce the issue.)

@cxgslegend

This comment has been minimized.

Copy link

commented Sep 2, 2017

I have the exact same problem. I have been losing my mind for the last few hours. I thought I was the only person in the universe with this problem. Hopefully this get fixed quickly. I need this working for a school project (and time is ticking away).

@larenelg-tw

This comment has been minimized.

Copy link

commented Sep 2, 2017

Hey @cxgslegend - I had the same problem as well. I'm using a previous version while it gets resolved :)

react-native init --version 0.47.0 <projectname>

@alpfilho

This comment has been minimized.

Copy link

commented Sep 2, 2017

same problem here

@cxgslegend

This comment has been minimized.

Copy link

commented Sep 2, 2017

@larenelg-tw, that worked like a charm! Thank you so much!

@joshmello

This comment has been minimized.

Copy link

commented Sep 2, 2017

Same problem pulling my hair out lol.

@rahulvramesh

This comment has been minimized.

Copy link

commented Sep 2, 2017

wasted my 2 days. hope it will fix soon.

@kichiwa

This comment has been minimized.

Copy link

commented Sep 2, 2017

Thank you,
So, I dont need to reinstall node,js,yarn as I think

@masudhossain

This comment has been minimized.

Copy link

commented Sep 2, 2017

Same problem here. I really wish I looked at the Issues before spending the last 5 hours trying to fix it...

@adithwip

This comment has been minimized.

Copy link

commented Sep 2, 2017

I think i'm the only one :(
Hopefully it'll fixed soon

@andreatoso

This comment has been minimized.

Copy link

commented Sep 2, 2017

Same problem here.

@piyush2468

This comment has been minimized.

Copy link

commented Sep 2, 2017

The New version of react-native is carrying some bugs during js bundle and with gradlew assemblerelease downgrading the react version seems to be only option for right now.

@fabriziogiordano fabriziogiordano changed the title iOS - 0.48.0 - New App Crashes At Launch iOS - 0.48.0 - Blank App Crashes At Launch Sep 2, 2017

@lcarmichael

This comment has been minimized.

Copy link

commented Sep 2, 2017

I have the same problem. I have tried 0.47.2, and 0.47.0 with rebuild and I continue to get the same error. I have uninstalled everything from RN to Xcode, hoping that maybe it was a setting that I changed along the way. If anyone has any suggestions as to why downgrading would not work, please let me know.

screen shot 2017-09-02 at 10 33 51 am

@lcarmichael

This comment has been minimized.

Copy link

commented Sep 2, 2017

Fixed by switching to 0.48.0-rc.1 as @fabriziogiordano noted previously. Thank You!

@fredesse

This comment has been minimized.

Copy link

commented Sep 2, 2017

Ran into the same problem last night so followed @larenelg-tw advice, downgraded to react-native 0.47.0 and that fixed the problem for now. Thanks!

@anivon

This comment has been minimized.

Copy link

commented Sep 2, 2017

Same problem ! I'm now bald ! :(

@DarkSector

This comment has been minimized.

Copy link

commented Sep 3, 2017

Same issue. Downgraded to 0.47.2.

@timrc

This comment has been minimized.

Copy link

commented Sep 3, 2017

+1

@aethiss

This comment has been minimized.

Copy link

commented Sep 3, 2017

Same issue, solution is downgrade or wait some fix :)

@krittiyaclark

This comment has been minimized.

Copy link

commented Sep 3, 2017

This is my third days with a same problem. I almost give up learning React-Native.

@fabriziogiordano

This comment has been minimized.

Copy link
Author

commented Sep 3, 2017

@usakc posted a fix here
#15768 (comment)

I tested it on a fresh blank app and not the iOS Simulator does not crash.

@Jonovono

This comment has been minimized.

Copy link

commented Sep 3, 2017

React Native is the most extreme love & hate relationship I have.

@kgirma

This comment has been minimized.

Copy link

commented Sep 3, 2017

@larenelg-tw this is also proven to be stable for both ios and android
react-native init --version 0.47.2 yourprojectname

@srdjanprpa

This comment has been minimized.

Copy link

commented Sep 3, 2017

Same problem here.

@varunprasadyadav

This comment has been minimized.

Copy link

commented Sep 4, 2017

Same problem for me also.
What worked is if I create the project using an earlier version like 0.44

@jvitorr

This comment has been minimized.

Copy link

commented Sep 4, 2017

I am with the same problem
What solution?

@varunprasadyadav

This comment has been minimized.

Copy link

commented Sep 4, 2017

@johnpalaganas

This comment has been minimized.

Copy link

commented Sep 4, 2017

Same problem here with 0.48.0. I hope a fix will come soon.

@Gotogoo

This comment has been minimized.

Copy link

commented Sep 4, 2017

This is a bug with 0.48.0,I have the same problem.
I set a exceotion breakpoint with Xcode and find the problem.
The following fixes might be useful to you.

  1. open the xxx.xcodeproj with XCode;
  2. click ⌘⇧F ,search(in RCTMultipartStreamReader.m at line 79):
NSUInteger headersContentLength = headers[@"Content-Length"] != nil ? [headers[@"Content-Length"] unsignedIntValue] : 0;
  1. replace it with:
NSUInteger headersContentLength = headers[@"Content-Length"] != nil ? [headers[@"Content-Length"] integerValue] : 0;
  1. run.
@gpuente

This comment has been minimized.

Copy link

commented Sep 4, 2017

Same problem here

@gre

This comment has been minimized.

Copy link
Contributor

commented Sep 4, 2017

#15755 should fix it

@grabbou

This comment has been minimized.

Copy link
Collaborator

commented Sep 4, 2017

Since I am at the workshop already, I reverted the commit that caused this issue and released 0.48.2.

Apologies for the issues, hope I didn't destroy everyone's Sunday 🔥

@grabbou grabbou closed this Sep 4, 2017

@gre

This comment has been minimized.

Copy link
Contributor

commented Sep 4, 2017

thanks for your monday morning fix :)

@yudai524

This comment has been minimized.

Copy link

commented Sep 4, 2017

Thanks !

@srdjanprpa

This comment has been minimized.

Copy link

commented Sep 4, 2017

@grabbou you mean 0.48.1. Or 0.48.2 coming soon?

@grabbou

This comment has been minimized.

Copy link
Collaborator

commented Sep 4, 2017

@fachilles

This comment has been minimized.

Copy link

commented Sep 4, 2017

Finally, it's a real bug. Waste too much...

@alxvallejo

This comment has been minimized.

Copy link

commented Sep 4, 2017

@grabbou you said you released 0.48.2? But i don't see that in the releases? https://github.com/facebook/react-native/releases Please clarify, thx

@grabbou

This comment has been minimized.

Copy link
Collaborator

commented Sep 4, 2017

@johnpalaganas

This comment has been minimized.

Copy link

commented Sep 4, 2017

Thanks @grabbou I was going a little crazy last night :)

@raff90

This comment has been minimized.

Copy link

commented Mar 1, 2018

having a same issue with 50.0

@Salinn

This comment has been minimized.

Copy link

commented Mar 5, 2018

Seem to have the same issue on 50.1

@jose920405

This comment has been minimized.

Copy link

commented Jun 1, 2018

Same issue in 0.51.0

@hanssonfredrik

This comment has been minimized.

Copy link

commented Jul 11, 2018

Same issue on 0.55.4. Seems only to happen on iPhone X.

@ArunKulasegaran

This comment has been minimized.

Copy link

commented Jul 27, 2018

Any Update on this issue on iPhoneX

@facebook facebook locked as resolved and limited conversation to collaborators Sep 4, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.