Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to find a specification for `FBReactNativeSpec (= 0.61.4)` depended upon by `React-CoreModules` #27140

Closed
codler opened this issue Nov 6, 2019 · 3 comments
Labels
Bug

Comments

@codler
Copy link
Contributor

@codler codler commented Nov 6, 2019

After upgrading from 0.60.5 to 0.61.4 I no longer can start the app again..

Unable to find a specification for FBReactNativeSpec (= 0.61.4) depended upon by React-CoreModules

error: Build input file cannot be found: '/node_modules/react-native/ReactCommon/yoga/yoga/YGMarker.cpp' (in target 'yoga' from project 'Pods')

React Native version:
System:
OS: macOS Mojave 10.14.6
CPU: (4) x64 Intel(R) Core(TM) i5-5257U CPU @ 2.70GHz
Memory: 29.32 MB / 8.00 GB
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 12.10.0 - /usr/local/bin/node
npm: 6.10.3 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
SDKs:
iOS SDK:
Platforms: iOS 13.0, DriverKit 19.0, macOS 10.15, tvOS 13.0, watchOS 6.0
Android SDK:
API Levels: 23, 28
Build Tools: 28.0.3, 29.0.2
System Images: android-28 | Google APIs Intel x86 Atom
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.5791312
Xcode: 11.0/11A420a - /usr/bin/xcodebuild
npmPackages:
react: ^16.11.0 => 16.11.0
react-native: ^0.61.4 => 0.61.4
npmGlobalPackages:
react-native-cli: 2.0.1
react-native-git-upgrade: 0.2.7

Steps To Reproduce

Upgrading from 0.60.5 to 0.61.4

@codler codler added the Bug label Nov 6, 2019
@codler codler closed this Nov 6, 2019
@ZsKLiQuid

This comment has been minimized.

Copy link

@ZsKLiQuid ZsKLiQuid commented Nov 7, 2019

How do you resolve this issue ?

@codler

This comment has been minimized.

Copy link
Contributor Author

@codler codler commented Nov 7, 2019

Adding this to Podfile

  pod 'FBLazyVector', :path => "../node_modules/react-native/Libraries/FBLazyVector"
  pod 'FBReactNativeSpec', :path => "../node_modules/react-native/Libraries/FBReactNativeSpec"
  pod 'RCTRequired', :path => "../node_modules/react-native/Libraries/RCTRequired"
  pod 'RCTTypeSafety', :path => "../node_modules/react-native/Libraries/TypeSafety"
@boostmerlin

This comment has been minimized.

Copy link

@boostmerlin boostmerlin commented Nov 20, 2019

➜ ios pod install --repo-update
Updating local specs repositories
Analyzing dependencies
Fetching podspec for DoubleConversion from ../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec
Fetching podspec for Folly from ../node_modules/react-native/third-party-podspecs/Folly.podspec
Fetching podspec for glog from ../node_modules/react-native/third-party-podspecs/glog.podspec
[!] Unable to find a specification for React-RCTBlob (= 0.61.4) depended upon by React

You have either:

  • mistyped the name or version.
  • not added the source repo that hosts the Podspec to your Podfile.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.