Permalink
Browse files

Update build.gradle

Fixes to gradle build files
  • Loading branch information...
1 parent 593bcf2 commit a04b1e2e60c004d197082fccfd79fe1a5b0b8999 @jasleensingh jasleensingh committed Mar 16, 2015
Showing with 8 additions and 8 deletions.
  1. +4 −4 build.gradle
  2. +3 −3 shimmer-android-example/build.gradle
  3. +1 −1 shimmer-android/build.gradle
View
@@ -13,12 +13,12 @@ apply plugin: 'com.android.library'
import com.android.builder.core.BuilderConstants
android {
- compileSdkVersion 19
- buildToolsVersion "19.1.0"
+ compileSdkVersion 21
+ buildToolsVersion "21.1.2"
defaultConfig {
- minSdkVersion 16
- targetSdkVersion 19
+ minSdkVersion 11
+ targetSdkVersion 21
}
sourceSets {
@@ -5,12 +5,12 @@ dependencies {
}
android {
- compileSdkVersion 19
- buildToolsVersion "19.1.0"
+ compileSdkVersion 21
+ buildToolsVersion "21.1.2"
defaultConfig {
minSdkVersion 16
- targetSdkVersion 19
+ targetSdkVersion 21
}
signingConfigs {
@@ -8,7 +8,7 @@ android {
buildToolsVersion "21.1.2"
defaultConfig {
- minSdkVersion 9
+ minSdkVersion 11
targetSdkVersion 21
}

2 comments on commit a04b1e2

@alvinwoon

Interesting. I am still seeing:

"Error:(6, 5) uses-sdk:minSdkVersion 14 cannot be smaller than version 16 declared in library /Users/alvinwoon/AndroidStudioProjects/FirstApp/app/build/intermediates/exploded-aar/com.facebook.shimmer/shimmer/0.1.0/AndroidManifest.xml"

@jasleensingh
Member

I believe the issue is that the default maven repository used by AndroidStudio (jcenter) doesn't have the updated packages yet. If you switch to the following in your build.gradle file (and clear caches if necessary), it should work:

allprojects {
    repositories {
        mavenCentral()
    }
}

Or you can wait for a few hours to see the updated packages.

Please sign in to comment.