Skip to content
This repository has been archived by the owner. It is now read-only.

swift compiler error base on FBSDKShareKit (4.23.0) #157

Closed
qinweizhao opened this issue May 26, 2017 · 90 comments
Closed

swift compiler error base on FBSDKShareKit (4.23.0) #157

qinweizhao opened this issue May 26, 2017 · 90 comments

Comments

@qinweizhao
Copy link

@qinweizhao qinweizhao commented May 26, 2017

FacebookShare/LinkShareContent.swift

content.contentDescription = self.description
content.contentTitle = self.title
content.imageURL = self.imageURL

cannot assign to get-only property

@qinweizhao
Copy link
Author

@qinweizhao qinweizhao commented May 26, 2017

I got the compiler error after update pods (Xcode 8.3.2,CocoaPods 1.2.0)

@Raptor2000
Copy link

@Raptor2000 Raptor2000 commented May 26, 2017

Same issue with CocoaPods 1.2.1 and xcode 8.3.2

@ghost
Copy link

@ghost ghost commented May 26, 2017

same issue!

@deepakbms
Copy link

@deepakbms deepakbms commented May 26, 2017

same issue, for now, i remove these lines

@sche
Copy link

@sche sche commented May 27, 2017

same issue

1 similar comment
@sotozaki
Copy link

@sotozaki sotozaki commented May 27, 2017

same issue

@hikarivina
Copy link

@hikarivina hikarivina commented May 27, 2017

I facing same problem. Is there any solution?

@adrienyvon699
Copy link

@adrienyvon699 adrienyvon699 commented May 27, 2017

Hi, I confirm this issue too

@thaoth58
Copy link

@thaoth58 thaoth58 commented May 28, 2017

Seem like a lot of people face this issue :D

@1amageek
Copy link

@1amageek 1amageek commented May 28, 2017

same issue

@NikKovIos
Copy link

@NikKovIos NikKovIos commented May 28, 2017

The same

@taglia3
Copy link

@taglia3 taglia3 commented May 28, 2017

same issue

@phalladar
Copy link

@phalladar phalladar commented May 29, 2017

+1. Womp.

@dams2007
Copy link

@dams2007 dams2007 commented May 29, 2017

Same one to.

@happiehappie
Copy link

@happiehappie happiehappie commented May 29, 2017

+1

@SwiftyGuerrero
Copy link

@SwiftyGuerrero SwiftyGuerrero commented May 29, 2017

Same issue here.

@beautynanacalico
Copy link

@beautynanacalico beautynanacalico commented May 30, 2017

@soulfoodz
Copy link

@soulfoodz soulfoodz commented May 30, 2017

Same issue

@aman-git
Copy link

@aman-git aman-git commented May 30, 2017

Compiler Error :

content.contentDescription = self.description
content.contentTitle = self.title
content.imageURL = self.imageURL

Cocoa pods Version : 1.2.1
Xcode Version : Version 8.2.1 (8C1002)

Cannot assign to get-only property, attaching screenshot along
Whats the possible solution to this

screen shot 2017-05-30 at 11 49 49 am

@mememto
Copy link

@mememto mememto commented May 30, 2017

Till the problem is solved i'm using:

pod 'FacebookCore', '~> 0.2'
pod 'FacebookLogin', '~> 0.2'
pod 'FacebookShare', '~> 0.2'
pod 'FBSDKCoreKit', '~> 4.22.1'
pod 'FBSDKLoginKit', '~> 4.22.1'
pod 'FBSDKShareKit', '~> 4.22.1'
@happiehappie
Copy link

@happiehappie happiehappie commented May 30, 2017

@mememto Is there any point to this? Since FacebookShare is just a swift wrap for FBSDKShareKit. Isn't this considered as a bad duplication?

@mememto
Copy link

@mememto mememto commented May 30, 2017

According to SDK documentation (https://developers.facebook.com/docs/swift/getting-started), you should add:
pod 'FacebookCore'
pod 'FacebookLogin'
pod 'FacebookShare'
to install all the modules of the SDK. Taking into account that doing this, will install FBSDKCoreKit, FBSDKLoginKit & FBSDKShareKit with version 4.23.0 into your project, the only way i've found to install FacebookCore, FacebookLogin and FacebookShare with version 4.22.1 of FBSDKCoreKit, FBSDKLoginKit & FBSDKShareKit is this.
Not sure if this is a duplication or not. Just wanted to share my "temporary solution".

@NikKovIos
Copy link

@NikKovIos NikKovIos commented May 30, 2017

Solved using pod 'FBSDKCoreKit', '~> 4.23' instead of all this swifty ..
Changelogs of SDKs https://developers.facebook.com/docs/ios/downloads

@matvdg
Copy link

@matvdg matvdg commented May 31, 2017

same issue, temporary solved here: https://stackoverflow.com/questions/44248118/facebookshare-causing-compiler-error-after-update
Facebook, please UPDATE your changelog: last updated = 4.18.0 : 30 nov 2016 :$

@1amageek
Copy link

@1amageek 1amageek commented Jun 9, 2017

pod 'FacebookCore'
pod 'FacebookLogin'
pod 'FacebookShare', :git => 'https://github.com/1amageek/facebook-sdk-swift'
@ygbr
Copy link

@ygbr ygbr commented Jun 9, 2017

+1

1 similar comment
@kasokuta
Copy link

@kasokuta kasokuta commented Jun 9, 2017

+1

@ygbr
Copy link

@ygbr ygbr commented Jun 9, 2017

There are 2 PR's with fixes for this bug (one is even CLA signed already), why not merge them and create a new release?

@tylermilner
Copy link

@tylermilner tylermilner commented Jun 10, 2017

I'm getting compiler errors after running pod repo update and then pod install as well. This seems like it's an easy fix. Please push a new release ASAP!

@isairuiz
Copy link

@isairuiz isairuiz commented Aug 2, 2017

+1

2 similar comments
@johntiror
Copy link

@johntiror johntiror commented Aug 2, 2017

+1

@ghost
Copy link

@ghost ghost commented Aug 3, 2017

+1

@shingsoso
Copy link

@shingsoso shingsoso commented Aug 8, 2017

same :)
waiting for update
;D

@Zulqarnain-Mustafa
Copy link

@Zulqarnain-Mustafa Zulqarnain-Mustafa commented Aug 9, 2017

facing same issue.

@NMKRebelute
Copy link

@NMKRebelute NMKRebelute commented Aug 11, 2017

Still..

Installing FBSDKCoreKit (4.25.0)
Installing FBSDKLoginKit (4.25.0)
Installing FBSDKShareKit (4.25.0)
Installing FacebookCore (0.2.0)
Installing FacebookLogin (0.2.0)
Installing FacebookShare (0.2.0)

Dear Facebook team please resolve the problem.

@goufo
Copy link

@goufo goufo commented Aug 12, 2017

+1

@ismoli
Copy link

@ismoli ismoli commented Aug 14, 2017

I like how quickly FB react to this 🥇

@ghost
Copy link

@ghost ghost commented Aug 14, 2017

After all, who needs facebook nowadays? /ironic

@cbarbera80
Copy link

@cbarbera80 cbarbera80 commented Aug 15, 2017

ridiculous!

@tylermilner
Copy link

@tylermilner tylermilner commented Aug 15, 2017

I don't know about you guys, but I gave up on Facebook ever fixing this and went back to the Obj-C SDK. Sure, I had to deal with a lovely implicitly unwrapped optional crash during Apple review, but at least my project compiles when using the latest Facebook SDK. ¯_(ツ)_/¯

@mingflifb
Copy link

@mingflifb mingflifb commented Aug 20, 2017

Graph API 2.9 introduced a 90-day breaking change that prohibited the overriding of these parameters. See https://developers.facebook.com/docs/apps/changelog#v2_9

@dmr07
Copy link

@dmr07 dmr07 commented Aug 26, 2017

+1

@CoffeePowered
Copy link

@CoffeePowered CoffeePowered commented Aug 31, 2017

What in the world are these FB guys doing? This must be some kind of prank that ended up in production, for over 3 months now. Get real, Facebook!

@nemexyz
Copy link

@nemexyz nemexyz commented Sep 1, 2017

The library is obsolete. @1amageek try to make the arrangement but the rules of Facebook will not let him, then who keeps the repository? it is ridiculous what happens here if many developers take Facebook Swift for their projects. Better get on with ObjC. #159

@denirorobert
Copy link

@denirorobert denirorobert commented Sep 12, 2017

still exists ☹️

@vatsal1992
Copy link

@vatsal1992 vatsal1992 commented Sep 23, 2017

FB guys..! what are you doing.. come on guys you must fix this issue.

@francodriansetti
Copy link

@francodriansetti francodriansetti commented Sep 26, 2017

+1

1 similar comment
@kevni111
Copy link

@kevni111 kevni111 commented Oct 1, 2017

+1

@zhihuitang
Copy link

@zhihuitang zhihuitang commented Oct 2, 2017

Seems our the great company Facebook doesn't care about it at all

@adnanboz
Copy link

@adnanboz adnanboz commented Oct 2, 2017

+1

@cs14rendra
Copy link

@cs14rendra cs14rendra commented Oct 5, 2017

I am using these Pod and its working fine .
pod 'Bolts'
pod 'FBSDKCoreKit'
pod 'FBSDKLoginKit'

tested on xode 8 and xcode 9
(i got it from a tutorial, i will update link later)

@MorganIsBatman
Copy link

@MorganIsBatman MorganIsBatman commented Oct 6, 2017

+1

@SGBRocks73
Copy link

@SGBRocks73 SGBRocks73 commented Oct 11, 2017

screen shot 2017-10-11 at 14 06 56

Those fields have been deprecated in 4.22.0 (18 Apr 2017). I would recommend just comment out.

@gfosco
Copy link
Contributor

@gfosco gfosco commented Oct 12, 2017

4.27.1 of the obj-c SDK is out, 0.3.0 of Swift sdk is out. All of this should be resolved.

@gfosco gfosco closed this Oct 12, 2017
@atistank
Copy link

@atistank atistank commented Nov 8, 2017

4.27.1 same problem :( they don't fix it

@ZhixiangWangCR7
Copy link

@ZhixiangWangCR7 ZhixiangWangCR7 commented Aug 8, 2018

+1

@memedinaa
Copy link

@memedinaa memedinaa commented Dec 12, 2018

Installing FBSDKCoreKit (4.38.1)
Installing FBSDKLoginKit (4.38.1)
Installing FBSDKShareKit (4.38.1)
Installing FacebookCore (0.5.0)
Installing FacebookLogin (0.5.0)
Installing FacebookShare (0.5.0)

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
You can’t perform that action at this time.