Permalink
Browse files

Use "commander" for cli argv handling (#1195)

* Use "commander" for  cli argv handling

* Handle different scripts version forms and exits without a name given

* Revert comment about min supported node version

* Check sooner for the minimal node version

* Add travis test for node <4

* Parse stderr in node versions <4
1 parent 9d42ffa commit 7f9fb294b3382d3ae964778489a0003c62c97fba @EnoahNetzach EnoahNetzach committed with gaearon Dec 11, 2016
Showing with 48 additions and 29 deletions.
  1. +1 −0 .travis.yml
  2. +31 −22 packages/create-react-app/index.js
  3. +1 −1 packages/create-react-app/package.json
  4. +15 −6 tasks/e2e.sh
View
@@ -1,6 +1,7 @@
---
language: node_js
node_js:
+ - 0.10
- 4
- 6
cache:
@@ -38,38 +38,47 @@
'use strict';
+var chalk = require('chalk');
+
+var currentNodeVersion = process.versions.node
+if (currentNodeVersion.split('.')[0] < 4) {
+ console.error(chalk.red('You are currently running Node v' + currentNodeVersion +
+ ' but create-react-app requires >=4. Please use a supported version of Node.\n'));
+ process.exit(1);
+}
+
var fs = require('fs');
var path = require('path');
var execSync = require('child_process').execSync;
var spawn = require('cross-spawn');
-var chalk = require('chalk');
var semver = require('semver');
-var argv = require('minimist')(process.argv.slice(2));
var pathExists = require('path-exists');
-/**
- * Arguments:
- * --version - to print current version
- * --verbose - to print logs while init
- * --scripts-version <alternative package>
- * Example of valid values:
- * - a specific npm version: "0.22.0-rc1"
- * - a .tgz archive from any npm repo: "https://registry.npmjs.org/react-scripts/-/react-scripts-0.20.0.tgz"
- * - a package prepared with `tasks/clean_pack.sh`: "/Users/home/vjeux/create-react-app/react-scripts-0.22.0.tgz"
- */
-var commands = argv._;
-if (commands.length === 0) {
- if (argv.version) {
- console.log('create-react-app version: ' + require('./package.json').version);
- process.exit();
- }
- console.error(
- 'Usage: create-react-app <project-directory> [--verbose]'
- );
+var projectName;
+
+var program = require('commander')
+ .version(require('./package.json').version)
+ .arguments('<name>')
+ .action(function (name) {
+ projectName = name;
+ })
+ .option('-v, --verbose', 'print logs while init')
+ .option('-s, --scripts-version <alternative package>', 'select a react script variant')
+ .on('--help', function () {
+ console.log('Example of valid script version values:')
+ console.log(' - a specific npm version: "0.22.0-rc1"')
+ console.log(' - a .tgz archive from any npm repo: "https://registry.npmjs.org/react-scripts/-/react-scripts-0.20.0.tgz"')
+ console.log(' - a package prepared with `tasks/clean_pack.sh`: "/Users/home/vjeux/create-react-app/react-scripts-0.22.0.tgz"')
+ })
+ .parse(process.argv)
+
+if (typeof projectName === 'undefined') {
+ console.error('Error: no name given!');
+ console.log('Usage: ' + program.name() + ' ' + program.usage());
process.exit(1);
}
-createApp(commands[0], argv.verbose, argv['scripts-version']);
+createApp(projectName, program.verbose, program.scriptsVersion);
function createApp(name, verbose, version) {
var root = path.resolve(name);
@@ -21,8 +21,8 @@
},
"dependencies": {
"chalk": "^1.1.1",
+ "commander": "^2.9.0",
"cross-spawn": "^4.0.0",
- "minimist": "^1.2.0",
"path-exists": "^2.1.0",
"semver": "^5.0.3"
}
View
@@ -14,6 +14,11 @@
# Start in tasks/ even if run from root directory
cd "$(dirname "$0")"
+# CLI and app temporary locations
+# http://unix.stackexchange.com/a/84980
+temp_cli_path=`mktemp -d 2>/dev/null || mktemp -d -t 'temp_cli_path'`
+temp_app_path=`mktemp -d 2>/dev/null || mktemp -d -t 'temp_app_path'`
+
function cleanup {
echo 'Cleaning up.'
cd $root_path
@@ -53,15 +58,23 @@ set -x
cd ..
root_path=$PWD
+npm install
+
+# If the node version is < 4, the script should just give an error.
+if [ `node --version | sed -e 's/^v//' -e 's/\..\+//g'` -lt 4 ]
+then
+ cd $temp_app_path
+ err_output=`node "$root_path"/packages/create-react-app/index.js test-node-version 2>&1 > /dev/null || echo ''`
+ [[ $err_output =~ You\ are\ currently\ running\ Node\ v.+\ but\ create-react-app\ requires\ \>=4\. ]] && exit 0 || exit 1
+fi
+
if [ "$USE_YARN" = "yes" ]
then
# Install Yarn so that the test can use it to install packages.
npm install -g yarn@0.17.10 # TODO: remove version when https://github.com/yarnpkg/yarn/issues/2142 is fixed.
yarn cache clean
fi
-npm install
-
# Lint own code
./node_modules/.bin/eslint --ignore-path .gitignore ./
@@ -117,13 +130,10 @@ mv package.json.orig package.json
# ******************************************************************************
# Install the CLI in a temporary location
-# http://unix.stackexchange.com/a/84980
-temp_cli_path=`mktemp -d 2>/dev/null || mktemp -d -t 'temp_cli_path'`
cd $temp_cli_path
npm install $cli_path
# Install the app in a temporary location
-temp_app_path=`mktemp -d 2>/dev/null || mktemp -d -t 'temp_app_path'`
cd $temp_app_path
create_react_app --scripts-version=$scripts_path test-app
@@ -185,7 +195,6 @@ npm test -- --watch=no
# Test the server
npm start -- --smoke-test
-
# ******************************************************************************
# Test --scripts-version with a version number
# ******************************************************************************

0 comments on commit 7f9fb29

Please sign in to comment.