Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
branch: master
Commits on Aug 12, 2011
  1. Patch for Issue #20

    authored
Commits on Jul 15, 2011
  1. @kof
  2. @kof
Commits on May 30, 2011
  1. @kof
Commits on May 5, 2011
  1. @kof

    Merge pull request #30 from nmorse/patch-1

    kof authored
    I didn't know what 'jte' was, thought it should be 'jqtpl'?
  2. @nmorse
Commits on Apr 30, 2011
  1. @kof

    update inline doc

    kof authored
  2. @kof
Commits on Apr 28, 2011
  1. @kof

    Closes #29. Express don't pass cache=false/true option any more, so i…

    kof authored
    …t was interpreted as false and after firest rendering, cache was removed, so the next render call was trying to render a template using filename which is not in cache and was interpreted as a template
Commits on Apr 25, 2011
  1. @kof

    Closes #27. Implemented layout tag which is using layout method from …

    kof authored
    …express, so since express@2.2.1
Commits on Apr 19, 2011
  1. @kof

    inc version

    kof authored
  2. @aseemk @kof

    Fix bug in HTML-escaping apostrophe.

    aseemk authored kof committed
Commits on Apr 12, 2011
  1. @kof

    fix package.json

    kof authored
Commits on Apr 11, 2011
  1. @kof

    fix package.json

    kof authored
  2. @kof

    docs

    kof authored
  3. @kof

    docs

    kof authored
  4. @kof

    add partials docs

    kof authored
  5. @kof
  6. @kof

    update docs

    kof authored
  7. @kof
Commits on Apr 1, 2011
  1. @laurie71
  2. @laurie71

    Fix #16, #22

    laurie71 authored
    While I appreciate that the original jQuery plugin has the same
    issue, this is a real problem affecting people today, and it's
    a trivial fix. These issues are easily resolved by escaping,
    rather than removing, line-break characters.
Commits on Mar 7, 2011
  1. @kof

    support for express 2.0

    kof authored
  2. @laurie71

    Provisional support for Express 2.

    laurie71 authored
    Add support for Express 2.0 `compile()` method.
    This makes jqtpl compatible with Express 2.0.
    Backwards compatible with prior versions of
    Express, by virtue of leaving the existing
    `render()` method untouched.
    
    There are no new tests included, and I haven't
    verified the old tests still pass, as I can't
    get qunit to run on Node 0.4.2... :(
  3. @laurie71

    Correct express dependency for the .91 version.

    laurie71 authored
    The .91 release doesn't work with Express 2.0.0beta.
    It should be re-published to the npm registry with
    this change, to avoid compatibility issues.
    
    Ideally, older versions would also get this change
    and a re-publish, to ensure minimum confusion...
Commits on Mar 6, 2011
  1. @kof

    inc version

    kof authored
Commits on Mar 3, 2011
  1. @defunctzombie

    move qunit to devDependencies

    defunctzombie authored
    normal users will not need this
Commits on Feb 18, 2011
  1. @kof

    add keyword

    kof authored
Commits on Feb 17, 2011
  1. @kof

    Closes #14. fixed issue if passing array to tmpl tag. some workaround…

    kof authored
    …s are ugly, added tests
Commits on Feb 15, 2011
  1. @kof

    add test for express partial method, change description, add note abo…

    kof authored
    …ut jsons inside of template tags
Commits on Feb 14, 2011
  1. @kof
  2. @kof

    Closes #14. Fixed issue with partials using tmpl tag, use util.debug …

    kof authored
    …for debug option instead of util.print, rewrite tests based on qunit, add as dependency
Commits on Feb 11, 2011
  1. @kof

    pimp the version

    kof authored
Commits on Feb 10, 2011
  1. @kof
Something went wrong with that request. Please try again.