Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PIDFile= references path below legacy directory on Debian Buster #2474

Closed
gaia opened this issue Jul 17, 2019 · 3 comments
Closed

PIDFile= references path below legacy directory on Debian Buster #2474

gaia opened this issue Jul 17, 2019 · 3 comments

Comments

@gaia
Copy link

@gaia gaia commented Jul 17, 2019

Environment:

  • OS, including release name/version: Debian Buster 10
  • Fail2Ban installed via OS/distribution mechanisms

The issue:

upon systemctl enable fail2ban

systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.

shows up in the logs. both files exist

Expected behavior

no warning

Observed behavior

warning

Any additional information

uname -r is 5.0.15-1-pve (proxmox 6.0.4)

@gaia gaia changed the title PIDFile= references path below legacy directory PIDFile= references path below legacy directory on Debian Buster Jul 17, 2019
sebres added a commit that referenced this issue Jul 17, 2019
@sebres

This comment has been minimized.

Copy link
Member

@sebres sebres commented Jul 17, 2019

Fixed in d5a5efc.
Thanks!

@sebres sebres closed this Jul 17, 2019
@slrslr

This comment has been minimized.

Copy link

@slrslr slrslr commented Jan 24, 2020

Hello, @sebres sorry for bumping this, but i got this error:

systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.

On Raspberry Pi 4 with Raspbian 10 buster, 4.19.93-v7l+. "apt info fail2ban" shows:

Package: fail2ban
Version: 0.10.2-2.1
Priority: optional
Section: net
...
APT-Manual-Installed: yes
APT-Sources: http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages

You can do something about this, or i should ask somewhere else?

@sebres

This comment has been minimized.

Copy link
Member

@sebres sebres commented Jan 24, 2020

This is not an error (rather a warning)...
Should be updated by next release... If you want to update it right now by yourself:

  • patch your fail2ban.service like in the fix d5a5efc
  • run systemctl daemon-reload

and by next start you'd not see that anymore.

You could also search in /etc/fail2ban for /var/run/ and replace all occurrences with /run/.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.