Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow all versions of i18n from 1.6 up to 2 #1894

Merged
merged 2 commits into from Jan 11, 2020
Merged

Conversation

@orien
Copy link
Contributor

orien commented Jan 9, 2020

It's unlikely that any new features in i18n 1.x will be incompatible with faker.

Let's open up the version restriction to allow any version of 1.x after 1.6. Only when version 2 comes out should we expect breaking changes.

At the minute, downstream systems have to wait for a new release of faker, for every minor release of i18n.

Copy link
Contributor

connorshea left a comment

LGTM

@vbrazo
vbrazo approved these changes Jan 11, 2020
@vbrazo vbrazo merged commit 777b813 into faker-ruby:master Jan 11, 2020
1 check passed
1 check passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@orien orien deleted the orien:i18n-version-restriction branch Jan 11, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.