Skip to content
This repository has been archived by the owner. It is now read-only.

[Transporter Error Output]: Could not start delivery: all transports failed diagnostics #235

Closed
tuc0w opened this issue Jun 10, 2015 · 12 comments

Comments

@tuc0w
Copy link

commented Jun 10, 2015

Hey guys,

I'm getting a strange error message from deliver, I never used it before and did a fresh install. I'm not using a DeliverFile, just the command (deliver testflight -u xxx@xxx.xxx -a xxxxxxxxx) you see in the Screenshot attached:
deliver_bug

Any ideas, suggestions? I don't know why it fails since it works fine with Application Loader.

@KrauseFx

This comment has been minimized.

Copy link
Collaborator

commented Jun 10, 2015

That's a problem with your internet connection probably, could you try running it with a different connection? Also, do you have VPN and firewalls disabled?

@michalkalinowski-

This comment has been minimized.

Copy link

commented Jun 11, 2015

Hello,
I'm in a similar situation: I'm behind a firewall, but in settings of Application Loader I have disabled Signiant and Aspera protocols so that Application Loader uses only DAV protocol.

Now, when I upload an ipa directly from xcode (using Application loader I guess, that uses iTunes Transporter) everything works fine.

When I try to use deliver

deliver testflight <path to ipa>

I'm getting the same error as tucow.

Any idea how to specify transport protocol for itunes transporter?

@KrauseFx

This comment has been minimized.

Copy link
Collaborator

commented Jun 12, 2015

@michalkalinowski- you can try

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver

from #181

@michalkalinowski-

This comment has been minimized.

Copy link

commented Jun 12, 2015

Thanks, that solved the issue!

@KrauseFx KrauseFx closed this Jun 12, 2015
@tuc0w

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

Thanks for the replies, I was busy so I couldn't answer.
I will test this in my environment too, but where should I put the Param? Do I need to create a Deliver File for this?

@KrauseFx

This comment has been minimized.

Copy link
Collaborator

commented Jun 12, 2015

@tucow You can use

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver testflight <path to ipa>
@tuc0w

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

Thank you, will try it with the new app update later. To test other protocols, is it possibile to just pass them instead of DAV? Like:

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t Aspera" deliver testflight <path to ipa>
@KrauseFx

This comment has been minimized.

Copy link
Collaborator

commented Jun 12, 2015

Yes! 👍

@gholias

This comment has been minimized.

Copy link

commented Nov 4, 2015

could you provide an example of how I can use
DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver
in my Fastfile?

This is how Im trying to upload the .ipa

pilot(
      skip_submission: true,
    )
@KrauseFx

This comment has been minimized.

Copy link
Collaborator

commented Nov 5, 2015

@gholias

ENV["DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS"] = "-t DAV"
pilot...
@gholias

This comment has been minimized.

Copy link

commented Nov 5, 2015

Thanks @KrauseFx, it worked

@fastlanebot

This comment has been minimized.

Copy link

commented Mar 7, 2016

This issue was migrated to fastlane/fastlane#2294. Please post all further comments there.

fastlane is now a mono repo, you can read more about the change in our blog post. All tools are now available in the fastlane main repo 🚀

@fastlanebot fastlanebot added the migrated label Mar 7, 2016
@fastlane-old fastlane-old locked and limited conversation to collaborators Mar 11, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
5 participants
You can’t perform that action at this time.