New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Xcode 9 Export enterprise is not woking #11090

Closed
nageshkumarmishra opened this Issue Dec 1, 2017 · 10 comments

Comments

Projects
None yet
6 participants
@nageshkumarmishra

nageshkumarmishra commented Dec 1, 2017

bvkxtmyoftughvbzqbmjkwuqufjb/Build/Intermediates.noindex/ArchiveIntermediates/Sample/InstallationBuildProductsLocation/Applications/Sample.app�[0m
[06:50:51]: �[35m�[33m▸�[0m �[39;1mTouching�[0m Sample.app.dSYM�[0m
[06:50:52]: �[35m�[33m▸�[0m �[39;1mArchive�[0m Succeeded�[0m
[06:50:52]: �[33mGenerated plist file with the following values:�[0m
[06:50:52]: ▸ �[35m-----------------------------------------�[0m
[06:50:52]: ▸ �[35m{�[0m
[06:50:52]: ▸ �[35m "method": "enterprise"�[0m
[06:50:52]: ▸ �[35m}�[0m
[06:50:52]: ▸ �[35m-----------------------------------------�[0m
[06:50:52]: �[4m�[36m$ /usr/bin/xcrun /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.23.0/gym/lib/assets/wrap_xcodebuild/xcbuild-safe.sh -exportArchive -exportOptionsPlist '/var/folders/6g/08mp43t161xfmj452m2gtg980000gn/T/gym_config20171201-37009-l2rmb5.plist' -archivePath /Users/admin/Library/Developer/Xcode/Archives/2017-12-01/Sample\ 2017-12-01\ 06.47.23.xcarchive -exportPath '/var/folders/6g/08mp43t161xfmj452m2gtg980000gn/T/gym_output20171201-37009-19y5q8n' �[0m�[0m
RVM detected, forcing to use system ruby
Now using system ruby.
rbenv detected, removing env variables
rbenv: no such command `shell'

  • xcodebuild -exportArchive -exportOptionsPlist /var/folders/6g/08mp43t161xfmj452m2gtg980000gn/T/gym_config20171201-37009-l2rmb5.plist -archivePath '/Users/admin/Library/Developer/Xcode/Archives/2017-12-01/Sample 2017-12-01 06.47.23.xcarchive' -exportPath /var/folders/6g/08mp43t161xfmj452m2gtg980000gn/T/gym_output20171201-37009-19y5q8n
    2017-12-01 06:50:53.332 xcodebuild[42785:2029596] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path '/var/folders/6g/08mp43t161xfmj452m2gtg980000gn/T/Sample_2017-12-01_06-50-53.331.xcdistributionlogs'.
    2017-12-01 06:50:54.662 xcodebuild[42785:2029596] [MT] IDEDistribution: Step failed: <IDEDistributionSigningAssetsStep: 0x7fd38a489290>: Error Domain=IDEDistributionSigningAssetStepErrorDomain Code=0 "Locating signing assets failed." UserInfo={NSLocalizedDescription=Locating signing assets failed., IDEDistributionSigningAssetStepUnderlyingErrors=(
    "Error Domain=IDEProfileLocatorErrorDomain Code=1 "No profiles for 'com.sample.sample' were found" UserInfo={NSLocalizedDescription=No profiles for 'com.sample.sample' were found, NSLocalizedRecoverySuggestion=Xcode couldn't find any iOS In House provisioning profiles matching 'com.sample.tae2f92e0'. Automatic signing is disabled and unable to generate a profile. To enable automatic signing, pass -allowProvisioningUpdates to xcodebuild.}"
    )}
    error: exportArchive: No profiles for 'com.sample.sample' were found

Error Domain=IDEProfileLocatorErrorDomain Code=1 "No profiles for 'com.sample.sample' were found" UserInfo={NSLocalizedDescription=No profiles for 'com.sample.sample' were found, NSLocalizedRecoverySuggestion=Xcode couldn't find any iOS In House provisioning profiles matching 'com.sample.sample'. Automatic signing is disabled and unable to generate a profile. To enable automatic signing, pass -allowProvisioningUpdates to xcodebuild.}

** EXPORT FAILED **
[06:50:54]: �[31mExit status: 70�[0m
[06:50:54]: �[33m📋 For a more detailed error log, check the full log at:�[0m
[06:50:54]: �[33m📋 /Users/admin/Library/Logs/gym/Sample-Sample.log�[0m
+------------------+----------+
| �[33mLane Context�[0m |
+------------------+----------+
| DEFAULT_PLATFORM | ios |
| VERSION_NUMBER | 1.2.1 |
| BUILD_NUMBER | 1.2.1 |
| PLATFORM_NAME | ios |
| LANE_NAME | ios beta |
+------------------+----------+
[06:50:54]: �[31mError packaging up the application�[0m

+------+-------------------------------------+-------------+
| �[32mfastlane summary�[0m |
+------+-------------------------------------+-------------+
| Step | Action | Time (in s) |
+------+-------------------------------------+-------------+
| 1 | Verifying required fastlane version | 0 |
| 2 | default_platform | 0 |
| 3 | increment_version_number | 0 |
| 4 | get_version_number | 0 |
| 5 | increment_build_number | 0 |
| 6 | cocoapods | 4 |
| 💥 | �[31mgym�[0m | 214 |
+------+-------------------------------------+-------------+

[06:50:54]: �[31mfastlane finished with errors�[0m
�[31m
[!] Error packaging up the application�[0m
Build step 'Execute managed script' marked build as failure
Performing Post build task...
Match found for : : True
Logical operation result is TRUE


Above is the error message coming when I am using gym(scheme: "Sample",export_method: "enterprise")

-- Please let me know how can I fix this issue using Xcode 9.

@fastlane-bot

This comment has been minimized.

fastlane-bot commented Dec 1, 2017

It seems like this issue might be related to code signing 🚫

Have you seen our new Code Signing Troubleshooting Guide? It will help you resolve the most common code signing issues 👍

@fastlane-bot

This comment has been minimized.

fastlane-bot commented Dec 1, 2017

It seems like you have not included the output of fastlane env

To make it easier for us help you resolve this issue, please update the issue to include the output of fastlane env 👍

@janpio

This comment has been minimized.

Collaborator

janpio commented Dec 1, 2017

Error Domain=IDEProfileLocatorErrorDomain Code=1 "No profiles for 'com.sample.sample' were found" UserInfo={NSLocalizedDescription=No profiles for 'com.sample.sample' were found, NSLocalizedRecoverySuggestion=Xcode couldn't find any iOS In House provisioning profiles matching 'com.sample.sample'. Automatic signing is disabled and unable to generate a profile. To enable automatic signing, pass -allowProvisioningUpdates to xcodebuild.}

This looks wrong.

@ghost

This comment has been minimized.

ghost commented Dec 1, 2017

Ran into this myself recently. Xcode 9 changes some ways you do signing, for adhoc/appstore you can simply provide an export options.plist with the configuration you want. However I haven't been successful doing this for Enterprise.

Instead, I have to modify the xcodeproj to set
Manual
Teamid
Provisioning profile specifier
Code signing identity

Personally, I used the update_xcode_project plugin.

Setting those params as a step in fastlane fixes my export issues.

Sorry my response is short, on mobile

@oronbz

This comment has been minimized.

Contributor

oronbz commented Dec 3, 2017

Same as #11059

@oronbz

This comment has been minimized.

Contributor

oronbz commented Dec 4, 2017

@PetrosIchor this is not related to Xcode 9, this is a regression bug. It worked perfectly on 2.66.

@gcmleon

This comment has been minimized.

gcmleon commented Dec 7, 2017

I also had this issue trying to use an Ad-Hoc profile with the latest Fastlane version, 2.68.2.
Thanks to @oronbz comment, I changed to 2.66.0 and it worked.

@oronbz

This comment has been minimized.

Contributor

oronbz commented Dec 7, 2017

@gcmleon , this issue was resolved for me on 2.68.2, make sure you specify export_method: "ad-hoc" on gym.

@ohayon

This comment has been minimized.

Member

ohayon commented Dec 7, 2017

If it's cool with you folks, I am going to close this issue. Let us know if there are still issues and we can definitely reopen it!

@ohayon ohayon closed this Dec 7, 2017

@gcmleon

This comment has been minimized.

gcmleon commented Dec 11, 2017

@oronbz @ohayon Unfortunately that did not work for me. I tried specifying the method (also "ad-hoc" in my case) and specifying the provisioning profile name in the export_options.
Furthermore, I experimented changing the signing style and using the flag -allowProvisioningUpdates based on the discussion in #11073 but still didn't work. However, like I said, using 2.66.0 with my original code worked well.

@fastlane fastlane locked and limited conversation to collaborators Feb 9, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.