Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Transporter Error Output]: Could not start delivery: all transports failed diagnostics #2294

Closed
fastlanebot opened this issue Jun 10, 2015 · 13 comments

Comments

@fastlanebot
Copy link

commented Jun 10, 2015

Original issue by @tucow - Imported from fastlane/deliver#235

Hey guys,

I'm getting a strange error message from deliver, I never used it before and did a fresh install. I'm not using a DeliverFile, just the command (deliver testflight -u xxx@xxx.xxx -a xxxxxxxxx) you see in the Screenshot attached:
deliver_bug

Any ideas, suggestions? I don't know why it fails since it works fine with Application Loader.

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 10, 2015

@KrauseFx commented

That's a problem with your internet connection probably, could you try running it with a different connection? Also, do you have VPN and firewalls disabled?

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 11, 2015

@michalkalinowski- commented

Hello,
I'm in a similar situation: I'm behind a firewall, but in settings of Application Loader I have disabled Signiant and Aspera protocols so that Application Loader uses only DAV protocol.

Now, when I upload an ipa directly from xcode (using Application loader I guess, that uses iTunes Transporter) everything works fine.

When I try to use deliver

deliver testflight <path to ipa>

I'm getting the same error as tucow.

Any idea how to specify transport protocol for itunes transporter?

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@KrauseFx commented

@michalkalinowski- you can try

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver

from fastlane-old/deliver#181

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@michalkalinowski- commented

Thanks, that solved the issue!

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@tucow commented

Thanks for the replies, I was busy so I couldn't answer.
I will test this in my environment too, but where should I put the Param? Do I need to create a Deliver File for this?

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@KrauseFx commented

@tucow You can use

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver testflight <path to ipa>
@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@tucow commented

Thank you, will try it with the new app update later. To test other protocols, is it possibile to just pass them instead of DAV? Like:

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t Aspera" deliver testflight <path to ipa>
@fastlanebot

This comment has been minimized.

Copy link
Author

commented Jun 12, 2015

@KrauseFx commented

Yes! 👍

@fastlanebot

This comment has been minimized.

Copy link
Author

commented Nov 4, 2015

@gholias commented

could you provide an example of how I can use
DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t DAV" deliver
in my Fastfile?

This is how Im trying to upload the .ipa

pilot(
      skip_submission: true,
    )
@fastlanebot

This comment has been minimized.

Copy link
Author

commented Nov 5, 2015

@KrauseFx commented

@gholias

ENV["DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS"] = "-t DAV"
pilot...
@fastlanebot

This comment has been minimized.

Copy link
Author

commented Nov 5, 2015

@gholias commented

Thanks @KrauseFx, it worked

@meenakshi2710

This comment has been minimized.

Copy link

commented Aug 29, 2016

DELIVER_ITMSTRANSPORTER_ADDITIONAL_UPLOAD_PARAMETERS="-t Aspera" deliver testflight does not resolve the issue for me

@TKBurner

This comment has been minimized.

Copy link

commented Aug 30, 2016

Hi @meenakshi2710 Thanks for reaching out about this. Can you open a new issue with the issue template? I'd love to help 👍

@fastlane fastlane locked and limited conversation to collaborators Dec 6, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
3 participants
You can’t perform that action at this time.