New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Connection reset by peer #6553

Closed
thecb4 opened this Issue Oct 14, 2016 · 109 comments

Comments

Projects
None yet
@thecb4

thecb4 commented Oct 14, 2016

New Issue Checklist

While attempting to use match in my workflow, I am getting a "connection reset by peer error.

Complete output when running fastlane, including the stack trace and command used
+-----------------------+-----------------------------------------------+
|                        Summary for match 0.8.1                        |
+-----------------------+-----------------------------------------------+
| git_url               | git@gitlab.com:thecb4/XXXXXX.git |
| app_identifier        | io.thecb4.XXXXXX                |
| type                  | appstore                                      |
| verbose               | true                                          |
| git_branch            | master                                        |
| username              | cavelle@XXXXX                            |
| keychain_name         | login.keychain                                |
| readonly              | false                                         |
| team_id               | XXXXXX                                    |
| force                 | false                                         |
| shallow_clone         | false                                         |
| force_for_new_devices | false                                         |
| skip_docs             | false                                         |
+-----------------------+-----------------------------------------------+
INFO [2016-10-14 16:52:47.88]: Cloning remote git repo...
INFO [2016-10-14 16:52:47.89]: $ GIT_TERMINAL_PROMPT=0 git clone 'git@gitlab.com:thecb4/FastlaneMatchTheCB4.git' '/var/folders/yh/rbjzzgk50b7f5g8pnyrntf8r0000gn/T/d20161014-9928-1ycj0u6'
INFO [2016-10-14 16:52:47.91]: ▸ Cloning into '/var/folders/yh/rbjzzgk50b7f5g8pnyrntf8r0000gn/T/d20161014-9928-1ycj0u6'...
INFO [2016-10-14 16:52:49.50]: ▸ remote: Counting objects: 57, done.
INFO [2016-10-14 16:52:49.69]: ▸ remote: Compressing objects: 100% (53/53), done.
INFO [2016-10-14 16:52:49.84]: ▸ remote: Total 57 (delta 4), reused 0 (delta 0)
INFO [2016-10-14 16:52:49.84]: ▸ Receiving objects: 100% (57/57), 102.94 KiB | 0 bytes/s, done.
INFO [2016-10-14 16:52:49.84]: ▸ Resolving deltas: 100% (4/4), done.
INFO [2016-10-14 16:52:49.85]: ▸ Checking connectivity... done.
INFO [2016-10-14 16:52:49.97]: 🔓  Decrypted '--------.cer'
INFO [2016-10-14 16:52:50.06]: 🔓  Decrypted '--------.cer'
INFO [2016-10-14 16:52:50.15]: 🔓  Decrypted '--------.p12'
INFO [2016-10-14 16:52:50.25]: 🔓  Decrypted '--------.p12'
INFO [2016-10-14 16:52:50.34]: 🔓  Decrypted 'AppStore_io.thecb4.----.mobileprovision'
INFO [2016-10-14 16:52:50.43]: 🔓  Decrypted 'AppStore_io.thecb4.----.mobileprovision'
INFO [2016-10-14 16:52:50.52]: 🔓  Decrypted 'Development_io.thecb4.----.mobileprovision'
INFO [2016-10-14 16:52:50.62]: 🔓  Decrypted 'Development_io.thecb4.----.mobileprovision'
INFO [2016-10-14 16:52:50.62]: 🔓  Successfully decrypted certificates repo
INFO [2016-10-14 16:52:50.69]: Verifying that the certificate and profile are still valid on the Dev Portal...
INFO [2016-10-14 16:53:05.22]: 🔒  Successfully encrypted certificates repo
INFO [2016-10-14 16:53:05.23]: -------------------
INFO [2016-10-14 16:53:05.23]: --- Step: slack ---
INFO [2016-10-14 16:53:05.23]: -------------------
INFO [2016-10-14 16:53:05.68]: Successfully sent Slack notification
WARN [2016-10-14 16:53:05.68]: Variable Dump:
INFO [2016-10-14 16:53:05.68]: {:DEFAULT_PLATFORM=>:ios, :PLATFORM_NAME=>:ios, :LANE_NAME=>"ios release_internal_beta", :GIT_REPO_WAS_CLEAN_ON_START=>true}
ERROR [2016-10-14 16:53:05.68]: Connection reset by peer - SSL_connect

Configuration Files

Please copy the complete content of your Fastfile and any other configuration files you use below:

Fastfile:

  lane :bootstrap_provisions do |options|

    provision_type = "development"

    if options[:type] != nil
      provision_type = options[:type]
    end

    match(
      git_url: "git@gitlab.com:thecb4/----.git",
      app_identifier: "io.thecb4.----,
      type: provision_type,
      # readonly: true
      verbose: true
    )
  end

Environment

fastlane version (run fastlane -v):
fastlane 1.105.2
match 0.8.1

Do you use bundler to execute fastlane (i.e. bundle exec fastlane)? yes

Do you use a Ruby environment manager (e.g. chruby, rbenv, rvm)? no

What Xcode version do you use (e.g. 7.3, 8.0) 8.0

@johnryan

This comment has been minimized.

Show comment
Hide comment
@johnryan

johnryan Oct 14, 2016

The same just started happening for me, i've tried several things based on previous answers (reinstalling openSSL for instance) but no luck yet.

The same just started happening for me, i've tried several things based on previous answers (reinstalling openSSL for instance) but no luck yet.

@thecb4

This comment has been minimized.

Show comment
Hide comment
@thecb4

thecb4 Oct 14, 2016

Ok. I feel sane now. It was fine yesterday and now it doesn't like me.

thecb4 commented Oct 14, 2016

Ok. I feel sane now. It was fine yesterday and now it doesn't like me.

@klundberg

This comment has been minimized.

Show comment
Hide comment
@klundberg

klundberg Oct 14, 2016

This started happening earlier today for us with cert as well, so it may not just be match with the problem

This started happening earlier today for us with cert as well, so it may not just be match with the problem

@lukethoene

This comment has been minimized.

Show comment
Hide comment
@lukethoene

lukethoene Oct 14, 2016

Yep, it's happening during sigh for us

{:DEFAULT_PLATFORM=>:ios, :PLATFORM_NAME=>:ios, :LANE_NAME=>"ios publisher"}
[14:13:32]: Connection reset by peer - SSL_connect

Yep, it's happening during sigh for us

{:DEFAULT_PLATFORM=>:ios, :PLATFORM_NAME=>:ios, :LANE_NAME=>"ios publisher"}
[14:13:32]: Connection reset by peer - SSL_connect

@pcsaito

This comment has been minimized.

Show comment
Hide comment
@pcsaito

pcsaito Oct 14, 2016

Same here, after cleaning all profiles it worked only once

INFO [2016-10-14 18:13:56.53]: Verifying that the certificate and profile are still valid on the Dev Portal...
INFO [2016-10-14 18:14:15.98]: 🔒 Successfully encrypted certificates repo
WARN [2016-10-14 18:14:15.98]: Variable Dump:
INFO [2016-10-14 18:14:15.98]: {:DEFAULT_PLATFORM=>:ios, :PLATFORM_NAME=>:ios, :LANE_NAME=>"ios certificates"}
ERROR [2016-10-14 18:14:15.99]: Connection reset by peer - SSL_connect

pcsaito commented Oct 14, 2016

Same here, after cleaning all profiles it worked only once

INFO [2016-10-14 18:13:56.53]: Verifying that the certificate and profile are still valid on the Dev Portal...
INFO [2016-10-14 18:14:15.98]: 🔒 Successfully encrypted certificates repo
WARN [2016-10-14 18:14:15.98]: Variable Dump:
INFO [2016-10-14 18:14:15.98]: {:DEFAULT_PLATFORM=>:ios, :PLATFORM_NAME=>:ios, :LANE_NAME=>"ios certificates"}
ERROR [2016-10-14 18:14:15.99]: Connection reset by peer - SSL_connect

@cava23

This comment has been minimized.

Show comment
Hide comment

cava23 commented Oct 14, 2016

+1

@aronse

This comment has been minimized.

Show comment
Hide comment

aronse commented Oct 14, 2016

+1

@raphaelbaldi

This comment has been minimized.

Show comment
Hide comment

+1

@gaylejj

This comment has been minimized.

Show comment
Hide comment
@gaylejj

gaylejj Oct 14, 2016

Having this issue with "fastlane init" as well when it tries to use produce to create an app

gaylejj commented Oct 14, 2016

Having this issue with "fastlane init" as well when it tries to use produce to create an app

@craigho

This comment has been minimized.

Show comment
Hide comment
@craigho

craigho Oct 14, 2016

+1 -- apple issue?

craigho commented Oct 14, 2016

+1 -- apple issue?

@mofojed

This comment has been minimized.

Show comment
Hide comment

mofojed commented Oct 14, 2016

+1

@GlaucoNeves

This comment has been minimized.

Show comment
Hide comment

+1

@dpassage

This comment has been minimized.

Show comment
Hide comment
@dpassage

dpassage Oct 14, 2016

So we've discovered that this failure occurs if you use the system Ruby, i.e. /usr/bin/ruby, on OS X 10.11.6. Using Ruby 2.3.0 installed via RVM, this works fine.

So we've discovered that this failure occurs if you use the system Ruby, i.e. /usr/bin/ruby, on OS X 10.11.6. Using Ruby 2.3.0 installed via RVM, this works fine.

@davidgovea

This comment has been minimized.

Show comment
Hide comment
@davidgovea

davidgovea Oct 14, 2016

Thanks @dpassage! Installed ruby 2.3.0 via RVM, reinstalled fastlane gem, and we're up and running again.

Thanks @dpassage! Installed ruby 2.3.0 via RVM, reinstalled fastlane gem, and we're up and running again.

@rvi

This comment has been minimized.

Show comment
Hide comment
@rvi

rvi Oct 14, 2016

Same here, I just update my ruby version via rbenv:

brew update
brew install rbenv
rbenv install 2.2.4
rbenv global 2.2.4

Then you may need to modify your .bash_profile or .zshrc if you use zsh.
Add these 2 lines:

export PATH="$HOME/.rbenv/bin:$PATH"
eval "$(rbenv init -)"

Then you can reinstall fastlane.

It should work after a reboot :)

rvi commented Oct 14, 2016

Same here, I just update my ruby version via rbenv:

brew update
brew install rbenv
rbenv install 2.2.4
rbenv global 2.2.4

Then you may need to modify your .bash_profile or .zshrc if you use zsh.
Add these 2 lines:

export PATH="$HOME/.rbenv/bin:$PATH"
eval "$(rbenv init -)"

Then you can reinstall fastlane.

It should work after a reboot :)

@dpassage

This comment has been minimized.

Show comment
Hide comment
@dpassage

dpassage Oct 14, 2016

I haven't dug into this further, but I'm guessing that Apple changed what SSL ciphers are acceptable on the dev portal to something not used by default by the system ruby.

I haven't dug into this further, but I'm guessing that Apple changed what SSL ciphers are acceptable on the dev portal to something not used by default by the system ruby.

@gaylejj

This comment has been minimized.

Show comment
Hide comment
@gaylejj

gaylejj Oct 14, 2016

@dpassage Thanks a lot! Seems to be working great now.

gaylejj commented Oct 14, 2016

@dpassage Thanks a lot! Seems to be working great now.

@zineer

This comment has been minimized.

Show comment
Hide comment
@zineer

zineer Oct 14, 2016

Thanks for the fix!

brew install ruby
gem install fastlane

got me back in business

zineer commented Oct 14, 2016

Thanks for the fix!

brew install ruby
gem install fastlane

got me back in business

@dpassage

This comment has been minimized.

Show comment
Hide comment
@dpassage

dpassage Oct 15, 2016

It appears that https://developer.apple.com is no longer accepting TLS versions below 1.2:

$ curl --tlsv1.1 https://developer.apple.com
curl: (35) Server aborted the SSL handshake
$ curl --tlsv1.0 https://developer.apple.com
curl: (35) Server aborted the SSL handshake

Unfortunately, it appears that the system ruby on El Capitan doesn't support 1.2. :(

@KrauseFx looks like spaceship and thus match now have a dependency on newer versions of ruby :(. Or some major surgery to make faraday use a different SSL library.

It appears that https://developer.apple.com is no longer accepting TLS versions below 1.2:

$ curl --tlsv1.1 https://developer.apple.com
curl: (35) Server aborted the SSL handshake
$ curl --tlsv1.0 https://developer.apple.com
curl: (35) Server aborted the SSL handshake

Unfortunately, it appears that the system ruby on El Capitan doesn't support 1.2. :(

@KrauseFx looks like spaceship and thus match now have a dependency on newer versions of ruby :(. Or some major surgery to make faraday use a different SSL library.

@JotaMelo

This comment has been minimized.

Show comment
Hide comment
@JotaMelo

JotaMelo Oct 15, 2016

It started happening this afternoon for me, @zineer saved the day.

It started happening this afternoon for me, @zineer saved the day.

@pedro380085

This comment has been minimized.

Show comment
Hide comment

+1

@thecb4

This comment has been minimized.

Show comment
Hide comment
@thecb4

thecb4 Oct 15, 2016

Configuring for a different Ruby/Bundle took a lot of effort for some reason. Would be good to get some clean instructions.

thecb4 commented Oct 15, 2016

Configuring for a different Ruby/Bundle took a lot of effort for some reason. Would be good to get some clean instructions.

@Nimothy

This comment has been minimized.

Show comment
Hide comment
@Nimothy

Nimothy Oct 15, 2016

Tried updating ruby:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin16]

Still getting the same error, only happened after I ran:
bundle update

Nimothy commented Oct 15, 2016

Tried updating ruby:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin16]

Still getting the same error, only happened after I ran:
bundle update

@hjanuschka

This comment has been minimized.

Show comment
Hide comment
@hjanuschka

hjanuschka Oct 15, 2016

Member

have you guys tried - replace with you ruby version used:

rvm reinstall ruby-2.2.5 --with-openssl-dir=/usr/local
Member

hjanuschka commented Oct 15, 2016

have you guys tried - replace with you ruby version used:

rvm reinstall ruby-2.2.5 --with-openssl-dir=/usr/local
@nthegedus

This comment has been minimized.

Show comment
Hide comment
@nthegedus

nthegedus Oct 15, 2016

No one of this methods above worked with me =\

I still getting the "Connection reset by peer - SSL_connect" message

No one of this methods above worked with me =\

I still getting the "Connection reset by peer - SSL_connect" message

@JonasWestAlro

This comment has been minimized.

Show comment
Hide comment
@rompic

This comment has been minimized.

Show comment
Hide comment

rompic commented Oct 16, 2016

+1

@lifuzu

This comment has been minimized.

Show comment
Hide comment
@lifuzu

lifuzu Oct 16, 2016

@zineer way works for me, thanks!

lifuzu commented Oct 16, 2016

@zineer way works for me, thanks!

@pascalc

This comment has been minimized.

Show comment
Hide comment
@pascalc

pascalc Oct 16, 2016

After using rbenv to update ruby to version 2.3 and reinstalling fastlane, I had to do bundle exec fastlane for it to work again.

pascalc commented Oct 16, 2016

After using rbenv to update ruby to version 2.3 and reinstalling fastlane, I had to do bundle exec fastlane for it to work again.

@thecb4

This comment has been minimized.

Show comment
Hide comment
@thecb4

thecb4 Oct 16, 2016

Seems to work for me

$ rbenv install 2.3.1
$ rbenv global 2.3.1
$ gem install bundler -v 1.13.4
$ bundle install --path ./.gems --verbose
$ bundle exec fastlane --verbose your_lane

thecb4 commented Oct 16, 2016

Seems to work for me

$ rbenv install 2.3.1
$ rbenv global 2.3.1
$ gem install bundler -v 1.13.4
$ bundle install --path ./.gems --verbose
$ bundle exec fastlane --verbose your_lane
@fuchanghuan

This comment has been minimized.

Show comment
Hide comment
@fuchanghuan

fuchanghuan Oct 17, 2016

@zineer works for me,Thanks.

@zineer works for me,Thanks.

@getreup

This comment has been minimized.

Show comment
Hide comment
@getreup

getreup Oct 17, 2016

+1

none of the steps above have helped.

getreup commented Oct 17, 2016

+1

none of the steps above have helped.

@jk2K

This comment has been minimized.

Show comment
Hide comment
@jk2K

jk2K Oct 17, 2016

@zineer, There is another error now

Looking for related GitHub issues on fastlane/fastlane...

➡️  Version getters
   https://github.com/fastlane/fastlane/pull/504 [closed] 4 💬
   17 Aug 2015

/usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http/response.rb:120:in `error!': [!] 504 "Connection failed" (Faraday::ConnectionFailed)
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http/response.rb:129:in `value'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:920:in `connect'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:863:in `do_start'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:852:in `start'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:1398:in `request'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:1156:in `get'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:80:in `perform_request'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:40:in `block in call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:87:in `with_net_http_connection'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:32:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-cookie_jar-0.0.6/lib/faraday/cookie_jar.rb:22:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/rack_builder.rb:139:in `build_respon

jk2K commented Oct 17, 2016

@zineer, There is another error now

Looking for related GitHub issues on fastlane/fastlane...

➡️  Version getters
   https://github.com/fastlane/fastlane/pull/504 [closed] 4 💬
   17 Aug 2015

/usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http/response.rb:120:in `error!': [!] 504 "Connection failed" (Faraday::ConnectionFailed)
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http/response.rb:129:in `value'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:920:in `connect'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:863:in `do_start'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:852:in `start'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:1398:in `request'
    from /usr/local/Cellar/ruby/2.3.1_2/lib/ruby/2.3.0/net/http.rb:1156:in `get'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:80:in `perform_request'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:40:in `block in call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:87:in `with_net_http_connection'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/adapter/net_http.rb:32:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-cookie_jar-0.0.6/lib/faraday/cookie_jar.rb:22:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday_middleware-0.10.0/lib/faraday_middleware/response_middleware.rb:30:in `call'
    from /usr/local/lib/ruby/gems/2.3.0/gems/faraday-0.9.2/lib/faraday/rack_builder.rb:139:in `build_respon
@tefinger

This comment has been minimized.

Show comment
Hide comment

+1

@iTaa

This comment has been minimized.

Show comment
Hide comment

iTaa commented Oct 17, 2016

+1

@chstraube

This comment has been minimized.

Show comment
Hide comment

+1

@medslt

This comment has been minimized.

Show comment
Hide comment
@medslt

medslt Oct 17, 2016

The same problem here

medslt commented Oct 17, 2016

The same problem here

@rompic

This comment has been minimized.

Show comment
Hide comment
@rompic

rompic Oct 17, 2016

@zineer thx. also had to gem update --system before in order to fix rubygems/rubygems#1560 'no implicit conversion of nil into String' when trying to install fastlane.

rompic commented Oct 17, 2016

@zineer thx. also had to gem update --system before in order to fix rubygems/rubygems#1560 'no implicit conversion of nil into String' when trying to install fastlane.

@joamafer

This comment has been minimized.

Show comment
Hide comment
@joamafer

joamafer Oct 17, 2016

I had the same problem and I fixed it by doing the following:

  1. Follow the instructions here (https://developer.xamarin.com/guides/testcloud/calabash/configuring/osx/updating-ruby-using-rbenv/) to install rbenv and ruby-build.
  2. Run $ rbenv install 2.3.1 and rbenv global 2.3.1.
  3. Reinstall fastlane gem install fastlane.
  4. Restart the build server.

joamafer commented Oct 17, 2016

I had the same problem and I fixed it by doing the following:

  1. Follow the instructions here (https://developer.xamarin.com/guides/testcloud/calabash/configuring/osx/updating-ruby-using-rbenv/) to install rbenv and ruby-build.
  2. Run $ rbenv install 2.3.1 and rbenv global 2.3.1.
  3. Reinstall fastlane gem install fastlane.
  4. Restart the build server.
@medslt

This comment has been minimized.

Show comment
Hide comment
@medslt

medslt Oct 17, 2016

I fixed the problem by updating ruby:

brew install rbenv ruby-build

2)Add rbenv to bash so that it loads every time you open a terminal
echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bash_profile
source ~/.bash_profile

  1. Install Ruby
    rbenv install 2.3.1
    rbenv global 2.3.1
    ruby -v

medslt commented Oct 17, 2016

I fixed the problem by updating ruby:

brew install rbenv ruby-build

2)Add rbenv to bash so that it loads every time you open a terminal
echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bash_profile
source ~/.bash_profile

  1. Install Ruby
    rbenv install 2.3.1
    rbenv global 2.3.1
    ruby -v
@jacobvanorder

This comment has been minimized.

Show comment
Hide comment
@jacobvanorder

jacobvanorder Oct 18, 2016

Contributor

🐄 Holy cow. 🐄

For anyone using Bamboo as their CI solution, I had to install Bamboozled, a Bamboo plugin, to get Bamboo to use something other than the system Ruby.

This plugin will use RVM and Bundler along with Bundler exec. It was a combination of this that allowed me to use Ruby 2.3.1 along with fastlane.

Contributor

jacobvanorder commented Oct 18, 2016

🐄 Holy cow. 🐄

For anyone using Bamboo as their CI solution, I had to install Bamboozled, a Bamboo plugin, to get Bamboo to use something other than the system Ruby.

This plugin will use RVM and Bundler along with Bundler exec. It was a combination of this that allowed me to use Ruby 2.3.1 along with fastlane.

@chappejw

This comment has been minimized.

Show comment
Hide comment
@chappejw

chappejw Oct 18, 2016

I had luck getting all my fastlane tools to work again after mysteriously encountering this error after making use of a web debugger named Charles ( which seemed to have changed my OpenSSL )

The step that made the difference for me was in symlinking my Open SSL so I was using the correct version

`ln -s /usr/local/Cellar/openssl/1.0.2j/bin/openssl /usr/local/bin/openssl`

found at this site
http://tonyle.ca/blog/?p=101

I had luck getting all my fastlane tools to work again after mysteriously encountering this error after making use of a web debugger named Charles ( which seemed to have changed my OpenSSL )

The step that made the difference for me was in symlinking my Open SSL so I was using the correct version

`ln -s /usr/local/Cellar/openssl/1.0.2j/bin/openssl /usr/local/bin/openssl`

found at this site
http://tonyle.ca/blog/?p=101

@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Oct 18, 2016

@chappejw @jacobvanorder Glad to hear you guys got up and running. Let me know if there are any changes we can make to improve this.

@chappejw @jacobvanorder Glad to hear you guys got up and running. Let me know if there are any changes we can make to improve this.

@getreup

This comment has been minimized.

Show comment
Hide comment
@getreup

getreup Oct 21, 2016

I had to link my ruby after installing:

brew link ruby

and if that doesn't work, follow the comment to force a link or do it safely.

getreup commented Oct 21, 2016

I had to link my ruby after installing:

brew link ruby

and if that doesn't work, follow the comment to force a link or do it safely.

@scottrhoyt

This comment has been minimized.

Show comment
Hide comment
@scottrhoyt

scottrhoyt Oct 23, 2016

Contributor

For those of you attempting the brew install ruby method and when you gem install fastlane you get the error:

ERROR: While executing gem ... (TypeError)
no implicit conversion of nil into String

Try updating your rubygems system with gem update --system.

Contributor

scottrhoyt commented Oct 23, 2016

For those of you attempting the brew install ruby method and when you gem install fastlane you get the error:

ERROR: While executing gem ... (TypeError)
no implicit conversion of nil into String

Try updating your rubygems system with gem update --system.

@ivanicspeter92

This comment has been minimized.

Show comment
Hide comment
@jlubeck

This comment has been minimized.

Show comment
Hide comment
@jlubeck

jlubeck Oct 24, 2016

I know this is not fastlane specific but I'm running out of options. I managed to update everything These are my current versions:

jan$ ruby -v
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin16
jan$ openssl version
OpenSSL 1.0.2j  26 Sep 2016

And I'm still getting the same Connection reset by peer - SSL_connect error.

Any idea what else I might try?

Thank you

jlubeck commented Oct 24, 2016

I know this is not fastlane specific but I'm running out of options. I managed to update everything These are my current versions:

jan$ ruby -v
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin16
jan$ openssl version
OpenSSL 1.0.2j  26 Sep 2016

And I'm still getting the same Connection reset by peer - SSL_connect error.

Any idea what else I might try?

Thank you

@geraldWilliam

This comment has been minimized.

Show comment
Hide comment
@geraldWilliam

geraldWilliam Oct 24, 2016

@jlubeck If you're using rbenv, I made sure that my openssl and ruby were on the correct versions and still got the "Connection reset by peer" error until I ran rbenv rehash. That fixed it.

geraldWilliam commented Oct 24, 2016

@jlubeck If you're using rbenv, I made sure that my openssl and ruby were on the correct versions and still got the "Connection reset by peer" error until I ran rbenv rehash. That fixed it.

@jlubeck

This comment has been minimized.

Show comment
Hide comment
@jlubeck

jlubeck Oct 24, 2016

@geraldWilliam still no luck for me :(

jlubeck commented Oct 24, 2016

@geraldWilliam still no luck for me :(

@jlubeck

This comment has been minimized.

Show comment
Hide comment
@jlubeck

jlubeck Oct 24, 2016

mmm that's weird.... didn't do anything new after my last post, and now it's working!

jlubeck commented Oct 24, 2016

mmm that's weird.... didn't do anything new after my last post, and now it's working!

@ivanicspeter92

This comment has been minimized.

Show comment
Hide comment
@ivanicspeter92

ivanicspeter92 Oct 25, 2016

My issues were resolved by executing the following commands

brew update && brew install ruby
sudo gem install fastlane
sudo gem update produce
sudo gem update sigh

ivanicspeter92 commented Oct 25, 2016

My issues were resolved by executing the following commands

brew update && brew install ruby
sudo gem install fastlane
sudo gem update produce
sudo gem update sigh
@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Oct 25, 2016

@ivanicspeter92 Awesome! Glad to hear you got up and running.

@ivanicspeter92 Awesome! Glad to hear you got up and running.

@danieljimenez

This comment has been minimized.

Show comment
Hide comment
@danieljimenez

danieljimenez Oct 26, 2016

Is it not possible to get this working with the macOS system ruby? I'm running El Cap and am running into this issue.

Is it not possible to get this working with the macOS system ruby? I'm running El Cap and am running into this issue.

@chappejw

This comment has been minimized.

Show comment
Hide comment
@chappejw

chappejw Oct 27, 2016

A couple key steps which are not mentioned here are that after updating your Ruby to version 2.3.1 etc ( at the time of this writing ), you will need to uninstall all of your ruby gems and re-install them to ensure everything is compatible, make sure you set your path to the new ruby in your .bash_profile or .bashrc, then re-install executable-hooks with the following command

sudo gem install --user-install executable-hooks

A couple key steps which are not mentioned here are that after updating your Ruby to version 2.3.1 etc ( at the time of this writing ), you will need to uninstall all of your ruby gems and re-install them to ensure everything is compatible, make sure you set your path to the new ruby in your .bash_profile or .bashrc, then re-install executable-hooks with the following command

sudo gem install --user-install executable-hooks

@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Oct 28, 2016

@danieljimenez On El Cap you should be able to get it to work with system ruby following the steps by @ivanicspeter92. You might need to use bundler (like bundle exec fastlane beta) in some cases. Let me know how it goes.

@chappejw Great point, are you using a tool to manage ruby like rvm or rebnev?

@danieljimenez On El Cap you should be able to get it to work with system ruby following the steps by @ivanicspeter92. You might need to use bundler (like bundle exec fastlane beta) in some cases. Let me know how it goes.

@chappejw Great point, are you using a tool to manage ruby like rvm or rebnev?

@danieljimenez

This comment has been minimized.

Show comment
Hide comment
@danieljimenez

danieljimenez Oct 28, 2016

@TKBurner running brew install ruby is no longer the system ruby. I mean the shipping ruby with macOS.

@TKBurner running brew install ruby is no longer the system ruby. I mean the shipping ruby with macOS.

@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Oct 28, 2016

@danieljimenez Sorry, I meant the last three commands, and xcode-seclect --install. Do you still get errors? Can you run fastlane env and past the output? Thanks so much 👍

@danieljimenez Sorry, I meant the last three commands, and xcode-seclect --install. Do you still get errors? Can you run fastlane env and past the output? Thanks so much 👍

@marbetschar

This comment has been minimized.

Show comment
Hide comment
@marbetschar

marbetschar Nov 1, 2016

@TKBurner I'm running into the exact same issue running El Cap on the CI machine. Running locally using macOS Sierra everything works as expected.

@TKBurner I'm running into the exact same issue running El Cap on the CI machine. Running locally using macOS Sierra everything works as expected.

@marbetschar

This comment has been minimized.

Show comment
Hide comment
@marbetschar

marbetschar Nov 1, 2016

@geraldWilliam @TKBurner using rbenv rehash did the trick! Thank you!!!!

@geraldWilliam @TKBurner using rbenv rehash did the trick! Thank you!!!!

@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Nov 2, 2016

@marbetschar Awesome! So glad to hear you got up and running. Always feel free to reach out. 👍

TKBurner commented Nov 2, 2016

@marbetschar Awesome! So glad to hear you got up and running. Always feel free to reach out. 👍

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Nov 4, 2016

I was running El Capitan 10.11.6 and ran into this problem today too.

I just installed brew and did:

  • brew update
  • brew install ruby

Ran my CI build script and it worked.

I should say that my fastlane tools (and other gems) are part of my gem file that get installed/updated via bundler every time I do a build, so I didn't have to manually update those gems.

ghost commented Nov 4, 2016

I was running El Capitan 10.11.6 and ran into this problem today too.

I just installed brew and did:

  • brew update
  • brew install ruby

Ran my CI build script and it worked.

I should say that my fastlane tools (and other gems) are part of my gem file that get installed/updated via bundler every time I do a build, so I didn't have to manually update those gems.

@cogentParadigm

This comment has been minimized.

Show comment
Hide comment
@cogentParadigm

cogentParadigm Nov 5, 2016

This is what ended up working for me using macports:

sudo port selfupdate
sudo port install ruby23
sudo port select --set ruby ruby23

follow these instructions to update gem http://guides.rubygems.org/ssl-certificate-update/

sudo gem install fastlane
sudo gem install match
cd /opt/local/etc/openssl
sudo wget http://curl.haxx.se/ca/cacert.pem
sudo mv cacert.pem cert.pem

then restart your terminal

cogentParadigm commented Nov 5, 2016

This is what ended up working for me using macports:

sudo port selfupdate
sudo port install ruby23
sudo port select --set ruby ruby23

follow these instructions to update gem http://guides.rubygems.org/ssl-certificate-update/

sudo gem install fastlane
sudo gem install match
cd /opt/local/etc/openssl
sudo wget http://curl.haxx.se/ca/cacert.pem
sudo mv cacert.pem cert.pem

then restart your terminal

@TKBurner

This comment has been minimized.

Show comment
Hide comment
@TKBurner

TKBurner Nov 7, 2016

@cogentParadigm We are still looking into a better long term solution. Expect and update on this thread in the coming week. Thanks!

TKBurner commented Nov 7, 2016

@cogentParadigm We are still looking into a better long term solution. Expect and update on this thread in the coming week. Thanks!

@jostster

This comment has been minimized.

Show comment
Hide comment
@jostster

jostster Nov 8, 2016

I'm having this exact same issue. I have updated system ruby, installed rbenv and rvm and still nothing is working. My issue, however is when running match My fastlane env is

<details><summary>✅ fastlane environment ✅</summary>

### Stack

| Key                 | Value                                         |
| ------------------- | --------------------------------------------- |
| OS                  | 10.11.6                                       |
| Ruby                | 2.3.1                                         |
| Bundler?            | false                                         |
| Xcode Path          | /Applications/Xcode.app/Contents/Developer/   |
| Xcode Version       | 8.1                                           |
| Git                 | git version 2.9.3 (Apple Git-75)              |
| Installation Source | /Users/bamboo-agent/.gem/bin/fastlane         |
| Host                | Mac OS X 10.11.6 (15G1108)                    |
| Ruby Lib Dir        | /Users/bamboo-agent/.rbenv/versions/2.3.1/lib |
| OpenSSL Version     | OpenSSL 1.0.2j  26 Sep 2016                   |


### fastlane files:

**No Fastfile found**


**No Appfile found**


### fastlane gems

| Gem                 | Version | Update-Status |
| ------------------- | ------- | ------------- |
| credentials_manager | 0.16.2  | ✅ Up-To-Date  |
| spaceship           | 0.37.0  | ✅ Up-To-Date  |
| fastlane_core       | 0.53.0  | ✅ Up-To-Date  |
| deliver             | 1.15.0  | ✅ Up-To-Date  |
| snapshot            | 1.16.3  | ✅ Up-To-Date  |
| frameit             | 3.0.0   | ✅ Up-To-Date  |
| pem                 | 1.4.0   | ✅ Up-To-Date  |
| cert                | 1.4.3   | ✅ Up-To-Date  |
| sigh                | 1.11.2  | ✅ Up-To-Date  |
| produce             | 1.3.0   | ✅ Up-To-Date  |
| gym                 | 1.12.0  | ✅ Up-To-Date  |
| pilot               | 1.12.0  | ✅ Up-To-Date  |
| scan                | 0.14.1  | ✅ Up-To-Date  |
| supply              | 0.7.1   | ✅ Up-To-Date  |
| match               | 0.10.0  | ✅ Up-To-Date  |
| screengrab          | 0.5.5   | ✅ Up-To-Date  |
| fastlane            | 1.107.0 | ✅ Up-To-Date  |


### Loaded fastlane plugins:

**No plugins Loaded**


<details><summary><b>Loaded gems</b></summary>

| Gem                       | Version      |
| ------------------------- | ------------ |
| did_you_mean              | 1.0.0        |
| highline                  | 1.7.8        |
| commander                 | 4.4.0        |
| terminal-table            | 1.4.5        |
| json                      | 1.8.3        |
| multipart-post            | 2.0.0        |
| faraday                   | 0.9.2        |
| faraday_middleware        | 0.10.0       |
| dotenv                    | 2.1.1        |
| net-ssh                   | 3.2.0        |
| net-sftp                  | 2.1.2        |
| plist                     | 3.1.0        |
| rubyzip                   | 1.1.7        |
| security                  | 0.1.3        |
| krausefx-shenzhen         | 0.14.10      |
| slack-notifier            | 1.5.1        |
| i18n                      | 0.7.0        |
| thread_safe               | 0.3.5        |
| tzinfo                    | 1.2.2        |
| minitest                  | 5.8.3        |
| activesupport             | 4.2.6        |
| CFPropertyList            | 2.3.3        |
| claide                    | 1.0.1        |
| colored                   | 1.2          |
| nanaimo                   | 0.2.2        |
| xcodeproj                 | 1.4.1        |
| rouge                     | 1.11.1       |
| xcpretty                  | 0.2.4        |
| terminal-notifier         | 1.7.1        |
| addressable               | 2.4.0        |
| credentials_manager       | 0.16.2       |
| multi_xml                 | 0.5.5        |
| unf_ext                   | 0.0.7.2      |
| unf                       | 0.1.4        |
| domain_name               | 0.5.20161021 |
| http-cookie               | 1.0.3        |
| faraday-cookie_jar        | 0.0.6        |
| fastimage                 | 1.6.8        |
| xcode-install             | 2.0.8        |
| word_wrap                 | 1.0.0        |
| multi_json                | 1.12.1       |
| babosa                    | 1.0.2        |
| excon                     | 0.54.0       |
| gh_inspector              | 1.0.2        |
| fastlane_core             | 0.53.0       |
| bundler                   | 1.13.6       |
| mini_magick               | 4.5.1        |
| xcpretty-travis-formatter | 0.0.4        |
| uber                      | 0.0.15       |
| representable             | 2.3.0        |
| retriable                 | 2.1.0        |
| mime-types-data           | 3.2016.0521  |
| mime-types                | 3.1          |
| hurley                    | 0.2          |
| little-plugger            | 1.1.4        |
| logging                   | 2.1.0        |
| jwt                       | 1.5.6        |
| memoist                   | 0.15.0       |
| os                        | 0.9.6        |
| signet                    | 0.7.3        |
| googleauth                | 0.5.1        |
| httpclient                | 2.8.2.4      |
| google-api-client         | 0.9.19       |
| io-console                | 0.4.5        |
</details>


*generated on:* **2016-11-08**
</details>

which clearly says ruby is now 2.3.1, but the SSL_Connect error still says RUBY_VERSION is 2.0.0. I have even rebooted the machine.

jostster commented Nov 8, 2016

I'm having this exact same issue. I have updated system ruby, installed rbenv and rvm and still nothing is working. My issue, however is when running match My fastlane env is

<details><summary>✅ fastlane environment ✅</summary>

### Stack

| Key                 | Value                                         |
| ------------------- | --------------------------------------------- |
| OS                  | 10.11.6                                       |
| Ruby                | 2.3.1                                         |
| Bundler?            | false                                         |
| Xcode Path          | /Applications/Xcode.app/Contents/Developer/   |
| Xcode Version       | 8.1                                           |
| Git                 | git version 2.9.3 (Apple Git-75)              |
| Installation Source | /Users/bamboo-agent/.gem/bin/fastlane         |
| Host                | Mac OS X 10.11.6 (15G1108)                    |
| Ruby Lib Dir        | /Users/bamboo-agent/.rbenv/versions/2.3.1/lib |
| OpenSSL Version     | OpenSSL 1.0.2j  26 Sep 2016                   |


### fastlane files:

**No Fastfile found**


**No Appfile found**


### fastlane gems

| Gem                 | Version | Update-Status |
| ------------------- | ------- | ------------- |
| credentials_manager | 0.16.2  | ✅ Up-To-Date  |
| spaceship           | 0.37.0  | ✅ Up-To-Date  |
| fastlane_core       | 0.53.0  | ✅ Up-To-Date  |
| deliver             | 1.15.0  | ✅ Up-To-Date  |
| snapshot            | 1.16.3  | ✅ Up-To-Date  |
| frameit             | 3.0.0   | ✅ Up-To-Date  |
| pem                 | 1.4.0   | ✅ Up-To-Date  |
| cert                | 1.4.3   | ✅ Up-To-Date  |
| sigh                | 1.11.2  | ✅ Up-To-Date  |
| produce             | 1.3.0   | ✅ Up-To-Date  |
| gym                 | 1.12.0  | ✅ Up-To-Date  |
| pilot               | 1.12.0  | ✅ Up-To-Date  |
| scan                | 0.14.1  | ✅ Up-To-Date  |
| supply              | 0.7.1   | ✅ Up-To-Date  |
| match               | 0.10.0  | ✅ Up-To-Date  |
| screengrab          | 0.5.5   | ✅ Up-To-Date  |
| fastlane            | 1.107.0 | ✅ Up-To-Date  |


### Loaded fastlane plugins:

**No plugins Loaded**


<details><summary><b>Loaded gems</b></summary>

| Gem                       | Version      |
| ------------------------- | ------------ |
| did_you_mean              | 1.0.0        |
| highline                  | 1.7.8        |
| commander                 | 4.4.0        |
| terminal-table            | 1.4.5        |
| json                      | 1.8.3        |
| multipart-post            | 2.0.0        |
| faraday                   | 0.9.2        |
| faraday_middleware        | 0.10.0       |
| dotenv                    | 2.1.1        |
| net-ssh                   | 3.2.0        |
| net-sftp                  | 2.1.2        |
| plist                     | 3.1.0        |
| rubyzip                   | 1.1.7        |
| security                  | 0.1.3        |
| krausefx-shenzhen         | 0.14.10      |
| slack-notifier            | 1.5.1        |
| i18n                      | 0.7.0        |
| thread_safe               | 0.3.5        |
| tzinfo                    | 1.2.2        |
| minitest                  | 5.8.3        |
| activesupport             | 4.2.6        |
| CFPropertyList            | 2.3.3        |
| claide                    | 1.0.1        |
| colored                   | 1.2          |
| nanaimo                   | 0.2.2        |
| xcodeproj                 | 1.4.1        |
| rouge                     | 1.11.1       |
| xcpretty                  | 0.2.4        |
| terminal-notifier         | 1.7.1        |
| addressable               | 2.4.0        |
| credentials_manager       | 0.16.2       |
| multi_xml                 | 0.5.5        |
| unf_ext                   | 0.0.7.2      |
| unf                       | 0.1.4        |
| domain_name               | 0.5.20161021 |
| http-cookie               | 1.0.3        |
| faraday-cookie_jar        | 0.0.6        |
| fastimage                 | 1.6.8        |
| xcode-install             | 2.0.8        |
| word_wrap                 | 1.0.0        |
| multi_json                | 1.12.1       |
| babosa                    | 1.0.2        |
| excon                     | 0.54.0       |
| gh_inspector              | 1.0.2        |
| fastlane_core             | 0.53.0       |
| bundler                   | 1.13.6       |
| mini_magick               | 4.5.1        |
| xcpretty-travis-formatter | 0.0.4        |
| uber                      | 0.0.15       |
| representable             | 2.3.0        |
| retriable                 | 2.1.0        |
| mime-types-data           | 3.2016.0521  |
| mime-types                | 3.1          |
| hurley                    | 0.2          |
| little-plugger            | 1.1.4        |
| logging                   | 2.1.0        |
| jwt                       | 1.5.6        |
| memoist                   | 0.15.0       |
| os                        | 0.9.6        |
| signet                    | 0.7.3        |
| googleauth                | 0.5.1        |
| httpclient                | 2.8.2.4      |
| google-api-client         | 0.9.19       |
| io-console                | 0.4.5        |
</details>


*generated on:* **2016-11-08**
</details>

which clearly says ruby is now 2.3.1, but the SSL_Connect error still says RUBY_VERSION is 2.0.0. I have even rebooted the machine.

@ohayon

This comment has been minimized.

Show comment
Hide comment
@ohayon

ohayon Nov 9, 2016

Member

Hey everyone, we've been working on a new way to install and use fastlane, all you have to do is to download fastlane.zip and double click the install file. This will install fastlane with all its Ruby and OpenSSL dependencies, and should all work out of the box.
We just finished building this, and would love your early feedback on this beta. Please let us know how it works for you and if you run into any problems 👍
Download the latest version here.

Member

ohayon commented Nov 9, 2016

Hey everyone, we've been working on a new way to install and use fastlane, all you have to do is to download fastlane.zip and double click the install file. This will install fastlane with all its Ruby and OpenSSL dependencies, and should all work out of the box.
We just finished building this, and would love your early feedback on this beta. Please let us know how it works for you and if you run into any problems 👍
Download the latest version here.

@wema1043

This comment has been minimized.

Show comment
Hide comment
@wema1043

wema1043 Nov 15, 2016

@ohwutup I tried your solution, but still getting same isue

@ohwutup I tried your solution, but still getting same isue

@ohayon

This comment has been minimized.

Show comment
Hide comment
@ohayon

ohayon Nov 15, 2016

Member

Hey @wema1043 could you share your output? And also confirm that which fastlane points to ~/.fastlane/... instead of a gem-installed version?

Member

ohayon commented Nov 15, 2016

Hey @wema1043 could you share your output? And also confirm that which fastlane points to ~/.fastlane/... instead of a gem-installed version?

@wema1043

This comment has been minimized.

Show comment
Hide comment
@wema1043

wema1043 Nov 16, 2016

Hei @ohwutup,
I Tried your solution with newest fastlane version from your .zip 1h later and everything worked fine.
Don't know what happened before.

Hei @ohwutup,
I Tried your solution with newest fastlane version from your .zip 1h later and everything worked fine.
Don't know what happened before.

@samingle

This comment has been minimized.

Show comment
Hide comment
@samingle

samingle Nov 18, 2016

Had all sorts of trouble getting this working following the homebrew-based instructions from the error output. If you were previously running the system ruby, and you upgraded to homebrew's ruby using the provided instructions, and you're using bundler to manage fastlane, you'll need to reinstall bundler once your ruby version has been upgraded (sudo gem install bundler did the job for me), otherwise fastlane won't see the new ruby version.

Had all sorts of trouble getting this working following the homebrew-based instructions from the error output. If you were previously running the system ruby, and you upgraded to homebrew's ruby using the provided instructions, and you're using bundler to manage fastlane, you'll need to reinstall bundler once your ruby version has been upgraded (sudo gem install bundler did the job for me), otherwise fastlane won't see the new ruby version.

@FrederikLi

This comment has been minimized.

Show comment
Hide comment
@FrederikLi

FrederikLi Nov 22, 2016

@ohwutup solution works perfectly. Thanks!

@ohwutup solution works perfectly. Thanks!

@leoniralves

This comment has been minimized.

Show comment
Hide comment
@leoniralves

leoniralves Dec 7, 2016

What worked for me was to update Ruby for latest vesion (2.3.3), openssl (1.0.2) and reinstall Fastlane.
But I needed to restart my system and manually set PATH of updated openssl.
http://tonyle.ca/blog/?p=101

What worked for me was to update Ruby for latest vesion (2.3.3), openssl (1.0.2) and reinstall Fastlane.
But I needed to restart my system and manually set PATH of updated openssl.
http://tonyle.ca/blog/?p=101

@KrauseFx

This comment has been minimized.

Show comment
Hide comment
@KrauseFx

KrauseFx Dec 8, 2016

Member

We updated our installation instructions to also include fastlane.zip, which solves this problem 🚀

Member

KrauseFx commented Dec 8, 2016

We updated our installation instructions to also include fastlane.zip, which solves this problem 🚀

@RishabhTayal

This comment has been minimized.

Show comment
Hide comment
@RishabhTayal

RishabhTayal Dec 9, 2016

Contributor

I tried installing the latest version of fastlane through zip. I tried @leoniralves solution (#6553 (comment)) . I tried @KrauseFx solution (#6553 (comment)). Still getting this issue.

Contributor

RishabhTayal commented Dec 9, 2016

I tried installing the latest version of fastlane through zip. I tried @leoniralves solution (#6553 (comment)) . I tried @KrauseFx solution (#6553 (comment)). Still getting this issue.

@RishabhTayal

This comment has been minimized.

Show comment
Hide comment
@RishabhTayal

RishabhTayal Dec 12, 2016

Contributor

Solved the issue. I tried installing ruby several times. The issue was related to something on my git server. Apparently there was some ssl issue with the git url.

Contributor

RishabhTayal commented Dec 12, 2016

Solved the issue. I tried installing ruby several times. The issue was related to something on my git server. Apparently there was some ssl issue with the git url.

@fastlane fastlane locked and limited conversation to collaborators Dec 12, 2016

@KrauseFx

This comment has been minimized.

Show comment
Hide comment
@KrauseFx

KrauseFx Dec 12, 2016

Member

I'll lock the conversation for this issue now, as there is a very high number of people subscribed. Please submit a new issue if you still experience this problem.

Member

KrauseFx commented Dec 12, 2016

I'll lock the conversation for this issue now, as there is a very high number of people subscribed. Please submit a new issue if you still experience this problem.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.