New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add warning that vis.mpl will be removed in v0.6 #335

Merged
merged 1 commit into from Nov 21, 2016

Conversation

Projects
None yet
2 participants
@rafaelmds
Member

rafaelmds commented Nov 21, 2016

Fixes #332

This PR is necessary to advise users to use matplotlib.pyplot module directly since vis.mpl will be removed in v0.6.

Checklist:

  • Make tests for new code (at least 80% coverage)
  • Create/update docstrings
  • Include relevant equations and citations in docstrings
  • Docstrings follow the style conventions
  • Code follows PEP8 style conventions
  • Code and docs have been spellchecked
  • Include new dependencies in doc/install.rst, environment.yml, ci/requirements-conda.txt and ci/requirements-pip.txt.
  • Documentation builds properly (run cd doc; make locally)
  • Changelog entry (leave for last to avoid conflicts)
  • Firt-time contributor? Add yourself to doc/contributors.rst (leave for last to avoid conflicts)
@leouieda

This comment has been minimized.

Member

leouieda commented Nov 21, 2016

This is perfect, thanks!

@leouieda leouieda changed the title from Add warning that this module will be removed in v0.6 to Add warning that vis.mpl will be removed in v0.6 Nov 21, 2016

@leouieda leouieda merged commit a33d37a into fatiando:master Nov 21, 2016

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage increased (+0.007%) to 73.444%
Details

@rafaelmds rafaelmds deleted the rafaelmds:mpl-remove-warning branch Nov 21, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment