Skip to content
No description or website provided.
PHP
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
database/migrations
resources/config
src
tests
.editorconfig
.gitattributes
.gitignore
.travis.yml
LICENSE
README.md
composer.json
phpunit.xml.dist
renovate.json

README.md

Laravel Questionable

Build Status PHP from Packagist Latest Version License

Installation

Require this package, with Composer, in the root directory of your project.

$ composer require artisanry/questionable

To get started, you'll need to publish the vendor assets and migrate:

php artisan vendor:publish --provider="Artisanry\Questionable\QuestionableServiceProvider" && php artisan migrate

Usage

Setup a Model

<?php

namespace App;

use Artisanry\Questionable\HasQuestions;
use Illuminate\Database\Eloquent\Model;

class Post extends Model
{
    use HasQuestions;
}

Ask a question

$post->createQuestion([
    'title' => 'Some title',
    'body' => 'Some body',
], $user);

Update a question

$post->updateQuestion(1, [
    'title' => 'new title',
    'body' => 'new body',
]);

Delete a question

$post->deleteQuestion(1);

Answer to a question

$question->createAnswer([
    'title' => 'Some title',
    'body' => 'Some body',
], $user);

Update an answer

$question->updateAnswer(1, [
    'title' => 'new title',
    'body' => 'new body',
]);

Delete an answer

$question->deleteAnswer(1);

Mark an answer as solution

$answer->markAsSolution();

Change log

Please see CHANGELOG for more information what has changed recently.

Contributing

Please see CONTRIBUTING and CONDUCT for details.

Testing

$ phpunit

Security

If you discover a security vulnerability within this package, please send an e-mail to hello@basecode.sh. All security vulnerabilities will be promptly addressed.

Credits

This project exists thanks to all the people who contribute.

License

Mozilla Public License Version 2.0 (MPL-2.0).

You can’t perform that action at this time.