Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Bump version to 0.3.1.1

  • Loading branch information...
commit dc224ce1cbda4f947f3d81cd0da21aa34d596686 1 parent adf65d8
Adam Bergmark authored March 19, 2013
11  README.md
Source Rendered
@@ -28,6 +28,11 @@ Features
28 28
 Changelog
29 29
 ---------
30 30
 
  31
+0.3.1.1.:
  32
+
  33
+* Hackage version now includes the example application
  34
+* Updated repository location
  35
+
31 36
 0.3.1.0:
32 37
 
33 38
 * Add `packages` flag in the config which lets you use other fay packages without using includeDirs
@@ -82,7 +87,7 @@ the recommended ones for development.
82 87
 
83 88
 Place your Fay .hs files in snaplets/fay/src. Note that a default
84 89
 devel.cfg will not be created if you have already created the fay
85  
-directory, if this happens to you move snaplets/fay, start your
  90
+directory. If this happens to you, move snaplets/fay, start your
86 91
 application, and then move the files back into snaplets/fay.
87 92
 
88 93
 Any requests to the specified directory (in this case /fay/) will
@@ -93,7 +98,7 @@ Example Application
93 98
 -------------------
94 99
 
95 100
 There is an example available in the `example` directory. It requires
96  
-[fay-jquery](http://www.github.com/faylang/fay-jquery).
  101
+fay-jquery [hackage](http://hackage.haskell.org/package/fay-jquery) [github](http://www.github.com/faylang/fay-jquery).
97 102
 
98 103
 
99 104
 Development Status
@@ -110,7 +115,7 @@ Fork on!
110 115
 
111 116
 Any enhancements are welcome.
112 117
 
113  
-The github master usually requires the latest fay master, available at
  118
+The github master may require the latest fay master, available at
114 119
 [faylang/fay](https://github.com/faylang/fay/).
115 120
 
116 121
 
2  example/example.cabal
@@ -32,7 +32,7 @@ Executable example
32 32
     , snap-core >= 0.9
33 33
     , snap-loader-static >= 0.9
34 34
     , snap-server >= 0.9
35  
-    , snaplet-fay >= 0.3.1.0
  35
+    , snaplet-fay >= 0.3.1.1
36 36
     , text >= 0.11
37 37
     , time >= 1.1 && < 1.5
38 38
     , xmlhtml >= 0.1
6  snaplet-fay.cabal
@@ -5,7 +5,7 @@ name:                snaplet-fay
5 5
 -- PVP summary:      +-+------- breaking API changes
6 6
 --                   | | +----- non-breaking API additions
7 7
 --                   | | | +--- code changes with no API change
8  
-version:             0.3.1.0
  8
+version:             0.3.1.1
9 9
 synopsis:            Fay integration for Snap with request- and pre-compilation.
10 10
 description:         Fay integration for Snap with request based compilation during development and precompilation in production.
11 11
                      For more information, please see <https://github.com/bergmark/snaplet-fay>.
@@ -15,7 +15,7 @@ author:              Adam Bergmark
15 15
 maintainer:          adam@edea.se
16 16
 homepage:            https://github.com/bergmark/snaplet-fay
17 17
 bug-reports:         https://github.com/bergmark/snaplet-fay/issues
18  
-category:            Web, Snap
  18
+category:            Web, Snap, Fay
19 19
 build-type:          Simple
20 20
 cabal-version:       >=1.8
21 21
 
@@ -39,7 +39,7 @@ library
39 39
     Snap.Snaplet.Fay.Internal, Paths_snaplet_fay
40 40
 
41 41
   build-depends:
42  
-      base         >= 4
  42
+      base         >= 4 && < 5
43 43
     , aeson        >= 0.6
44 44
     , bytestring   >= 0.9
45 45
     , configurator >= 0.2

0 notes on commit dc224ce

Please sign in to comment.
Something went wrong with that request. Please try again.