Permalink
Browse files

FCREPO-1144: Update bundled Tomcat from 6.0.29 to 6.0.35

Updates bundled Tomcat from 6.0.29 to 6.0.35

https://jira.duraspace.org/browse/FCREPO-1144
  • Loading branch information...
1 parent 392de68 commit 522635de4647efb35bc49f6d9ed14334bdbf6cba @eddies eddies committed Aug 24, 2012
View
@@ -137,7 +137,7 @@
<dependency>
<groupId>org.fcrepo</groupId>
<artifactId>apache-tomcat</artifactId>
- <version>6.0.29</version>
+ <version>6.0.35</version>
<type>zip</type>
</dependency>
@@ -10,7 +10,6 @@
import java.io.InputStream;
import org.dom4j.DocumentException;
-
import org.fcrepo.utilities.FileUtils;
import org.fcrepo.utilities.Zip;
import org.fcrepo.utilities.install.Distribution;
@@ -22,12 +21,13 @@
/**
* The profile for the servlet container bundled with the Fedora installer.
* History:
+ * Release 3.6.1 bundled Tomcat 6.0.35.
+ * Release 3.5 bundled Tomcat 6.0.29.
* Release 3.3 bundled Tomcat 6.0.20.
* Release 3.0 bundled Tomcat 5.5.26.
* Release 2.2 bundled Tomcat 5.0.28.
*
* @author Edwin Shin
- * @version $Id$
*/
public class BundledTomcat
extends Tomcat {
@@ -91,9 +91,10 @@ protected void installIncludedKeystore() throws InstallationFailedException {
File keystore = getIncludedKeystore();
if (!FileUtils.copy(is, new FileOutputStream(keystore))) {
- throw new InstallationFailedException("Copy to "
- + keystore.getAbsolutePath() + " failed.");
+ throw new InstallationFailedException("Copy to " +
+ keystore.getAbsolutePath() + " failed.");
}
+
} catch (IOException e) {
throw new InstallationFailedException(e.getMessage(), e);
}
@@ -3,8 +3,8 @@
# Note: These versions are hard coded and should be generated by Maven to match
# the actual dependencies.
-install.tomcat = apache-tomcat-6.0.29.zip
-install.tomcat.basename = apache-tomcat-6.0.29
+install.tomcat = apache-tomcat-6.0.35.zip
+install.tomcat.basename = apache-tomcat-6.0.35
install.jdbc.mysql = mysql-connector-java-5.1.20.jar
install.jdbc.derby = derby-10.8.2.2.jar
@@ -79,7 +79,7 @@ apim.ssl.required.validValues = true false
servlet.engine.label = Servlet engine
servlet.engine.description = \
Which servlet engine will Fedora be running in? \n\
-Enter 'included' to use the bundled Tomcat 6.0.20 server. \n\
+Enter 'included' to use the bundled Tomcat 6.0.35 server. \n\
To use your own, existing installation of Tomcat, enter 'existingTomcat'.\n\
Enter 'other' to use a different servlet container.
servlet.engine.defaultValue = included

0 comments on commit 522635d

Please sign in to comment.