Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

app.authenticate error : UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 2): * Error * #476

Closed
RileyDavidson-Evans opened this Issue Apr 9, 2017 · 5 comments

Comments

Projects
None yet
4 participants
@RileyDavidson-Evans
Copy link

RileyDavidson-Evans commented Apr 9, 2017

Steps to reproduce

using react native :
app.authenticate on the client

Expected behavior

Promise is returned with token or error

Actual behavior

UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 2): * Error *

System configuration

Tell us about the applicable parts of your setup.

Module versions (especially the part that's not working):

NodeJS version:

Operating System:

Browser Version:

React Native Version:

Module Loader:

@marshallswain

This comment has been minimized.

Copy link
Member

marshallswain commented Apr 9, 2017

Which module versions and React Native versions?

@RileyDavidson-Evans

This comment has been minimized.

Copy link
Author

RileyDavidson-Evans commented Apr 9, 2017

react native :

"dependencies": {
    "body-parser": "^1.17.1",
    "feathers": "^2.1.1",
    "feathers-authentication": "^1.2.1",
    "feathers-errors": "^2.6.3",
    "feathers-hooks": "^1.8.1",
    "feathers-localstorage": "^1.0.0",
    "feathers-memory": "^1.1.0",
    "feathers-rest": "^1.7.1",
    "feathers-socketio": "^1.5.2",
    "localstorage-memory": "^1.0.2",
    "react": "16.0.0-alpha.6",
    "react-native": "0.43.2",
    "socket.io-client": "^1.7.3"
  },

server :

"dependencies": {
    "body-parser": "^1.17.1",
    "compression": "^1.6.2",
    "cors": "^2.8.3",
    "feathers": "^2.1.1",
    "feathers-authentication": "^0.7.12",
    "feathers-configuration": "^0.3.3",
    "feathers-errors": "^2.6.3",
    "feathers-hooks": "^1.8.1",
    "feathers-mongoose": "^3.6.2",
    "feathers-rest": "^1.7.1",
    "feathers-socketio": "^1.5.2",
    "mongoose": "^4.9.3",
    "passport": "^0.3.2",
    "passport-facebook": "^2.1.1",
    "passport-facebook-token": "^3.3.0",
    "passport-google-oauth20": "^1.0.0",
    "passport-google-token": "^0.1.2",
    "serve-favicon": "^2.4.2",
    "winston": "^2.3.1"
  },
@marshallswain

This comment has been minimized.

Copy link
Member

marshallswain commented Apr 10, 2017

You have a module version mismatch. You should be using feathers-authentication-client in your RN app and feathers-authentication version ^1.2.1 on the server. Can you try that out and report back?

@daffl

This comment has been minimized.

Copy link
Member

daffl commented Apr 10, 2017

I think @marshallswain identified the problem. The issue with the bad error message is also being tracked in feathersjs/authentication-local#10.

@ekryski

This comment has been minimized.

Copy link
Member

ekryski commented Apr 11, 2017

Sounds good. Going to close until further notice, to keep things curated. @RileyDavidson-Evans let us know if that doesn't solve your problem and we can re-open.

@ekryski ekryski closed this Apr 11, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.