Skip to content
Browse files

Merge remote-tracking branch 'upstream/master'

  • Loading branch information...
2 parents a730e57 + 65d523b commit a25d872ab8e0ac2e3b4229ff432b51566eef0922 @fedegl committed Jun 15, 2011
View
2 VERSION
@@ -1 +1 @@
-0.2.5
+0.2.6
View
5 lib/delocalize/rails_ext/active_record.rb
@@ -1,4 +1,9 @@
require 'active_record/connection_adapters/abstract/schema_definitions'
+begin
+ require 'active_record/connection_adapters/column'
+rescue LoadError
+ # Not Rails 3.1, it seems
+end
# let's hack into ActiveRecord a bit - everything at the lowest possible level, of course, so we minimalize side effects
ActiveRecord::ConnectionAdapters::Column.class_eval do
View
2 test/rails2_app/config/environment.rb
@@ -1,7 +1,7 @@
# Be sure to restart your server when you modify this file
# Specifies gem version of Rails to use when vendor/rails is not present
-RAILS_GEM_VERSION = '2.3.8' unless defined? RAILS_GEM_VERSION
+RAILS_GEM_VERSION = '2.3.11' unless defined? RAILS_GEM_VERSION
# Bootstrap the Rails environment, frameworks, and default configuration
require File.join(File.dirname(__FILE__), 'boot')
View
4 test/rails3.1_app/.gitignore
@@ -0,0 +1,4 @@
+.bundle
+db/*.sqlite3
+log/*.log
+tmp/**/*
View
5 test/rails3.1_app/Gemfile
@@ -0,0 +1,5 @@
+source 'http://rubygems.org'
+
+gem 'rails', '3.1.0.beta1'
+gem 'sqlite3'
+gem 'delocalize', :path => '../../'
View
93 test/rails3.1_app/Gemfile.lock
@@ -0,0 +1,93 @@
+PATH
+ remote: ../../
+ specs:
+ delocalize (0.2.3)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (3.1.0.beta1)
+ actionpack (= 3.1.0.beta1)
+ mail (~> 2.3.0)
+ actionpack (3.1.0.beta1)
+ activemodel (= 3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6.0beta1)
+ rack (~> 1.3.0.beta)
+ rack-cache (~> 1.0.1)
+ rack-mount (~> 0.7.2)
+ rack-test (~> 0.6.0)
+ sprockets (~> 2.0.0.beta.2)
+ tzinfo (~> 0.3.27)
+ activemodel (3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ bcrypt-ruby (~> 2.1.4)
+ builder (~> 3.0.0)
+ i18n (~> 0.6.0beta1)
+ activerecord (3.1.0.beta1)
+ activemodel (= 3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ arel (~> 2.1.0)
+ tzinfo (~> 0.3.27)
+ activeresource (3.1.0.beta1)
+ activemodel (= 3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ activesupport (3.1.0.beta1)
+ multi_json (~> 1.0)
+ arel (2.1.0)
+ bcrypt-ruby (2.1.4)
+ builder (3.0.0)
+ erubis (2.7.0)
+ hike (1.0.0)
+ i18n (0.6.0beta1)
+ mail (2.3.0)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.16)
+ multi_json (1.0.1)
+ polyglot (0.3.1)
+ rack (1.3.0.beta)
+ rack-cache (1.0.1)
+ rack (>= 0.4)
+ rack-mount (0.7.2)
+ rack (>= 1.0.0)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.0)
+ rack (>= 1.0)
+ rails (3.1.0.beta1)
+ actionmailer (= 3.1.0.beta1)
+ actionpack (= 3.1.0.beta1)
+ activerecord (= 3.1.0.beta1)
+ activeresource (= 3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ bundler (~> 1.0)
+ railties (= 3.1.0.beta1)
+ railties (3.1.0.beta1)
+ actionpack (= 3.1.0.beta1)
+ activesupport (= 3.1.0.beta1)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ thor (~> 0.14.6)
+ rake (0.8.7)
+ sprockets (2.0.0.beta.2)
+ hike (~> 1.0)
+ rack (~> 1.0)
+ tilt (~> 1.0)
+ sqlite3 (1.3.3)
+ thor (0.14.6)
+ tilt (1.3)
+ treetop (1.4.9)
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.27)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ delocalize!
+ rails (= 3.1.0.beta1)
+ sqlite3
View
3 test/rails3.1_app/app/controllers/application_controller.rb
@@ -0,0 +1,3 @@
+class ApplicationController < ActionController::Base
+ protect_from_forgery
+end
View
2 test/rails3.1_app/app/helpers/application_helper.rb
@@ -0,0 +1,2 @@
+module ApplicationHelper
+end
View
14 test/rails3.1_app/app/views/layouts/application.html.erb
@@ -0,0 +1,14 @@
+<!DOCTYPE html>
+<html>
+<head>
+ <title>Rails3App</title>
+ <%= stylesheet_link_tag :all %>
+ <%= javascript_include_tag :defaults %>
+ <%= csrf_meta_tag %>
+</head>
+<body>
+
+<%= yield %>
+
+</body>
+</html>
View
44 test/rails3.1_app/config/application.rb
@@ -0,0 +1,44 @@
+require File.expand_path('../boot', __FILE__)
+
+require 'rails/all'
+
+# If you have a Gemfile, require the gems listed there, including any gems
+# you've limited to :test, :development, or :production.
+Bundler.require(:default, Rails.env) if defined?(Bundler)
+
+module Rails3App
+ class Application < Rails::Application
+ # Settings in config/environments/* take precedence over those specified here.
+ # Application configuration should go into files in config/initializers
+ # -- all .rb files in that directory are automatically loaded.
+
+ # Custom directories with classes and modules you want to be autoloadable.
+ # config.autoload_paths += %W(#{config.root}/extras)
+
+ # Only load the plugins named here, in the order given (default is alphabetical).
+ # :all can be used as a placeholder for all plugins not explicitly named.
+ # config.plugins = [ :exception_notification, :ssl_requirement, :all ]
+
+ # Activate observers that should always be running.
+ # config.active_record.observers = :cacher, :garbage_collector, :forum_observer
+
+ # Set Time.zone default to the specified zone and make Active Record auto-convert to this zone.
+ # Run "rake -D time" for a list of tasks for finding time zone names. Default is UTC.
+ # config.time_zone = 'Central Time (US & Canada)'
+
+ # The default locale is :en and all translations from config/locales/*.rb,yml are auto loaded.
+ # config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
+ # config.i18n.default_locale = :de
+
+ # JavaScript files you want as :defaults (application.js is always included).
+ # config.action_view.javascript_expansions[:defaults] = %w(jquery rails)
+
+ config.paths.config.database = File.expand_path(File.dirname(__FILE__) + '../../../database.yml')
+
+ # Configure the default encoding used in templates for Ruby 1.9.
+ config.encoding = "utf-8"
+
+ # Configure sensitive parameters which will be filtered from the log file.
+ config.filter_parameters += [:password]
+ end
+end
View
13 test/rails3.1_app/config/boot.rb
@@ -0,0 +1,13 @@
+require 'rubygems'
+
+# Set up gems listed in the Gemfile.
+gemfile = File.expand_path('../../Gemfile', __FILE__)
+begin
+ ENV['BUNDLE_GEMFILE'] = gemfile
+ require 'bundler'
+ Bundler.setup
+rescue Bundler::GemNotFound => e
+ STDERR.puts e.message
+ STDERR.puts "Try running `bundle install`."
+ exit!
+end if File.exist?(gemfile)
View
3 test/rails3.1_app/config/database.yml
@@ -0,0 +1,3 @@
+test:
+ adapter: sqlite3
+ database: ":memory:"
View
5 test/rails3.1_app/config/environment.rb
@@ -0,0 +1,5 @@
+# Load the rails application
+require File.expand_path('../application', __FILE__)
+
+# Initialize the rails application
+Rails3App::Application.initialize!
View
35 test/rails3.1_app/config/environments/test.rb
@@ -0,0 +1,35 @@
+Rails3App::Application.configure do
+ # Settings specified here will take precedence over those in config/environment.rb
+
+ # The test environment is used exclusively to run your application's
+ # test suite. You never need to work with it otherwise. Remember that
+ # your test database is "scratch space" for the test suite and is wiped
+ # and recreated between test runs. Don't rely on the data there!
+ config.cache_classes = true
+
+ # Log error messages when you accidentally call methods on nil.
+ config.whiny_nils = true
+
+ # Show full error reports and disable caching
+ config.consider_all_requests_local = true
+ config.action_controller.perform_caching = false
+
+ # Raise exceptions instead of rendering exception templates
+ config.action_dispatch.show_exceptions = false
+
+ # Disable request forgery protection in test environment
+ config.action_controller.allow_forgery_protection = false
+
+ # Tell Action Mailer not to deliver emails to the real world.
+ # The :test delivery method accumulates sent emails in the
+ # ActionMailer::Base.deliveries array.
+ config.action_mailer.delivery_method = :test
+
+ # Use SQL instead of Active Record's schema dumper when creating the test database.
+ # This is necessary if your schema can't be completely dumped by the schema dumper,
+ # like if you have constraints or database-specific column types
+ # config.active_record.schema_format = :sql
+
+ # Print deprecation notices to the stderr
+ config.active_support.deprecation = :stderr
+end
View
2 test/rails3_app/Gemfile
@@ -1,5 +1,5 @@
source 'http://rubygems.org'
-gem 'rails', '3.0.0'
+gem 'rails', '3.0.5'
gem 'sqlite3-ruby', :require => 'sqlite3'
gem 'delocalize', :path => '../../'
View
96 test/rails3_app/Gemfile.lock
@@ -1,79 +1,79 @@
PATH
- remote: /Users/clemens/.repositories/delocalize
+ remote: ../../
specs:
- delocalize (0.2.2)
+ delocalize (0.2.3)
GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.0)
- actionpack (= 3.0.0)
- mail (~> 2.2.5)
- actionpack (3.0.0)
- activemodel (= 3.0.0)
- activesupport (= 3.0.0)
+ actionmailer (3.0.5)
+ actionpack (= 3.0.5)
+ mail (~> 2.2.15)
+ actionpack (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
builder (~> 2.1.2)
erubis (~> 2.6.6)
- i18n (~> 0.4.1)
+ i18n (~> 0.4)
rack (~> 1.2.1)
- rack-mount (~> 0.6.12)
- rack-test (~> 0.5.4)
+ rack-mount (~> 0.6.13)
+ rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- activemodel (3.0.0)
- activesupport (= 3.0.0)
+ activemodel (3.0.5)
+ activesupport (= 3.0.5)
builder (~> 2.1.2)
- i18n (~> 0.4.1)
- activerecord (3.0.0)
- activemodel (= 3.0.0)
- activesupport (= 3.0.0)
- arel (~> 1.0.0)
+ i18n (~> 0.4)
+ activerecord (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
+ arel (~> 2.0.2)
tzinfo (~> 0.3.23)
- activeresource (3.0.0)
- activemodel (= 3.0.0)
- activesupport (= 3.0.0)
- activesupport (3.0.0)
- arel (1.0.1)
- activesupport (~> 3.0.0)
+ activeresource (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
+ activesupport (3.0.5)
+ arel (2.0.9)
builder (2.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
- i18n (0.4.1)
- mail (2.2.6)
+ i18n (0.5.0)
+ mail (2.2.15)
activesupport (>= 2.3.6)
- mime-types
- treetop (>= 1.4.5)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
mime-types (1.16)
polyglot (0.3.1)
- rack (1.2.1)
- rack-mount (0.6.13)
+ rack (1.2.2)
+ rack-mount (0.6.14)
rack (>= 1.0.0)
- rack-test (0.5.4)
+ rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.0)
- actionmailer (= 3.0.0)
- actionpack (= 3.0.0)
- activerecord (= 3.0.0)
- activeresource (= 3.0.0)
- activesupport (= 3.0.0)
- bundler (~> 1.0.0)
- railties (= 3.0.0)
- railties (3.0.0)
- actionpack (= 3.0.0)
- activesupport (= 3.0.0)
- rake (>= 0.8.4)
- thor (~> 0.14.0)
+ rails (3.0.5)
+ actionmailer (= 3.0.5)
+ actionpack (= 3.0.5)
+ activerecord (= 3.0.5)
+ activeresource (= 3.0.5)
+ activesupport (= 3.0.5)
+ bundler (~> 1.0)
+ railties (= 3.0.5)
+ railties (3.0.5)
+ actionpack (= 3.0.5)
+ activesupport (= 3.0.5)
+ rake (>= 0.8.7)
+ thor (~> 0.14.4)
rake (0.8.7)
sqlite3-ruby (1.2.5)
- thor (0.14.0)
- treetop (1.4.8)
+ thor (0.14.6)
+ treetop (1.4.9)
polyglot (>= 0.3.1)
- tzinfo (0.3.23)
+ tzinfo (0.3.25)
PLATFORMS
ruby
DEPENDENCIES
delocalize!
- rails (= 3.0.0)
+ rails (= 3.0.5)
sqlite3-ruby
View
2 test/test_helper.rb
@@ -7,7 +7,7 @@
require File.expand_path(File.join(File.dirname(__FILE__), "rails2_app/config/environment"))
require 'test_help'
else
- require File.expand_path(File.join(File.dirname(__FILE__), "rails3_app/config/environment"))
+ require File.expand_path(File.join(File.dirname(__FILE__), "rails#{rails_version}_app/config/environment"))
require 'rails/test_help'
end

0 comments on commit a25d872

Please sign in to comment.
Something went wrong with that request. Please try again.