Rails3 active_support/core_ext/time #42

Closed
rickr opened this Issue Sep 27, 2010 · 6 comments

Projects

None yet

6 participants

@rickr
rickr commented Sep 27, 2010

Rails 3, Ruby 1.9.2

On the require 'feedzirra' I get:

no such file to load -- active_support/core_ext/time

This seems to be related to issue 19?

Here is an updated hack:

--- feedzirra.rb    2010-09-27 02:33:51.000000000 -0500
+++ feedzirra.rb.works  2010-09-27 02:43:42.000000000 -0500
@@ -8,8 +8,9 @@ require 'sax-machine'
 require 'dryopteris'
 require 'uri'
 require 'active_support/basic_object'
-require 'active_support/core_ext/object'
-require 'active_support/core_ext/time' 
+#require 'active_support/core_ext/object'
+require 'active_support/core_ext'
+require 'active_support/time'

 require 'core_ext/date'
 require 'core_ext/string'
@dteoh
dteoh commented Oct 11, 2010

I'm having this problem as well. Applying rickr's patch fixed it for me.

Edit: turns out the docs are wrong. gem 'feedzirra' with rubygems.org as a source is the way to go.

@kurtheinrich

I had same problem but rickr's patch worked.

@archiloque
Contributor

moved core_ext to feedzirra/core_ext to avoid conflict

@archiloque archiloque closed this Jun 27, 2011
@tamaloa
tamaloa commented Aug 22, 2011

README.rdoc is still outdated.
It says to use github as a source to install feedzirra. This ends up in pauldix-feedzirra-0.0.18 being installed instead of feedzirra-0.0.31 from rubygems. Which still raises the above mentioned erorr

 no such file to load -- active_support/core_ext/time

(on ruby 1.8.7 and rails 3.0.10).

@archiloque
Contributor

Damn, never noticed this part, I'll fix it, thanks !

@ricola
ricola commented Nov 28, 2011

While trying to install feedzirra on Debian I still needed to install libcurl4-gnutls-dev.

This was part of the documentation that has been removed by commit 4a01234 and I guess would still be needed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment