Updating to automatic and multilanguage package #43

Closed
wants to merge 4 commits into
from

Conversation

Projects
None yet
2 participants

See the changes and apport changes if it's necessary

Antonio David Gellida Lavara added some commits Aug 26, 2013

Owner

ferventcoder commented Aug 26, 2013

Thanks, I will evaluate this and get back to you on it.

Owner

ferventcoder commented Jan 1, 2014

Still holding on this guy until I can test it properly.

@ferventcoder ferventcoder commented on the diff Feb 9, 2014

adobereader/tools/chocolateyInstall.ps1
@@ -1,8 +1,42 @@
-$silentArgs = '/sPB /msi /norestart /quiet ALLUSERS=1 EULA_ACCEPT=YES'
-$downloadUrl = '{{DownloadUrl}}'
+$packageName = 'adobereader'
+$installerType = 'EXE'
+$silentArgs = '/sAll /msi /norestart /quiet ALLUSERS=1 EULA_ACCEPT=YES'
+#$url = 'http://ardownload.adobe.com/pub/adobe/reader/win/{mainversion}.x/{version}/en_US/AdbeRdr{version:replace:.:}_en_US.exe'
@ferventcoder

ferventcoder Feb 9, 2014

Owner

This line is incorrect. {version:replace:.:} is a function of ketarin, not of powershell.

@adgellida

adgellida Feb 9, 2014

ok, adobereader isn't multi yet? u can do it manual but multi if not?

2014-02-09 21:33 GMT+01:00 Rob Reynolds notifications@github.com:

In adobereader/tools/chocolateyInstall.ps1:

@@ -1,8 +1,42 @@
-$silentArgs = '/sPB /msi /norestart /quiet ALLUSERS=1 EULA_ACCEPT=YES'
-$downloadUrl = '{{DownloadUrl}}'
+$packageName = 'adobereader'
+$installerType = 'EXE'
+$silentArgs = '/sAll /msi /norestart /quiet ALLUSERS=1 EULA_ACCEPT=YES'
+#$url = 'http://ardownload.adobe.com/pub/adobe/reader/win/{mainversion}.x/{version}/en_US/AdbeRdr{version:replace:.:}_en_US.exe'

This line is incorrect. version:replace:.:} is a function of ketarin, not
of powershell.

Reply to this email directly or view it on GitHubhttps://github.com/ferventcoder/chocolateyautomaticpackages/pull/43/files#r9570693
.

@ferventcoder

ferventcoder Feb 10, 2014

Owner

Note that you are attempting to call a KETARIN function in PowerShell which does not know {mainversion} {version} or {version.replace:.:}. This looks to be a copy/paste error. (Oh wait) you have this commented.

Nevermind. Ignore this. :)

Antonio David Gellida Lavara Update adobereader.xml
Can you check this?
0e0838b
Owner

ferventcoder commented Sep 24, 2014

I'm pulling in the gist of this into https://github.com/ferventcoder/chocolatey-packages

Hurray! But now I'm on the Open Source wave with your Sumatra package. For
all the other people it will be find, so delete:

<goog_1658066316>
https://chocolatey.org/packages/adobereader-de
https://chocolatey.org/packages/adobereader-jp
https://chocolatey.org/packages/simnetsa-adobereader-fr
https://chocolatey.org/packages/BR.AdobeReaderFR

Ok?

2014-09-24 15:11 GMT+02:00 Rob Reynolds notifications@github.com:

I'm pulling in the gist of this into
https://github.com/ferventcoder/chocolatey-packages


Reply to this email directly or view it on GitHub
#43 (comment)
.

adgellida closed this Mar 19, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment