Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

V 1.20 crashes #407

Closed
MAlfare opened this issue Jan 29, 2017 · 12 comments

Comments

@MAlfare
Copy link

commented Jan 29, 2017

Hi!
Crashes after displaying "connected to..." and on KONNWEI KW902 BT is on, Host flashes, OBD off.
Lenovo A3500 F Tablet, Android 4.4.2 and Motorola Moto G4+, Android 6.0.1.
Both worked with previous version.

@fesch

This comment has been minimized.

Copy link
Owner

commented Jan 29, 2017

What locales do you have in your settings?

@yoh-there

This comment has been minimized.

Copy link
Collaborator

commented Jan 29, 2017

Damn, I thought there was always fallback to the default language? Is that just in the XML layouts??

@MAlfare

This comment has been minimized.

Copy link
Author

commented Jan 29, 2017

@fesch: The language on my Android devices?
It is "Deutsch"

@fesch

This comment has been minimized.

Copy link
Owner

commented Jan 29, 2017

I've put my Android on "Deutsch" --> CanZE remains EN
If I chose "Français" --> CanZE becomes FR :-)

So no crash on my device!

@yoh-there

This comment has been minimized.

Copy link
Collaborator

commented Jan 29, 2017

Same here. Confused?

@fesch

This comment has been minimized.

Copy link
Owner

commented Jan 29, 2017

@MAlfare : What options do you have selected in the settings tab?
What happens if you switch you Android language to English?

I need to be able to reproduce the crash ...

@yoh-there

This comment has been minimized.

Copy link
Collaborator

commented Jan 29, 2017

Seems to fail only if SD card logging -> Fields is on, independant of Locale. That is my first analysis at least.

fesch pushed a commit that referenced this issue Jan 29, 2017
@fesch

This comment has been minimized.

Copy link
Owner

commented Jan 29, 2017

Indeed. That is reproducible.

I've uploaded a fix. Can you confirm it works at your side too?

@yoh-there

This comment has been minimized.

Copy link
Collaborator

commented Jan 29, 2017

Pulling. Hold on........

@yoh-there

This comment has been minimized.

Copy link
Collaborator

commented Jan 29, 2017

Fix confirmed!

@MAlfare

This comment has been minimized.

Copy link
Author

commented Jan 29, 2017

My settings, language set to English(UK)
screenshot_2017-01-29-19-40-43
screenshot_2017-01-29-19-41-48

@fesch

This comment has been minimized.

Copy link
Owner

commented Jan 29, 2017

Version 1.21 with fix has been uploaded and is waiting for validation and dispatching in the store.

@fesch fesch closed this Jan 29, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.