Permalink
Browse files

Dependencies

- updated readme with a hint to dependencies for the oniguruma gem
- updated .travis.yml with a before script to install libonig-dev as oniguruma dependency
  • Loading branch information...
1 parent c6191c9 commit 045fd74f801e7aa1cde355c125aed4ccc7c4da54 ffeldhaus committed May 7, 2013
Showing with 8 additions and 0 deletions.
  1. +4 −0 .travis.yml
  2. +4 −0 README.md
View
4 .travis.yml
@@ -1,4 +1,8 @@
language: ruby
+
+before_install:
+ - sudo apt-get install -qq libonig-dev
+
rvm:
- 1.8.7
- 1.9.3
View
4 README.md
@@ -8,6 +8,9 @@ rOCCI - A Ruby OCCI Framework
Requirements
------------
+Ruby
+* at least version 1.8.7 is required
+
The following setup is recommended
* usage of the Ruby Version Manager
@@ -18,6 +21,7 @@ The following libraries / packages may be required to use rOCCI
* libxslt-dev
* libxml2-dev
+* **only if using Ruby 1.8.7:** libonig-dev (Linux) or oniguruma (Mac)
To use rOCCI with Java, you need JRE 6 or 7. To build rOCCI for Java, you need JDK 6 or 7.

0 comments on commit 045fd74

Please sign in to comment.