Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Html5Boilerplate for Rails using compass-h5bp gem

tag: v0.0.3

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 app
Octocat-spinner-32 lib
Octocat-spinner-32 test
Octocat-spinner-32 vendor
Octocat-spinner-32 .gitignore
Octocat-spinner-32 Gemfile
Octocat-spinner-32 LICENSE
Octocat-spinner-32 README.md
Octocat-spinner-32 Rakefile
Octocat-spinner-32 html5-rails.gemspec
README.md

Html5 for Rails

Sensible Html5 defaults for Rails projects based on Html5 Boilerplate by Paul Irish, Divya Manian and many other fine folks.

(A rewrite of compass-html5-boilerplate that decouples the compass CSS library and adds Rails asset pipeline integration).

Installation

We're a bit light on documentation right now, but this should get you going...

In your Gemfile

group :assets do
  gem 'sass-rails'
  gem 'coffee-rails'
  gem 'uglifier'
  gem 'compass', '0.12.alpha.4'
  gem 'compass-h5bp'
end

gem 'haml-rails' #(Optional) to use haml

gem 'jquery-rails'
gem 'html5-rails', :git => 'git://github.com/sporkd/html5-rails.git'

Install

$ bundle install

Run generator

$ rails generate html5:install

Notes

[1] If you use --template-engine=haml (or haml-rails), the install generator will remove your application.html.erb layout and generate application.html.haml.

[2] If you're upgrading from compass-html5-boilerplate you may need to remove config/compass.rb before you can run the generators.

[3] I'm still organizing stuff to be as flexible as possible, so some paths might change. Just make sure you re-run generators when upgrading.

License

Copyright (c) 2010-2012 Peter Gumeson. See LICENSE for full license.

Something went wrong with that request. Please try again.