New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not work in IE7 and IE8 #78

Closed
akashthapa opened this Issue Jun 15, 2012 · 17 comments

Comments

Projects
None yet
7 participants
@akashthapa

akashthapa commented Jun 15, 2012

I tested http://fgnass.github.com/spin.js/ in IE7 and 8, it does not work

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
Timestamp: Fri, 15 Jun 2012 19:25:21 UTC

Message: Failed
Line: 2
Char: 571
Code: 0
URI: http://fgnass.github.com/spin.js/dist/spin.min.js?v=1.2.5

Message: 'Spinner' is undefined
Line: 225
Char: 9
Code: 0
URI: http://fgnass.github.com/spin.js/

Message: 'Spinner' is undefined
Line: 225
Char: 9
Code: 0
URI: http://fgnass.github.com/spin.js/

Message: 'Spinner' is undefined
Line: 225
Char: 9
Code: 0
URI: http://fgnass.github.com/spin.js/

Message: 'Spinner' is undefined
Line: 225
Char: 9
Code: 0
URI: http://fgnass.github.com/spin.js/

When I opened spin.min.js in NetBeans editor, it was showing the warning
'Function K does not always return a value'

Any luck?

@jeffbaun

This comment has been minimized.

Show comment
Hide comment
@jeffbaun

jeffbaun Jul 18, 2012

Having the same issue. Running IE8

jeffbaun commented Jul 18, 2012

Having the same issue. Running IE8

@dmr

This comment has been minimized.

Show comment
Hide comment
@dmr

dmr Oct 11, 2012

In my IE8, http://fgnass.github.com/spin.js/ works like a charm :)

dmr commented Oct 11, 2012

In my IE8, http://fgnass.github.com/spin.js/ works like a charm :)

@luwes

This comment has been minimized.

Show comment
Hide comment
@luwes

luwes Jan 21, 2013

var Spinner = function Spinner(o) {

That line was causing issues for me in IE8, after uglifying the code...
It's also a bit redundant I think, just use

function Spinner(o) {

luwes commented Jan 21, 2013

var Spinner = function Spinner(o) {

That line was causing issues for me in IE8, after uglifying the code...
It's also a bit redundant I think, just use

function Spinner(o) {

@dmr

This comment has been minimized.

Show comment
Hide comment
@dmr

dmr Jan 27, 2013

From my experience

var Spinner = function(0) {

should work.

dmr commented Jan 27, 2013

From my experience

var Spinner = function(0) {

should work.

fgnass added a commit that referenced this issue Jan 28, 2013

@kraftwer1

This comment has been minimized.

Show comment
Hide comment
@kraftwer1

kraftwer1 Jun 2, 2013

Same here, even though I'm using 1.3.

kraftwer1 commented Jun 2, 2013

Same here, even though I'm using 1.3.

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel Sep 20, 2013

1.3.2 doesn't work for me in IE7. I get a "Object expected" error.

Note that http://fgnass.github.io/spin.js still uses 1.2.8. There I get "'Spinner' is undefined".

daniel commented Sep 20, 2013

1.3.2 doesn't work for me in IE7. I get a "Object expected" error.

Note that http://fgnass.github.io/spin.js still uses 1.2.8. There I get "'Spinner' is undefined".

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Sep 20, 2013

Owner

@daniel http://fgnass.github.io/spin.js does use v1.3.2. The fact that the script is included with a ?v=1.2.8 parameter might be a little bit confusing though. This was just a cache-buster to prevent 1.2.7 from being served back than.

Owner

fgnass commented Sep 20, 2013

@daniel http://fgnass.github.io/spin.js does use v1.3.2. The fact that the script is included with a ?v=1.2.8 parameter might be a little bit confusing though. This was just a cache-buster to prevent 1.2.7 from being served back than.

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Sep 20, 2013

Owner

Do you guys have any toolbars or browser extensions installed? It works for me both in BrowserStack as well as in the IE7/8 VMs available at http://www.modern.ie/en-us/virtualization-tools

Owner

fgnass commented Sep 20, 2013

Do you guys have any toolbars or browser extensions installed? It works for me both in BrowserStack as well as in the IE7/8 VMs available at http://www.modern.ie/en-us/virtualization-tools

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Sep 20, 2013

Owner

... or some Windows group policies or IE's compatibility mode?

Owner

fgnass commented Sep 20, 2013

... or some Windows group policies or IE's compatibility mode?

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel Sep 20, 2013

No, I use a freshly installed IE7/Vista VM from that site.

daniel commented Sep 20, 2013

No, I use a freshly installed IE7/Vista VM from that site.

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel Sep 20, 2013

I tried all versions of spin.js from here on my site (without loading any other javascript), but couldn't get any version to work!

daniel commented Sep 20, 2013

I tried all versions of spin.js from here on my site (without loading any other javascript), but couldn't get any version to work!

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Sep 20, 2013

Owner

Here is screenshot of my IE7 VM. How does your's look like?

screen shot 2013-09-20 at 14 15 31

Owner

fgnass commented Sep 20, 2013

Here is screenshot of my IE7 VM. How does your's look like?

screen shot 2013-09-20 at 14 15 31

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel commented Sep 20, 2013

screen shot 2013-09-20 at 2 20 39 pm

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel commented Sep 20, 2013

ie7_-vista_1__running

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel Sep 20, 2013

It worked after restarting IE!

daniel commented Sep 20, 2013

It worked after restarting IE!

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Sep 20, 2013

Owner

Any idea why? Has it to with with what site you visited before? Please let me know if you find a way to reproduce it!

Owner

fgnass commented Sep 20, 2013

Any idea why? Has it to with with what site you visited before? Please let me know if you find a way to reproduce it!

@daniel

This comment has been minimized.

Show comment
Hide comment
@daniel

daniel Sep 20, 2013

No, I have no idea why. I can't reproduce it now.

daniel commented Sep 20, 2013

No, I have no idea why. I can't reproduce it now.

@fgnass fgnass closed this Nov 11, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment