New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spinner broke with Opera 12 update #87

Closed
hydr opened this Issue Jul 17, 2012 · 2 comments

Comments

Projects
None yet
2 participants
@hydr

hydr commented Jul 17, 2012

The latest update for Opera from 11.62 to 12.00 broke the spin.js. On this demo page http://fgnass.github.com/spin.js/ nothing is moving anymore. In my project only the first bar of the spinner is flashing but all other bars remain dark, so there is no turning effect.

Is this a bug in Opera or can the spin.js script be fixed to support opera again?

@fgnass

This comment has been minimized.

Show comment
Hide comment
@fgnass

fgnass Jul 17, 2012

Owner

Okay, that's strange. FWIW on http://fgnass.github.com/spin.js/example/settings.html the 1st element (at 3 o'clock) is blinking, but the others aren't. The keyframe animation that makes it blink is created dynamically. The first one works:

@-o-keyframes opacity-60-25-0-12 { 0% { opacity: 0.25 } 0.009999999776482582% { opacity: 0.25 } 0.019999999552965164% { opacity: 1 } 60.009998321533196% { opacity: 0.25 } 100% { opacity: 0.25 } }

... while the second doesn't:

@-o-keyframes opacity-60-25-1-12 { 0% { opacity: 0.25 } 8.34333324432373% { opacity: 0.25 } 8.353333473205566% { opacity: 1 } 68.34333038330078% { opacity: 0.25 } 100% { opacity: 0.25 } }
Owner

fgnass commented Jul 17, 2012

Okay, that's strange. FWIW on http://fgnass.github.com/spin.js/example/settings.html the 1st element (at 3 o'clock) is blinking, but the others aren't. The keyframe animation that makes it blink is created dynamically. The first one works:

@-o-keyframes opacity-60-25-0-12 { 0% { opacity: 0.25 } 0.009999999776482582% { opacity: 0.25 } 0.019999999552965164% { opacity: 1 } 60.009998321533196% { opacity: 0.25 } 100% { opacity: 0.25 } }

... while the second doesn't:

@-o-keyframes opacity-60-25-1-12 { 0% { opacity: 0.25 } 8.34333324432373% { opacity: 0.25 } 8.353333473205566% { opacity: 1 } 68.34333038330078% { opacity: 0.25 } 100% { opacity: 0.25 } }

@fgnass fgnass closed this in 430f524 Aug 10, 2012

@hydr

This comment has been minimized.

Show comment
Hide comment
@hydr

hydr Aug 10, 2012

Thank you for the fix! I tested it and it works perfect :)

hydr commented Aug 10, 2012

Thank you for the fix! I tested it and it works perfect :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment