Skip to content

filsv/iOSDeviceSupport

master
Switch branches/tags

Name already in use

A tag already exists with the provided branch name. Many Git commands accept both tag and branch names, so creating this branch may cause unexpected behavior. Are you sure you want to create this branch?
Code

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
October 18, 2016 14:06
November 16, 2016 14:57
February 18, 2018 21:11
April 13, 2018 17:03
May 22, 2022 11:30
June 8, 2022 08:41
6.0
October 18, 2016 14:06
6.1
October 18, 2016 14:06
7.0
October 18, 2016 14:06
7.1
October 18, 2016 14:06
8.0
October 18, 2016 14:06
8.1
October 18, 2016 14:06
8.2
October 18, 2016 14:06
8.3
October 18, 2016 14:06
8.4
October 18, 2016 14:06
9.0
October 18, 2016 14:06
9.1
October 18, 2016 14:06
9.2
October 18, 2016 14:06
October 18, 2016 14:06
February 19, 2022 15:00
February 19, 2022 15:00
February 19, 2022 15:00
February 19, 2022 15:00
February 19, 2022 15:01
February 19, 2022 15:01
February 19, 2022 15:01
September 16, 2018 20:47
September 16, 2018 19:40
February 19, 2022 15:01
February 19, 2022 15:02
December 17, 2018 22:59
February 19, 2022 15:02
February 19, 2022 15:02
February 19, 2022 15:02
February 6, 2020 08:29
June 23, 2020 19:35
September 21, 2020 10:14
August 6, 2021 17:07
August 2, 2021 09:54
December 14, 2021 18:31
January 29, 2022 18:05
January 29, 2022 18:04
May 22, 2022 11:32
February 19, 2022 14:59
February 19, 2022 14:59
February 19, 2022 14:59
February 19, 2022 14:59
September 3, 2022 19:09

iPhoneOSDeviceSupport

Xcode iPhoneOS DeviceSupport (6.0 - 16.0) [WatchOS | tvOS];

Most recent releases:

iOS 16.0 - Download
iOS 15.6 - Download
iOS 15.5 - Download
iOS 15.4 - Download
iOS 15.3 - Download
iOS 15.2 - Download
iOS 15.1 - Download
iOS 15.0 - Download

iOS 14+
iOS 14.7.1 - Download
iOS 14.7 - Download
iOS 14.6 - Download
iOS 14.5 - Download
iOS 14.4 - Download
iOS 14.3 - Download
iOS 14.2 - Download
iOS 14.1 - Download
iOS 14.0 - Download

iOS 13+
iOS 13.7 - Download
iOS 13.6 - Download
iOS 13.5 - Download
iOS 13.4 - Download
iOS 13.3 - Download
iOS 13.2 - Download
iOS 13.1 - Download
iOS 13.0 - Download

iOS 12+
iOS 12.4 - Download
iOS 12.4 (16G73) - Download
iOS 12.3 - Download
iOS 12.2 - Download
iOS 12.2 (16E5181e) - Download
iOS 12.1 - Download
iOS 12.1 (16B91) - Download
iOS 12.1 (16B5059d) - Download
iOS 12.0 - Download
iOS 12.0 (16A366) - Download

iOS 11+
iOS 11.4 - Download
iOS 11.4.1 (15G77) - Download
iOS 11.4 (15F79) - Download
iOS 11.4 (15F5061c) - Download
iOS 11.4 (15F5037c) - Download
iOS 11.3 - Download
iOS 11.3 (15E5178d) - Download
iOS 11.2 - Download
iOS 11.1 - Download
iOS 11.0 - Download

iOS 10+
iOS 10.3 - Download
iOS 10.3 (14E5265a) - Download
iOS 10.3 (14E5230d) - Download
iOS 10.2 - Download
iOS 10.1 - Download
iOS 10.0 - Download

iOS 9+
iOS 9.3 - Download
iOS 9.2 - Download
iOS 9.1 - Download
iOS 9.0 - Download

Note: If you need upper version of the support files less than 1 iteration (eg. You have "15.0" and you need "15.1.5" - You can simply rename folder from "15.0" to "15.1.5" and it should work or try to use next iteration version of the support files, is exist "15.2", otherwise open an issue);

⚠️ Warning ⚠️

Xcode 12 now encrypts the connection between Xcode and paired devices, protecting against an attacker in a privileged network position executing arbitrary code on connected iOS, iPadOS, watchOS, or tvOS devices during a remote debug session. (60386733)

These security benefits are available when Xcode 12 connects to devices running iOS 14, iPadOS 14, watchOS 7, tvOS 14, or later versions. 
These OS versions also refuse debugger connections from older Xcode releases. 
Xcode 12 continues to support debugging for older OS versions, but without the new encryption. 

Thank to this comment

For debugging in iOS 14 devices you need Xcode 12 atleast. 
Cause Apple have updated their code for debugging apps on iOS 14 and that is not compatible on older version of Xcode.

Thank to this comment

🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩🚩

- To get iOS 13.(version) [example iOS 13.5.1] works with iOS 14.0, just rename a folder.
- Like this: 13.5 ~> 13.5.1 (17F80);

How to support iOS 14 devices with Xcode 11.5+:
(tested with 11.6 (11E708))

Download iOS 14.2 Support Files
Unzip it
Put unzipped folder into path:
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
Restart Xcode

How to:

  1. Download version you need listed above;
  2. Unzip it;
  3. Close Xcode;
  4. Copy and paste unziped folder by path:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

hierarchy like this:

alt text

  1. Reopen Xcode;

Thank You.

Xcode usage license - Link.

About

Xcode iPhoneOS DeviceSupport files (6.0 - 15.4)

Resources

Stars

Watchers

Forks

Releases

No releases published

Packages

No packages published