Skip to content
Browse files

Require active_support 2.3 thanks to #tap, release 3.1.4

  • Loading branch information...
1 parent 6a4aba9 commit 2955ee21c645a975e35c02bc0d24fd273b534694 @Empact Empact committed Dec 18, 2009
Showing with 17 additions and 10 deletions.
  1. +6 −0 History.txt
  2. +1 −1 Rakefile
  3. +1 −1 VERSION
  4. +1 −1 lib/roxml.rb
  5. +8 −7 roxml.gemspec
View
6 History.txt
@@ -1,3 +1,9 @@
+== 3.1.4 (December 18, 2009)
+
+* bug fix
+
+ * require the necessary version of active support (#tap wasn't introduced until 2.3)
+
== 3.1.3 (October 30, 2009)
* minor enhancements
View
2 Rakefile
@@ -22,7 +22,7 @@ EOF
gem.extra_rdoc_files = ["History.txt", "Manifest.txt", "README.rdoc"]
- gem.add_dependency 'activesupport', '>= 2.1.0'
+ gem.add_dependency 'activesupport', '>= 2.3.0'
gem.add_dependency 'nokogiri', '>= 1.3.3'
gem.add_development_dependency "rspec"
View
2 VERSION
@@ -1 +1 @@
-3.1.3
+3.1.4
View
2 lib/roxml.rb
@@ -5,7 +5,7 @@
require 'roxml/xml'
module ROXML # :nodoc:
- VERSION = '3.1.3'
+ VERSION = '3.1.4'
def self.included(base) # :nodoc:
base.class_eval do
View
15 roxml.gemspec
@@ -1,15 +1,15 @@
# Generated by jeweler
-# DO NOT EDIT THIS FILE
-# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{roxml}
- s.version = "3.1.3"
+ s.version = "3.1.4"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ben Woosley", "Zak Mandhro", "Anders Engstrom", "Russ Olsen"]
- s.date = %q{2009-10-30}
+ s.date = %q{2009-12-18}
s.description = %q{ROXML is a Ruby library designed to make it easier for Ruby developers to work with XML.
Using simple annotations, it enables Ruby classes to be mapped to XML. ROXML takes care
of the marshalling and unmarshalling of mapped attributes so that developers can focus on
@@ -184,23 +184,24 @@ RESTful applications, Web Services, and XML-RPC.
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, [">= 2.1.0"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 2.3.0"])
s.add_runtime_dependency(%q<nokogiri>, [">= 1.3.3"])
s.add_development_dependency(%q<rspec>, [">= 0"])
s.add_development_dependency(%q<sqlite3-ruby>, [">= 1.2.4"])
s.add_development_dependency(%q<activerecord>, [">= 2.2.2"])
else
- s.add_dependency(%q<activesupport>, [">= 2.1.0"])
+ s.add_dependency(%q<activesupport>, [">= 2.3.0"])
s.add_dependency(%q<nokogiri>, [">= 1.3.3"])
s.add_dependency(%q<rspec>, [">= 0"])
s.add_dependency(%q<sqlite3-ruby>, [">= 1.2.4"])
s.add_dependency(%q<activerecord>, [">= 2.2.2"])
end
else
- s.add_dependency(%q<activesupport>, [">= 2.1.0"])
+ s.add_dependency(%q<activesupport>, [">= 2.3.0"])
s.add_dependency(%q<nokogiri>, [">= 1.3.3"])
s.add_dependency(%q<rspec>, [">= 0"])
s.add_dependency(%q<sqlite3-ruby>, [">= 1.2.4"])
s.add_dependency(%q<activerecord>, [">= 2.2.2"])
end
end
+

0 comments on commit 2955ee2

Please sign in to comment.
Something went wrong with that request. Please try again.