Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow bootstrapping on 10.14.5 w/ perl 5.18.4 #190

Open
wants to merge 8 commits into
base: master
from

Conversation

Projects
None yet
4 participants
@nieder
Copy link
Member

commented May 24, 2019

No description provided.

@nieder nieder requested a review from fink/core May 24, 2019

@nieder nieder added the Bootstrap label May 24, 2019

@nieder

This comment has been minimized.

Copy link
Member Author

commented May 26, 2019

bb608f2 and 4be81e2 are needed for bootstrapping.

e13ad45 is necessary, but I'm not sure sufficient , to create a new dist for 10.14.5.

@akhansen

This comment has been minimized.

Copy link
Member

commented May 26, 2019

Seems sensible to me.

@akhansen

This comment has been minimized.

Copy link
Member

commented May 26, 2019

Bootstrap worked for me (10.14.5/Xcode 10.2)

Fionna:fink hansen$ /tmp/sw/bin/fink list perl
Scanning package description files..........
Information about 319 packages read in 1 seconds.
p perl5184-core [virtual package]
p perlio-eol-pm51 [virtual package]
p perlobjcbridge- [virtual package]
i system-perl 5.18.4-1 [virtual package representing perl]
p system-perl5184 [virtual package]

&print_breaking("This system is supported and tested.");
$distribution = "10.14";
} elsif ($host =~ /^i386-apple-darwin18\.[6]/) {
&print_breaking("This system is supported and tested.");
$distribution = "10.14.5";
} elsif ($host =~ /^i386-apple-darwin18\./) {

This comment has been minimized.

Copy link
@PovlAbrahamsen

PovlAbrahamsen May 30, 2019

Shouldn't line 259 now read $distribution = "10.14.5";, to ensure that the newer distribution is used for future updates?

This comment has been minimized.

Copy link
@akhansen

akhansen Jun 3, 2019

Member

Yes, at least until Apple breaks things on us again.

This comment has been minimized.

Copy link
@nieder

nieder Jun 4, 2019

Author Member

fixed in 648179b

@mrvacbob

This comment has been minimized.

Copy link
Member

commented Jun 2, 2019

I tried bootstrapping on 10.14.6 with this and get a failure:

/sw/bin/fink -y install gettext-bin libgettext8-dev libiconv-dev libncurses5
Use 'fink reinstall fink' to switch distributions
from 10.14.5 to 10.14.
'install' operation not permitted.
### execution of /tmp/fink.4nAiX failed, exit code 29
phase compiling: dpkg-1.10.21-1248 failed
@nieder

This comment has been minimized.

Copy link
Member Author

commented Jun 2, 2019

@mrvacbob was this a fresh bootstrap, or an update of an existing install?

@mrvacbob

This comment has been minimized.

Copy link
Member

commented Jun 2, 2019

This is a fresh bootstrap from the nieder-5.18.4-bootstrap branch on 18G29g.

@nieder

This comment has been minimized.

Copy link
Member Author

commented Jun 3, 2019

What does 10.14.6 report with uname -a ?

@mrvacbob

This comment has been minimized.

Copy link
Member

commented Jun 3, 2019

Darwin asimac.local 18.6.0 Darwin Kernel Version 18.6.0: Tue May 7 22:54:55 PDT 2019; root:xnu-4903.270.19.100.1~2/RELEASE_X86_64 x86_64

@akhansen

This comment has been minimized.

Copy link
Member

commented Jun 3, 2019

@mrvacbob, @nieder, that's probably due to what @PovlAbrahamsen noted above, because when the tests fail they fall through to 10.14 instead of 10.14.5.

@nieder

This comment has been minimized.

Copy link
Member Author

commented Jun 4, 2019

648179b should take care of unreleased versions accidentally falling back to Dist: 10.14 and not 10.14.5.

However, I think line 260 in Engine.pm needs to be tweaked because I think I hardcoded it to only work as intended when 10.14.5 (distribution field) == 10.14.5 (os version). And I don't know enough perl to grok the versions correctly as version numbers and not as strings or decimals.

@akhansen

This comment has been minimized.

Copy link
Member

commented Jun 4, 2019

version->parse() is what is used to convert the strings/decimals into version strings.

@nieder

This comment has been minimized.

Copy link
Member Author

commented Jun 5, 2019

That conditional is driving me nuts.
Don't do an upgrade if

  1. $osversion == $distribution (<=10.14 and presumably 10.15 coming up if Apple returns to form), or
  2. if $distribution == 10.14.5, then check if $osversion_long == $distribution.

(2) is meant to catch macOS 10.14.[67...], where $distribution = 10.14.5, but $osversion_long != 10.14.5. And the leading if for (2) is because we normally don't want to compare against $osversion_long, except in the 10.14.5 case.

Does this make sense?

@nieder

This comment has been minimized.

Copy link
Member Author

commented Jun 9, 2019

To update, this worked for me as a both a fresh install (./bootstrap) on 10.14.5 and just tested an upgrade from 0.44.1 (./inject) on 10.14.5.

Not tested on 10.14.6 but I think the pseudocode in m previous comment should work if someone could help with the actual perl code.

@akhansen

This comment has been minimized.

Copy link
Member

commented Jun 9, 2019

I looked at this a bit, but I haven't gotten to the point of actual code yet--I've been doing paid job stuff over the weekend.

Merge pull request #193 from PovlAbrahamsen/nieder-5.18.4-bootstrap
Changes to Engine.pm to allow upgrades to 10.14.5 distribution
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.